Unable to boot live USB

Hey, I've been trying to install manjaro to potentially use as my main OS, but every time I try to boot the live USB it stops at "Starting Load/Save RF Kill Switch Status".

Things I've tried:

  • Rufus 2.18 and 3.10, in both ISO and DD mode
  • ImageWriter
  • BalenaEtcher
  • 3 different USBs, each used multiple times with each writer.
  • Manjaro KDE and Architect (Multiple Downloads, Multiple times written, 3 USBs, all writers)
  • both nonfree and free drivers

Computer Info:
Ryzen 2700
RX 5700 (With 5700XT BIOS)
ASUS Prime B350-Plus Motherboard
Corsair Vengeance RAM (2x8GB @ 2733 MHz)

I've been able to use, and have had installed both Ubuntu and Parrot Security on my computer before, but I'm kind of at my wits end trying to troubleshoot the exact same issue for hours.

Bump? Re-tried everything with the May 11th update, removed my bluetooth and WiFi cards in case that had something to do with it freezing up on rfkill, everything to no avail.

Have you checked the ISO checksum. Sounds like a bad download.

using QuickHash on Windows 10 the hash matches the one on the download page.

Hey, I've been trying to install manjaro to potentially use as my main OS, but every time I try to boot the live USB it stops at "Starting Load/Save RF Kill Switch Status".

Things I've tried:

  • Rufus 2.18 and 3.10, in both ISO and DD mode
  • ImageWriter
  • BalenaEtcher
  • 4 different USBs, each used multiple times with each writer.
  • Manjaro KDE, GNOME and Architect (Multiple Downloads, Multiple times written, 4 USBs, all writers)
  • both nonfree and free drivers
  • Updating my BIOS
  • Disabling Secure Boot

Verified all the ISO files with QuickHash on Windows 10

Computer Info:
Ryzen 2700
RX 5700 (With 5700XT BIOS)
ASUS Prime B350-Plus Motherboard
Corsair Vengeance RAM (2x8GB @ 2733 MHz)

I've used both Ubuntu and Parrot Security on my computer in the past, but I'm kind of at my wits end trying to troubleshoot the exact same issue for hours.

Use the ventoy project - it is available from the repo.

sudo pacman -Syu ventoy

If you are on Windows - it works too - download from

While in live media, before boot, edit GRUB by pressing e and add instead of quiet this systemd.mask=tlp.service then press F10 to save and continue booting.

Got some extra lines after the rf kill switch line saying "kvm: disabled by bios" but otherwise no change, stops at the same point.

Tried ventoy and while I do actually like it quite a bit since I can load multiple ISOs on it, no change in live USB halting at save/load RF kill switch.

Additionally, I'm actually able to boot pop!_os on a USB with or without ventoy, so other distros still work.

This guy had the same problem, and it turned out to be the kernel:

Worth a try, if there's a Manjaro rc with a different one.

VT-x and VT-d are disabled in BIOS by default, on some motherboards. Try enabling them in BIOS settings and see if that changes things for you. I would go and check also if there is a newer version too.

Not sure if I'm just looking in the wrong spots, but I couldn't find any later development versions, I might just be blind but they did just release a new version yesterday.

While I don't have VT-x or VT-d, my virtualization was off, turned it on and it still halts at the same line, just doesn't have the "kvm: disabled by bios" lines anymore.

So after essentially giving up on manjaro I began trying out different distros to varying degrees of success, with all of them having different issues related to the kernel. I finally found the answer in my question.

Apparently the linux kernel REALLY doesn't like flashed cards or something, because despite never encountering any issues whatsoever with the flashed BIOS, the second I reverted to my card's original BIOS all the issues with all distros vanished.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by