Unable to boot Manjaro, fix or re-install the Grub Boot loader

No, just install GRUB onto your SSD so you can boot from the internal disk.

After a fresh install, with only the SSD plugged in, I am getting on boot an error message "Invalid Partition Table!", hitting any key brings up the GRUB Boot Loader with Manjaro on it.

I tried installing Elementary OS, same settings (erase disk), no other change. I am not getting the error message and Elementary boots without a problem.

So to sum it up, without the backup HDD plugged in, Manjaro gives the aforementioned error message but boots, whereas Elementary does not show any error messages and boots without showing the boot loader first. (just to make it clear, I prefer Manjaro over Elementary)

Is your Laptop with UEFI and you set it to boot in Legacy? If so, put it back in UEFI, disable secure boot / fast boot, and install Manjaro following this.

If is a Laptop with Legacy Bios, make sure you not only erase the partition.

  1. Select manual partitioning:
  2. Create a new partition table from the bottom of the page.


  1. Select the Free Space that comes in that tab and click Create on the bottom of the page. You will only have to pay attention and select this:

  2. Click Next and you will see that the boot loader is installing:
    your SSD.

Create a new partition table prior to installation (use GParted, it's on the disk).

If you only ever boot in BIOS/legacy mode, create an MBR partition table. If you boot in UEFI mode, create a GPT partition table.

1 Like

Thank you guys for the help. I will try again tomorrow and report back...

Nevertheless, the basic instructions are the same for single boot.

For problems, you need to get system info with some commands. Follow this tutorial for an idea.

I followed bogdancovaciu's instructions and jonathon's. Meaning I first tried an install with formatting the ssd first, using gparted. Then I ran the installer with Bogdan's instructions.

Both result in the same sequence of events: laptop boots, I am getting now two (!) "Invalid Partition Table!" messages and then GRUB appears with the option to log in to Manjaro. No other OS's are displayed (as they should not be).

Right now I feel contempt to just live with the stupid error messages and move on... I don't think I have the knowledge to identify (let alone fix!) the problem...

(as they should not be) or (as they should be)? Do you have other OS's?
Confirm uefi or bios-legacy.
Provide (print) from terminal output

sudo parted -l
pacman -Ss grub | grep installed
findmnt -s

There is no other OS installed.

So in my BIOS settings I have the option to either select UEFI or Legacy boot. I assume that means my system is UEFI?

I have set it to Legacy, Fast and Secure Boot off, installed Manjaro without any issues, using a MBR partition table (erase disk option).

The output you requested is as follows:

Model: ATA M4-CT256M4SSD2 (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 238GB 238GB primary ext4
2 238GB 256GB 18,4GB primary linux-swap(v1)

Model: ATA ST9750420AS (scsi)
Disk /dev/sdb: 750GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 750GB 750GB primary ntfs

core/grub 2.03.0-9 [installed]

/ UUID=430f2b23-a9bf-454f-af6e-a387a8f6f1eb ext4 defaults,noatime,discard
swap UUID=393dca21-b599-485d-8264-822da32c1a49 swap defaults,noatime,discard
/tmp tmpfs tmpfs defaults,noatime,mode=17
none /swapfile swap defaults

EFI variables are not supported on this system.

You have both swap and swapfile in your fstab.
Do 2 things and see if the error messages still appear.

  1. Comment out the swap file entry in fstab
    Oh, since you're at it, check if 393dca21-b599-485d-8264-822da32c1a49 is indeed the UUID of sda2 with 'sudo blkid'
  2. At terminal
parted /dev/sda set 1 boot on

Good luck.

Ok I edited fstab and put a '#' before the swap file entry and I also checked the UUID, it is correct.

I entered the comment in the terminal and I am now rebooting

I am now receiving only one Invalid Partition error...

I am calling that progress :smiley:

1 Like

So comment out the other swap.... Just kidding.

Now check /etc/default/grub and see if the resume=UUID=xxxxxxxxxxx of some GRUB_LINUX line correspond. Sorry, should have ask you to do this the first time.

If it correspond, check /etc/mkinitcpio.conf HOOKS line and see if 'resume' is there.
Even if all looks okay. try doing the 2 things below and see if there's still any error message left

sudo mkinitcpio -P
sudo update-grub


1 Like



This is what I have in those two files.

Is there something I need to do with those files, or should I just run the two commands in a terminal?

Then yes, do the 2 commands anyway.

sudo mkinitcpio -P
sudo update-grub

All done, rebooting and reporting back

Unfortunately I am getting the same error...

Okay. No idea now. Sorry.
If I think of something, I'll alert you.

Thanks for the help anyway!

1 Like

One more thing to try. Let's not use udev in mkinitcpio.
So change HOOKS line to

HOOKS="base systemd autodetect modconf block keyboard keymap filesystems"

Note 'udev' is no longer there, and we don't need 'resume' but it will use 'swap' as defined in fstab.
No need either for 'fsck' but systemd will do fsck on its own too.
But we will need a 'systemd' there.
The sequence is important. Use as above.

After changing HOOKS line, we will need to do

sudo mkinitcpio -P

No other command needed.
No need to change /etc/default/grub and no need for 'update-grub'

Doing all that now and will report back after a reboot

Same "Invalid Partition Table!" error but now, after selecting Manjaro from the GRUB menu, I am getting a wall of text before the login screen. Other than that, no change, although it feels like it's taking a bit more time to get to the log in screen now

Forum kindly sponsored by