Unable to boot Manjaro

I was dual booting Manjaro and Windows and decided to install Arch in a separate partition. After installing Arch, I lost Windows in Grub menu and I am no longer able to boot in Manjaro.

This is the error I am getting.

Is it possible that you need to regenerate your Grub? I don't know how different Arch Grub and Manjaro Grub configs are, but It's possible that you need something that's in the Manjaro configs to correctly boot Manjaro.

You should use manjaro grub, other distros have trouble booting it because of intel ucode.

Is this uefi or legacy? In uefi just change boot order to use manjaro grub. If legacy, boot into arch, install arch-install-scripts, chroot into manjaro with arch-chroot and reinstall grub from there.

I reinstalled manjaro GRUB using chroot. Now there is no manjaro in Grub menu,
How do I update grub menu to include Manjaro and Windows ?

Edit : After updating the grub menu, I still get the same error.

Ok I Nailed it down. I think the problem is with the intelucode image. I don't know how to fix it. Any help would be appreciated.

Edit:Solved it !! Restore Manjaro Boot

1 Like

For future readers, I just wanted to link this other tutorial here as well (also thanks to gohlip for making it), since you don't always need a grub rescue cd.
It contains the above link to how to make the grub rescue cd if needed and also how to make another distro's bootloader able to load Manjaro.

Restore Manjaro Boot


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by