Unable to connect to wifi after suspend mode

maybe ditch networkmanager for now and use wicd to check.

Well, I still hope that there will be a fix at some point. :slight_smile: Is there a bug report for this issue btw?

how can i downgrade it ?

@maitrikarunar Just use the downgrade command followed by the name of the desired package - "downgrade networkmanager" does the trick in your case. Perhaps the wiki page about downgrading might help as well.

well i tried it several time and it works, i do edit connection, delete the wifi that stuck, and then log out, login again and connect to wifi again, and got my connection back. my laptop is x220.

networkmanager 1.4.4-1 is in Testing and working well :slight_smile:

2 Likes

it solved the problem of reconnecting, but it random disconnect .... am i the only one ?

Maybe - random disconnects were not one of my symptoms. You might want to start a new thread including some system info and what youre experiencing so we can take a look :wink:

Start a new thread, supply all the relevant information - your problem may be different, no idea on your hardware....................

^^^ what cscs said, typed my reply got busy, forgot to press reply!!!

1.4.4 seems to have solved the issue for me, either!

interesting. i've experienced this issue a few times. my fix has been switching to a different kernel or just waiting for an update. from my experience upgrades have both fixed or caused this behavior again. it happens.

i am happy to say the current 44 kernel has been working just fine for me. no problems with wifi after coming back from suspend. :raised_hands:

btw, sometimes if you run "sudo ifconfig wlp12s0 up" (substitute wlp12s0 with your network interface), wifi will come back.

¯\_(ツ)_/¯

It's always complicated. Just ditched broadcom-wl in favour of stock b43, not even sure whose fault.

1 Like

Yes, this works, but not always :frowning: I hope better update later. I have the same network card as Bob1234

I have Dell Inspiron laptop with 4.7.10-1-MANJARO and every time the laptop returns from sleep mode it cannot connect to wifi asking me to enter a password. This issue has been like forever on my machine and I never bothered to try and fix it. Looks like classic "linux" network card problem which is only fixed by the tide of time :slight_smile:

Isn't 4.7 unsupported for several months already? Did you try a newer kernel or an LTS kernel like 4.4?

For a year I had no wifi after suspend (card stopped working) so I learned to live without suspending and set my lid to turn off screen instead suspend.
However, with some updates and kernel switch to newer version it got fixed. I don't know exactly when but when I tried it couple months ago, everything was ok.

This thread is almost 2 years old and this issue is still occurring. This can be resolved by writing systemd suspend/resume unit files.

See:

Surface Pro 1796 Wifi not resuming after suspend

In some cases restarting network manager and lowering/raising the adapter may also be required for a full working solution. Downgrading may be an easier solution, but partial upgrades are not officially supported on Arch based systems.

I was able to figure this out. I have had the same problem (wifi and Bluetooth disabled after suspended) while I was in ubuntu and later when I moved to manjaro the problem was still there. I tried a lot of solution but none of them worked. One solution which worked for me is to make a change in "GRUB_CMDLINE_LINUX_DEFAULT=" in grub file. Follow the following steps :wink:

  1. sudo nano /etc/default/grub. Create a backup in case if any thing goes wrong

  2. Now you will see the grub configuration.

  3. The trick here is to override the configuration for GRUB_CMDLINE_LINUX_DEFAULT. Look for the GRUB_CMDLINE_LINUX_DEFAULT in the file. it should look like following
    GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor resume=UUID=471d5ddd-298e-4f20-bd1c-e1a264f5af42 udev.log_priority=3"
    ** Note: UUID is different for every computer (Copy the UUID value which will be required in next step. I think this has something to do with hibernation)

  4. Add the following line at the end :
    GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=! acpi_osi='Windows 2009' quiet resume=UUID=YOURUUID splash"

  5. Here replace YOURUUID with the copied UUID.

  6. Now save the file and run sudo update-grub.

  7. This will also work for ubuntu (tested) remove the 'resume=UUID=YOURUUID' if you are on ubuntu.

  8. I am also attaching the forum link from where I found the soln. https://askubuntu.com/questions/1043547/wifi-hard-blocked-after-suspend-in-ubuntu-on-gs65/1058248#1058248

  9. Let me know If this works.

Below are the output of inxi -Fx.

System: Host: vikash-manjaro Kernel: 5.4.40-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: KDE Plasma 5.18.5
Distro: Manjaro Linux
Machine: Type: Laptop System: Hewlett-Packard product: HP Pavilion Notebook v: Type1ProductConfigId serial:
Mobo: Hewlett-Packard model: 8096 v: 89.33 serial: UEFI: Insyde v: F.91 date: 08/20/2019
Battery: ID-1: BAT0 charge: 0% condition: 0.9/0.9 Wh (100%) model: Hewlett-Packard Primary status: Charging

CPU: Topology: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP arch: Broadwell rev: 4 L2 cache: 3072 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 17606
Speed: 801 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 801 2: 800 3: 800 4: 802
Graphics: Device-1: Intel HD Graphics 5500 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0
Device-2: NVIDIA GM108M [GeForce 940M] vendor: Hewlett-Packard driver: nouveau v: kernel bus ID: 0a:00.0
Display: x11 server: X.Org 1.20.8 driver: intel,nouveau unloaded: modesetting resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 20.0.6 direct render: Yes
Audio: Device-1: Intel Broadwell-U Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:03.0
Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
bus ID: 00:1b.0
Sound Server: ALSA v: k5.4.40-1-MANJARO
Network: Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Hewlett-Packard driver: rtl8723be v: kernel
port: 5000 bus ID: 08:00.0
IF: wlo1 state: up mac: 70:77:81:2f:f2:e7
Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000
bus ID: 09:00.0
IF: eno1 state: down mac: 3c:a8:2a:a9:db:b1
Drives: Local Storage: total: 1.13 TiB used: 52.64 GiB (4.6%)
ID-1: /dev/sda vendor: Kingston model: SA400S37240G size: 223.57 GiB
ID-2: /dev/sdb vendor: HGST (Hitachi) model: HTS541010A9E680 size: 931.51 GiB
Partition: ID-1: / size: 37.46 GiB used: 20.17 GiB (53.8%) fs: ext4 dev: /dev/sda6
ID-2: /home size: 48.28 GiB used: 32.36 GiB (67.0%) fs: ext4 dev: /dev/sda9
ID-3: swap-1 size: 3.91 GiB used: 117.4 MiB (2.9%) fs: swap dev: /dev/sda7
Sensors: System Temperatures: cpu: 51.0 C mobo: N/A gpu: nouveau temp: 49 C
Fan Speeds (RPM): N/A
Info: Processes: 257 Uptime: 1h 28m Memory: 11.63 GiB used: 1.96 GiB (16.9%) Init: systemd Compilers: gcc: 9.3.0
Shell: bash v: 5.0.16 inxi: 3.0.37

While grub boot parameters may have worked for you (and that's great), it's not a fix that necessarily works for most others that don't have your hardware.

This thread is 4 years old and necrobumping is frowned upon on the forum. I think it's about time this thread was put to sleep permanently. There are tons of threads about wifi suspension issues that are current. There is no need to revive a thread from when this forum was first created to discuss this subject.

Can a mod please close this thread.

Forum kindly sponsored by