Unable to flash a Install USB

Hi, I have followed the instructions listed on the website, I installed Rufus (3.11), downloaded the GNOME Manjaro iso from the website, inserted a USB and tried to start. I am not being given the option for DD mode within Rufus, the Rufus team says the option is still (https://github.com/pbatard/rufus/issues/1148) in there and I am wondering if anyone else has this issue. Is this iso definately a ISOHybrid?

I am currently using a Windows 10 machine (still trying out linux and getting feet wet) info listed below, please ask if you need more info. Thanks in advance for the help

Rufus - 3.11
Windows 10 Pro - Version 2004
Sandisk Cruzer Blade 16GB

Hello and welcome,

Did you check all advanced options with Rufus? Did the ISO actually burn on USB, did you test to boot it? Did you check the ISO before all that?
Have you tried BalenaEtcher ?

1 Like

Hi!
If rufus doesn't work, you could try with ventoy, I'm use it without any problems.

:speaking_head: VENTOY

Rufus's advanced options have no options for DD mode. It says it burns (successfully) but doesn't boot. I've tried balenaEtcher and it always fails with checksum did not match.

I will try Ventoy and get back to you :slight_smile:

Ventoy doesn't seem to want to install, thinking I might have a dodgy USB stick now after all this flashing and formatting :S :confused:

Does VENTOY require a particular format before trying to install?

No. It will make two partitions, one for the bootloader and one for the iso's and format them.

The following is an example of how the partitions could look like


Disk /dev/sdc: 14.54 GiB, 15597568000 bytes, 30464000 sectors
Disk model: Cruzer Blade    
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x9f2f0556

Device     Boot    Start      End  Sectors  Size Id Type
/dev/sdc1           2048 30398463 30396416 14.5G  7 HPFS/NTFS/exFAT
/dev/sdc2  *    30398464 30463999    65536   32M ef EFI (FAT-12/16/32)

When Rufus detects a Manjaro ISO, it uses DD mode by default. That's why there is no choice.

1 Like

You can't go wrong with rufus.

I think the issue is with your pc. Try booting legacy CSM do not install though. Try disabling secure boot as well.

Forum kindly sponsored by