Unable to install Manjaro 17.0.1 KDE - Boost.Python-Fehler in Job "bootloader"

Wait so that means it works now???

If so, don't forget to mark my post as a solution! :kissing_closed_eyes:
It help my journey to the sacred badge

And follow @gohlip advice above me...

Whoa why did you deleted rw??? shouldn't it be just quiet instead? But hey who I am to judge, at least it works for you...

Hmm I just restarted and now I am stuck again and it says:

Manjaro Linux wird gebootet

Loading Linux 4.9.20-1-MANJARO x64 ...
Loading initial ramdisk ...

Then you need to delete quiet and rw again as the changes are only temporarily....

Okay can I save that somehow?
I would be nice if I do not have to edit it all the time

You can edit in /etc/default/grub using any editor with root.

When you done run sudo update-grub

Okay I just deleted "quiet". Lets see if it works :wink:

Just checked the grub config.
The quiet is gone but rw is still there. I did not see it in the grub file.
What do I have to change to remove the rw?

My Grub file:

GNU nano 2.7.5 Datei: /etc/default/grub


If you want to enable the save default function, uncomment the following

line, and set GRUB_DEFAULT to saved.


Preload both GPT and MBR modules so that they are not missed

GRUB_PRELOAD_MODULES="part_gpt part_msdos"

Uncomment to enable Hidden Menu, and optionally hide the timeout count


Uncomment to use basic console


Uncomment to disable graphical terminal


The resolution used on graphical terminal

note that you can use only modes which your graphic card supports via VBE

you can see them in real GRUB with the command `vbeinfo'


Uncomment to allow the kernel use the same resolution used by grub


Uncomment if you want GRUB to pass to the Linux kernel the old parameter

format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"


Uncomment to disable generation of recovery mode menu entries


Uncomment and set to the desired menu colors. Used by normal and wallpaper

modes only. Entries specified as foreground/background.


Uncomment one of them for the gfx desired, a image background or a gfxtheme


Uncomment to get a beep at GRUB start

#GRUB_INIT_TUNE="480 440 1"

because it is located in /boot/grub/grub.cfg and I think you shouldn't really delete or change that .......

Anyway see this

Hmm okay but with the rw I am not able to boot. What should I do then?

You could try to delete it (the rw not the file) or change it to ro(don't change it to ro! I was wrong!!!!)

Can you run fsck in the meantime? ( I think you may need to add sudo before it)

excuse me again. 'rw' is the right one for manjaro. not 'ro'. And we must have the 'rw' in the linux line.
'ro' is the right one for ubuntu and debian, not arch or manjaro.

But suggest we use 'configfile' so we do not mistype our kernels and miss out 'rw' or '.img' in initramfs.img.
It's easier anyway.

1 Like

fsck von util-linux 2.29.2
e2fsck 1.43.4 (31-Jan-2017)
/dev/sdb6 ist eingehängt.
e2fsck: Fortsetzung nicht möglich, wird abgebrochen.

@gohlip but why am I not able to boot if rw is in the line? When I deleted rw in the grub temporay config I was able to boot.

I think you need to run it in your live usb, cause your /dev/sdb6 is still mounted (you could try to unmount it before it, but I don't think is advised).....

Okay then I will boot the livecd.

I also just ran:

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --boot-directory=/boot --recheck --debug

grub-install: Info: copying /boot/grub/x86_64-efi/core.efi' -> /boot/efi/EFI/Manjaro/grubx64.efi'. grub-install: Info: Registering with EFI: distributor = Manjaro', path = \EFI\Manjaro\grubx64.efi', ESP at hostdisk//dev/sdb,gpt8. grub-install: Info: executing efibootmgr --version </dev/null >/dev/null. grub-install: Info: executing modprobe -q efivars. grub-install: Info: executing efibootmgr -b 0001 -B. BootCurrent: 0001 Timeout: 1 seconds BootOrder: 0002,0000,0003,0004 Boot0000* ubuntu Boot0002* Hard Drive Boot0003* ubuntu Boot0004* ubuntu grub-install: Info: executing efibootmgr -c -d /dev/sdb -p 8 -w -L Manjaro -l \EFI\Manjaro\grubx64.efi. BootCurrent: 0001 Timeout: 1 seconds BootOrder: 0001,0002,0000,0003,0004 Boot0000* ubuntu Boot0002* Hard Drive Boot0003* ubuntu Boot0004* ubuntu Boot0001* Manjaro installation beendet. Keine Fehler aufgetreten.

It will give an error message something like "the filesystem is not configured properly" It the past, it won't boot, but if it boots now, it is still not a good thing. Let's do the right thing. But good you asked.

From the livecd? No! It won't work this way.

1 Like

Help me on this one @gohlip, I'm not really good at this

Okay I think I solved it.

On this harddrive where I just installed Manjaro I have also installed Linux Mint KDE and Linux Mint Cinnamon.
I always booted I selected in my bios "ubuntu ...". In there I seleced Manjaro.

But as I just wanted to boot the livecd I saw that Manjaro has an own listitem in the Bios. And I was able to start it without configuring it :wink:

In this config I just added quiet and manjaro still starts :wink:

1 Like

You're alright. You've done a few right things past one week. Please continue to help. I'm quite impressed.

Right. Now [quote="gohlip, post:6, topic:25073, full:true"]
Try this.

Try first the configfile and then the chainload, if your grub.cfg is messed up.
When booted up . check that your fstab has the correction as noted..[quote="gohlip, post:14, topic:25073"]
You also need to change mount point to /boot/efi , to something like this.

UUID=xxxxxxxxxxx /boot/efi vfat defaults,noatime 0 2

And if it has not been fixed prior to this..do this...[quote="gohlip, post:14, topic:25073"]
Then (where /dev/sdxy is your /boot/efi)

sudo mount /dev/sdxy /boot/efi
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --boot-directory=/boot --recheck --debug

If it had been fixed, verfy with

findmt /boot/efi

and do only the 'grub-install' command.

Good luck,


Okay I just created the default grub with /etc/default/grub and sudo update-grub with the "quiet".
When I select Manjaro in the bios to boot everything works :wink:
The problem was that I selected the grub from Linux mint. But somehow I was able to select Manjaro in the Linux mint grub.

Thanks a lot to both of you :wink:

Have a nice day :slight_smile:

You really should have said this much earlier.
You can then just select the Manjaro boot from F10.
Really. :confounded:


Forum kindly sponsored by