Unable to install Manjaro 17.0.1 KDE - Boost.Python-Fehler in Job "bootloader"

Hello, I tried to install Manjaro 17.0.1 KDE but it always occurs an error during the installation.

On this PC is also a Windows 10 installation so I did the partitioning by my own.
I selected a 50gb "ext 4" partion for / (root)
128 mb "FAT32" for /boot/efi
and 100 gb "ext 4" for /home.

How can I solve this error?

Thanks a lot

I think this happen because your /boot/efi is too small... You need to add more "size" to it......

How big should it be?
But I installed quite a few different distros this way and it always worked.

I'm not sure.... try 300 MB ?

Nevermind... After searching in this forum I found that this is calamares bug ....
Can you try this? ( Click on the arrow or the link for full info)

Try this.

Thank you. The installation worked :wink:
I also changed the /boot/efi partion in fstab from FAT32 to vfat.

But I am unable to boot into manjaro. It is stucks direct in the beginning.
I only see:

Loading Linux 4.9.20-1-MANJARO x64...
Loading initial ramdisk ...

Have you tried the following on the bottom of the post that I gave you...

Yes I edited fstab and changed the Filesystem-Name from "Fat32" to "vfat".

At least can you make it to your grub?

If so can you do this?

Before you select an entry in your boot menu press CTRL+E to edit it. Go to the kernel line linux and remove the word quiet and if there is also, splash. Then when done start your system with CTRL+X to see a more detailed text boot-up. I want to see what happen..


        menuentry 'Manjaro Linux (Kernel: 4.9.26-1-MANJARO x64 - fallback initramfs)' --class manjaro --class gnu-linux --cla$
                set gfxpayload=keep
                insmod gzio
                insmod part_msdos
                insmod ext2
                set root='hd0,msdos6'
                if [ x$feature_platform_search_hint = xy ]; then
                  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos6 --hint-efi=hd0,msdos6 --hint-baremetal=ahci0$
                  search --no-floppy --fs-uuid --set=root fcd883f2-5d60-4b71-9d17-1a24e210d2b6
                echo    'Linux 4.9.26-1-MANJARO x64 wird geladen …'
                linux   /boot/vmlinuz-4.9-x86_64 root=UUID=fcd883f2-5d60-4b71-9d17-1a24e210d2b6 rw  resume=UUID=6dd17673-7ddb3-7ddb-4fd5-9c83-e3ef0116a872 quiet splash
                echo    'Initiale Ramdisk wird geladen …'
                initrd  /boot/intel-ucode.img /boot/initramfs-4.9-x86_64-fallback.img

liked this.

Or try to follow @gohlip link to see if that works for you....

Please report....Don't leave me hangin' :((((((

Sorry I just got something to eat :wink:
It worked now but I only deleted rw quiet in the row unter "Linux 4.9.26-1 Manjaro wird geladen"

After I deleted it I pressed "Strg+X" and then it showed a lot of text. Then my monitor when black and 1 or 2 seconds later I am in the loginscreen of manjaro

Thank you so much :wink: I would never be able to solve that my own :wink:

I will just check, if I can start it now as usual :wink: Otherwise I will always have to remove rw quiet ^^

You also need to change mount point to /boot/efi , to something like this.

UUID=xxxxxxxxxxx /boot/efi vfat defaults,noatime 0 2

Then (where /dev/sdxy is your /boot/efi)

sudo mount /dev/sdxy /boot/efi
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --boot-directory=/boot --recheck --debug

1 Like

Wait so that means it works now???

If so, don't forget to mark my post as a solution! :kissing_closed_eyes:
It help my journey to the sacred badge

And follow @gohlip advice above me...

Whoa why did you deleted rw??? shouldn't it be just quiet instead? But hey who I am to judge, at least it works for you...

Hmm I just restarted and now I am stuck again and it says:

Manjaro Linux wird gebootet

Loading Linux 4.9.20-1-MANJARO x64 ...
Loading initial ramdisk ...

Then you need to delete quiet and rw again as the changes are only temporarily....

Okay can I save that somehow?
I would be nice if I do not have to edit it all the time

You can edit in /etc/default/grub using any editor with root.

When you done run sudo update-grub

Okay I just deleted "quiet". Lets see if it works :wink:

Just checked the grub config.
The quiet is gone but rw is still there. I did not see it in the grub file.
What do I have to change to remove the rw?

My Grub file:

GNU nano 2.7.5 Datei: /etc/default/grub


If you want to enable the save default function, uncomment the following

line, and set GRUB_DEFAULT to saved.


Preload both GPT and MBR modules so that they are not missed

GRUB_PRELOAD_MODULES="part_gpt part_msdos"

Uncomment to enable Hidden Menu, and optionally hide the timeout count


Uncomment to use basic console


Uncomment to disable graphical terminal


The resolution used on graphical terminal

note that you can use only modes which your graphic card supports via VBE

you can see them in real GRUB with the command `vbeinfo'


Uncomment to allow the kernel use the same resolution used by grub


Uncomment if you want GRUB to pass to the Linux kernel the old parameter

format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"


Uncomment to disable generation of recovery mode menu entries


Uncomment and set to the desired menu colors. Used by normal and wallpaper

modes only. Entries specified as foreground/background.


Uncomment one of them for the gfx desired, a image background or a gfxtheme


Uncomment to get a beep at GRUB start

#GRUB_INIT_TUNE="480 440 1"

Forum kindly sponsored by