Unable to Install Manjaro - Stuck at partitions screen


I'm new to Manjaro distro.
I have been trying to install Manjaro on my old desktop which runs on 4 GB ram and 64 bit dual core Pentium processor(E6600).
I am using a hard disk drive for installation which is of 320GB.
The OS runs fine in live mode but can't install.
I've attached a screenshot of my exact problem. The screen you see in the screenshot is stuck for over 45 minutes.

Please guide me on how can this issue be solved.Screenshot%20from%202018-11-24%2017-27-42

We will need more information to assist you in resolving your issue.

Please post:

inxi -Fxxxz       

Please post the input/outputs of requested commands via the terminal as text, (not as pics).

Information on how to properly post hardware specs and logs on the forum:


It could very well be that your disk has been setup with LVM and the Calamares installer is not good with LVM.

Calamares stalling on the partitioning is often caused by an existing LVM setup.

Did you previously install e.g. Fedora or another distribution defaulting to LVM?

1 Like

When I first used the GUI installer it displayed partition information but I was unable to select a partition for Manjaro and unable to select 'next' to move on. After several botched installs using architect, when I tried Manjaro Deepin from a live USB this screen worked just fine. Possible things I did that may have made the difference:

1 - making sure 'secure boot' mode was off in my BIOS settings
2 - formatting the EFI partition to get rid of the several bootloaders I had accidentally installed
3 - reformatting the main root partition where I intended to install Manjaro

Hope that helps

I don't know why it is stalling.

What I can suggest, is reboot to a live usb then zap the partitions using dd. And by zapping I mean zapping - there is no partition table - no anything when you do it this way.

That also means that you need to be observant and double check the command I am giving you.

First open a terminal and identify your disks - you could get an output like this

$ lsblk
sda      8:0    0 223,6G  0 disk 
├─sda1   8:1    0   300M  0 part /boot/efi
├─sda2   8:2    0   512M  0 part /boot
├─sda3   8:3    0    32G  0 part [SWAP]
└─sda4   8:4    0 190,8G  0 part /
sdb      8:16   1   7.3G  0 disk 
└─sdb1   8:17   1   7.3G  0 part 

It is obvious - I hope - which one is the live media and which one is the system disk.

Replace the letters in the command with the letters representing your system disk

sudo dd if=/dev/zero of=/dev/sdX bs=1M count=10

The command writes 10MiB zeroes to your system disk

Then start the installer.


Make sure your ISO is not corrupted.
Be sure to write the ISO to USB or DVD (USB preferred),
The correct tool or command to do so. If using Rufus, you must use 'DD' mode.
Unetbootin is not supported.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Apologies if I'm disturbing you. I wanted to reach out and say a big thanks for your post about getting past the partition section of the Manjaro Deepin install. I was having the same issue as the original poster. I took your advice about using dd and it worked perfectly.
I'm just an everyday user that prefers to understand and work out the Linux issues I encounter. Is it possible to share with me how you knew to use dd in order to fix the issue so I can better understand Linux? Thanks!

The basics is the file allocation table (FAT)

The FAT exist in various forms and is written in various predefined locations on the disk in question.

When using dd it is possible to write data to specific locations and doing this as referenced in the mentioned post overwrites the first part of the disk with zeroes - effectively removing any reference to the existing FAT.

I appreciate your reply. Thanks for the tip.


Forum kindly sponsored by