Unable to install module acpi_call

I am trying to install optimus-switch=gdm, hoping that it will resolve the issue of non-detected hdmi for an nvidia/intel laptop. However, I am stuck with installing the prerequisites, in particular the acpi_call module. I'd be glad about any advice.

sudo pacman -S linux419-headers acpi_call-dkms xorg-xrandr xf86-video-intel git

I am getting the following error message when installing the acpi_call module. You can find the complete output at the end of this post.

==> Unable to install module acpi_call/1.1.0 for kernel 4.19.108-1-MANJARO: Missing kernel headers.
==> Unable to install module acpi_call/1.1.0 for kernel 4.19.112-1-MANJARO: Missing kernel modules tree.

My system information is as follows:

Operating System: Manjaro Linux 
KDE Plasma Version: 5.18.3
KDE Frameworks Version: 5.67.0
Qt Version: 5.14.1
Kernel Version: 4.19.108-1-MANJARO
OS Type: 64-bit
Processors: 12 × Intel® Core™ i7-9750H CPU @ 2.60GHz
Memory: 31.3 GiB of RAM

Weirdly, while also uname -a shows the 4.19.108 Kernel (Linux HP7550-mark 4.19.108-1-MANJARO #1 SMP Thu Mar 5 20:27:09 UTC 2020 x86_64 GNU/Linux), in the System Settings Manager, the recommended, installed and running Kernel is 4.19.112-1.


sudo pacman -S linux419-headers acpi_call-dkms xorg-xrandr xf86-video-intel git 
warning: linux419-headers-4.19.112-1 is up to date -- reinstalling
warning: acpi_call-dkms-1.1.0-286 is up to date -- reinstalling
warning: xorg-xrandr-1.5.1-1 is up to date -- reinstalling
warning: xf86-video-intel-1:2.99.917+899+gf66d3954-1 is up to date -- reinstalling
warning: git-2.26.0-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (5) acpi_call-dkms-1.1.0-286  git-2.26.0-1  linux419-headers-4.19.112-1
             xf86-video-intel-1:2.99.917+899+gf66d3954-1  xorg-xrandr-1.5.1-1

Total Installed Size:  85.38 MiB
Net Upgrade Size:       0.00 MiB

:: Proceed with installation? [Y/n] y
(5/5) checking keys in keyring                                           [#########################################] 100%
(5/5) checking package integrity                                         [#########################################] 100%
(5/5) loading package files                                              [#########################################] 100%
(5/5) checking for file conflicts                                        [#########################################] 100%
(5/5) checking available disk space                                      [#########################################] 100%
:: Running pre-transaction hooks...
(1/2) Remove DKMS modules
(2/2) Save Linux kernel modules
:: Processing package changes...
(1/5) reinstalling linux419-headers                                      [#########################################] 100%
(2/5) reinstalling acpi_call-dkms                                        [#########################################] 100%
(3/5) reinstalling xorg-xrandr                                           [#########################################] 100%
(4/5) reinstalling xf86-video-intel                                      [#########################################] 100%
(5/5) reinstalling git                                                   [#########################################] 100%
:: Running post-transaction hooks...
(1/6) Creating system user accounts...
(2/6) Reloading system manager configuration...
(3/6) Arming ConditionNeedsUpdate...
(4/6) Updating module dependencies...
(5/6) Install DKMS modules
==> Unable to install module acpi_call/1.1.0 for kernel 4.19.108-1-MANJARO: Missing kernel headers.
==> Unable to install module acpi_call/1.1.0 for kernel 4.19.112-1-MANJARO: Missing kernel modules tree.
(6/6) Restore Linux kernel modules

==> Warning:
         -> Kernel has been updated. Modules of the current kernel
         -> have been backed up so you can continue to use your
         -> computer. However, the new kernel will only work 
         -> at next boot.

Well thats odd. It looks like you have 2 different versions of 4.19 installed.
You should do a full update and restart:

sudo pacman-mirrors -f && sudo pacman -Syyu

And I notice the last note actually mentions it here:

1 Like

Thanks for your reply @mandomanjaro. I ran sudo pacman-mirrors -f && sudo pacman -Syyu and tried to reboot. However, KDE does not start properly anymore. I am at a black screen.

I then followed the first two "things to try" here: Manjaro doesn't boot, boots to a black screen, or stops at a message

No packages needed to be updated for the "first thing to try" (since I had just updated them). The "second thing to try", running startx, gives Error messages (just an excerpt below because I had to type everything):

xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
(II) modeset (GO): Initializing kms color map for depth 24, 8 bpc. 
The KEYBOARD keycap compiler reports:
> Internal error: Could not resolve keys XF86FullScreen
Errors from xkbcomp are not fatal to the X server 

Couldn't exec startkde: No such file or directory 
kinit: connection to X server lost

waiting for X server to shut down .(II) Server terminated successfully (0). Closing log file.

It seems like I partly solved the above issue by setting DEFAULT_SESSION=startplasma-x11 in the .xinitrc file (see boots into tty after tablet driver installation and https://wiki.archlinux.org/index.php/KDE). After doing so and running startx again, I got to boot plasma as usual.

The problem is that the laptop still always boots with black screen. I have to press Cntrl+Alt+F2 and run startx every time to actually boot.

KDE edition uses sddm as login manager and one should not have to invoke startx - is it failing?
Please post output of:

$ systemctl status sddm

and

$ journalctl -xb -p err

@freggel.doe, many thanks for your reply. Then, I should have installed optimus-switch-sddm instead of optimus-switch-gdm?

I have installed optimus-switch-gdm. After a reboot, then setting sudo set-intel.sh and then another reboot, I am now not able to use the laptop keyboard, external keyboard, touchpad or external mouse anymore. I can't even get to tty.

Hence, I am also currently not able to post the outputs that you hinted at (thank you again). But what I can say is that the black-screen boot got resolved all of a sudden after a few reboots without having to invoke startx anymore. I.e. I did not get to a black screen anymore. Instead, I directly got to the usual KDE Plasma Desktop. (This does not change my issue that I am now unable to do use the keyboard etc.)

I created a new issue for this since it does not seem related to the original post title anymore: No external mouse, external keyboard, laptop keyboard, laptop touchpad at boot

Yes, probably.
I'd uninstall optimus-switch-gdm and install optimus-switch-sddm.

Nice, use this opportunity to correct your setup.

2 Likes

@freggel.doe, thanks a lot for your advice. optimus-swtich-sddm actually worked very well.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by