Unable to install xfce-17.0.1 (grub error)?

File Name: manjaro-xfce-17.0.1-stable-x86_64.iso
SHA1: 5d093986fa0abd54af48ce7912a9a5edfd37dc45
It's same file as stated on download page. Do not tell me to re-download. Also, the same worked on VMWare (host: Windows 10).
What I did:: Tried twice on same machine (don't have another for now). Tried with Ubuntu 16.04 LTS, it works fine
Detailed Description:
Error: Grub error. Unknown file system while booting from USB, and enters grub rescure mode. The iso was burnt using Rufus(v2.15) in UEFI for GPT Mode. I tried with Ubuntu in same mode and I can boot to live environment. If I remember correctly I did the same couple of months back with older iso, and it worked...

plz dont use rufus anymore for manjaro ,
try etcher or isousb

before launching un USB key manjaro ,check all option in bios

1 Like

Open a terminal and use classic dd

sudo dd if=manjaro-xfce-17.0.1-stable-x86_64.iso of=/dev/sdX

sdX is the USB drive. You my find the name via sudo fdisk -l

1 Like

Okay, I figured out. There are other similar questions in the forum....
I'm not sure if I should blame Manjaro team for this but after looking here and there and what actually messed it'd be Manjaro to blame. :expressionless: :expressionless:
In a normal ISO mode on Rufus, the Manjaro grub is modified and Rufus doesn't work with it. The alternative is to use DD mode when it shows both options. Or use DD command via command prompt/powershell/terminal... wherever you live.

I had the same problem.
If anyone else has this issue, here is my process and solution.
I have previously (twice) installed Manjaro from a live USB but for some reason when I tried booting from the USB a third time I didn’t work.
I tried different USBs and even a new ISO download. Also, I have an Ubuntu live USB which works in the Lenovo and I have successfully tested the Manjaro USB in another (desktop) computer.
I used Rufus to make the live USB but tried making the USB with Etcher and it worked.
I don’t know the whys, wheres, whats of how this problem occurred but changing from Rufus (which worked the first two times and was used on the (still functional) Ubuntu USB) to Etcher fixed it.


Forum kindly sponsored by