Unable to install XFCE 19.02 (no connectivity) Architect 19.0 (ignorance)

I've spent several days trying to get Manjaro installed. XFCE 19.02 will see my SSID but not establish a connection. Architect 19.0 will connect but then I get all screwed up in the mounting etc. In the process I've nuked my Windows and just can't seem to get the right combination in mounting, naming etc.

I'd love to go the easier route but set identically to Architect the XFCE ISO will not connect. I installed it and still no luck. Any suggestions? On the partitioning front I have a Dell XPS 15 9570 with UEFI. Architect in automatic wants to create a 4GB partition, a 512MB and the rest of the Disk as another. Root/Boot/Home, which is which? I need this for school so am just trying to get it up quickly as it's now been down for days.

Also have no idea what kernel to try to install if I do get that far on Architect. 4.19? Just pick one? Thanks for any suggestions.

Do I understand correctly you want only Manjaro installed on your computer? If yes did you try option “erase disk” when installing XFCE4.
Also I suggest you to read short manual how to install. It is in live ISO. I used it too. Sorry for pointing you to manual but I think it is well written and helped me answer questions.

This is a good place to find more details about that laptop and how it works on arch based distro:
https://wiki.archlinux.org/index.php/Dell_XPS_15_9570
My suggestion is not to complicate yourself much, and deal with each problem separately. Regarding the install and partitioning i would suggest to go with the default XFCE install and partitioning.

Probably that is the swap partition.

That would be the /boot/efi partition

That would be the root partition, mounted as /
In there you will have the /home too. You can create a separate partition for /home, but for that you have to manually specify it and decide how big it is.

Once you have the system installed, boot from it, and then deal with the wifi part.
See here


and also consider reading from here on

1 Like

I managed to get it installed with Architect. No connectivity with the NIC although I can see the SSID. The only reason I used Architect is that it allowed me to make a connection. I assumed this would carry over after the install but it did not. I installed 4.19 which will boot and I think 4.4 which will not. I didn't want to install the latest thinking that was the issue with the XFCE installer. Anyone know the difference in the Architect installer and the XFCE in regards to connectivity? If I knew that maybe I could get it working. It also installed Afgan for the language which was weird as I'd not asked for that.

IPV6 isn't disabled during the install and it works. I'll try disabling it but I've tried that before without luck. I'll also look at the other suggestions.

1 Like


Disable MAC Address Randomization with the following command:

echo -e "[device]\nwifi.scan-rand-mac-address=no" | sudo tee /etc/NetworkManager/conf.d/disable-random-mac.conf


We need your system specs to offer any detailed advice.

Please post:

inxi -SMa; hwinfo --netcard --bluetooth | grep -Ei "(hotplug|speed|model|status|cmd|file|detected|driver:)" | grep -v "Config S" && echo "System install date $(head -n1 /var/log/pacman.log | cut -d " " -f1 | cut -c 2-11)" 

Do not post pics, use Andoid USB phone tethering for a temporary internet connection to post required terminal outputs.

No help disabling MAC randomization.

System: Host: wonderland Kernel: 4.19.112-1-MANJARO x86_64 bits: 64
parameters: BOOT_IMAGE=/vmlinuz-4.19-x86_64 root=UUID=2c39d534-8cec-4eb1-b690-0f61819f6a60 rw quiet
udev.log_priority=3
Desktop: Xfce 4.14.2 Distro: Manjaro Linux
Machine: Type: Laptop System: Dell product: XPS 15 9570 v: N/A serial:
Mobo: Dell model: 0CNMT3 v: A00 serial: UEFI: Dell v: 1.15.0 date: 12/25/2019
Model: "Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter"
Driver: "ath10k_pci"
Driver Modules: "ath10k_pci"
Device File: wlp58s0
Link detected: yes
Driver Info #0:
Driver Status: ath10k_pci is active
Driver Activation Cmd: "modprobe ath10k_pci"
Model: "Qualcomm Atheros Bluetooth Device"
Hotplug: USB
Driver: "btusb"
Driver Modules: "btusb"
Speed: 12 Mbps
Driver Info #0:
Driver Status: btusb is active
Driver Activation Cmd: "modprobe btusb"
System install date 2020-03-23

I get either dquote> or cat: invalid option -- 'c' when I try that. The last because I put a " at the end to try and get some output. Not sure where it should go. I loaded 4.19 which boots and 4.44 as a backup which does not. I went back because the latest graphical install wouldn't connect. Disabling IPv6 didn't help.

When you say "Rename the /usr/lib/firmware/ath10k/QCA6174/ board-2.bin files: sudo mv /usr/lib/firmware/ath10k/QCA6174/hw2.1/board-2.bin /usr/lib/firmware/ath10k/QCA6174/hw2.1/board-2.bin.bak sudo mv /usr/lib/firmware/ath10k/QCA6174/hw3.0/board-2.bin /usr/lib/firmware/ath10k/QCA6174/hw3.0/board-2.bin.bak Replace /usr/lib/firmw…" I'm assuming I'm to download a replacement after renaming?

Edit: I didn't realize this referred to another post. I completed all the tasks there and it's worse. Whatever the program that you use to connect which sits on the lower panel disappears now when I try to connect a few times. This happens in Kernals 5.5.11-1, 5.4.27.1, 4.9.112.1 and 4.14.217-1. Can't really undo it as I don't know what I did. Interesting that it connects to my phone as a hotspot without issue.

After throwing so many things at it I reinstalled with XFCE 19.02 and started again with no luck.

The thing that seems to make the most sense is Killer Networking Support Article and I've accomplished that twice now. It crashes Network Manager. I've reverted back to the old setup.

I'm pretty much out of ideas after trying everything in every post I can find and coming at this for 6 days now. Does anyone have any other suggestions? If not can someone offer a suggestion on a distro that might work? I tried Debian with the same result and I won't go to Ubuntu due to their in distro advertising. I'd love to stay with Manjaro just can't seem to get the NIC to work. I would consider purchasing a new NIC if anyone has suggestions there but of course I'd rather get it going with the one I already have. Thanks!

This thread is marked as solved. The title and the Newbie sub-forum does not draw eyes to your networking issue.

You would be best to open a dedicated networking help thread in this sub-forum:

https://archived.forum.manjaro.org/c/technical-issues-and-assistance/networking/96

Please post your system specs again and all steps you have taken to resolve your issue. Those who enjoy helping out on networking issues will likely never notice this solved post here in the Newbie forum. A new thread dedicated to your network issue will be far more likely to get you proper assistance.

Thanks. I just ordered a new nic as I'd invested all the time I was willing to into getting it connected.

In the interim I failed to connect to one router of a friend and connected just fine to another. They have crappy passwords so I came home and reduced my password to something a child might use and it worked. So I'm not sure if Manjaro doesn't like lengthy passwords or what. In any case it's solved with the exception that if I can't get it going with a decent password using this nic or the other it won't be acceptable.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by