Unable to load Manjaro KDE from live-usb

The big problem is that I can't boot to the live-usb in uefi mode after accessing the live-usb grub.
So, I manage to enter the live-usb grub options. May be adding an extra line to the booting code.
I already tried: nvidia.modeset=0 (as I have an 1080 nvidia) no luck either. I have to say that I am not completely sure that the boot took into consideration the extra line.

You don't need to create Live USB in UEFI mode.

Repeat all steps again carefully:
1- Make a live USB by Rufus in legacy ISO mode.
2-Full shutdown Windows by holding shift key or using the command: shutdown /s /t 0
3- Boot to the Manjaro live USB.
4- Install Manjaro and its grub.
5- Reboot and pull out the usb. Now you have a UEFI/GPT dual boot on HDD.

I made the live USB by rufus in legacy ISO mode.
the USB boot did not work, grub didn´t load entering the "grub-rescue".

I made the live USB by rufus in legacy dd mode.
The USB booted just fine, entering the USB grub menu perfectly.
Here again, I couldn´t boot Manjaro: dark screen

I think the problem is not the creation of the live USB but the USB manjaro booting sequence, or a conflicting booting command or something.

As input:
I accessed the grub booting command options by tapping "e" when cursor over the booting option in the grub. There there is a command line with several options: language, keyboard, drivers.

Among those options there is written "quiet" to avoid having verbose when booting. I deleted it and tried to make the computer tell me at which step the booting stopped. I got again the dark screen.

I am starting to think that there is a problem with Manjaro when booting in UEFI with my hardware. may be my video card or something.
I have tried adding "nomodeset" "nvidia.modeset=0" setting all *.modeset to 0 adding "grup_gfxmode=1280x1024x24"
Truth is: I don´t really know what those mean. But I got same result: dead black screen

So I will specify the important hardware I am using: (HP Omen X laptop)

24 GB DDR4-2400 SDRAM (1 x 8 GB, 1 x 16 GB)
1 TB 7200 rpm SATA (ntfs data+swap);
256 GB PCIe® NVMe™ M.2 SSD (ntfs windows 10) UEFI boot
256GB PCIe NVMe M.2 SSD (Empty for Manjaro)
Intel® Core™ i7-7700HQ (2.8 GHz, up to 3.8 GHz, 6 MB cache, 4 cores)
NVIDIA® GeForce® GTX 1080 (8 GB GDDR5X dedicated)
LCD 17.3 FHD AG LED UWVA flatfGSync144Hz

I have an idea to solve the problem! But I need to know if it is possible:
I can boot the Manjaro live-usb in legacy mode.
And install Manjaro in UEFI mode in the hard drive.
Is it possible? How can we do it?

hi tkh,
Please, take a look at this post.
These guys solved many issues you have mentioned.
Hope it help you.

Do you have any other OS in your system?
Is that OS in uefi or bios-legacy?
Is your disk gpt or msdos partitioned?

Provide output of 'sudo parted -l' while in livecd terminal.

Hello, J8a,
Thank you very much for sharing this post. :slight_smile:
Still got some problems.
I will detail them in the next reply while answering Gohlip.

Hi Gohlip,

I already saw your "Using livecd v17.0.1 as grub to boot OS with broken bootloader" post that j8a proposed.
But let´s start answering the questions you made:

-I have Windows 10 pre-installed in a 256GB SSD.
-It is the OS I am using right now. This OS is in UEFI mode.
-This Windows SSD is GPT partitioned.

I want to install Manjaro in a separate 256SSD. Which is already GPT partitioned and ready to receive the new OS.

So, I followed the post instructions:

  • "c" to access the grub>
  • I verified the grub> echo $grub_platform it was indeed EFI
  • grub> search.file /etc/manjaro-release root
  • grub> configfile/boot/grub/grub.cfg

I came back to the Manjaro menu and tried to start ''Manjaro Linux".
I got:

Booting 'Manjaro Linux'
error: file '/boot/grub/grubenv' not found.
Loading Linux 4.14.52-1-MANJARO x64 ...
Loading initial ramdisk...

Press any key to continue...

And it freezes at this step. I waited 5 minutes after pressing any key.
I had to turn off by pressing the on/off button

Yes, if you cannot boot in uefi, do that in bios-legacy.
And.... information of all disks. Do not omit any disk.

And check this and confirm your windows is uefi or bios-legacy.

I confirm, Windows is in UEFI.
I booted Manjaro live-usb in Legacy mode. and ran the command:

$ sudo parted-l

The output is:

Model: ATA ST1000LM049-2GH1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 955GB 955GB ntfs Basic data partition msftdata
2 955GB 969GB 13.8GB ntfs Basic data partition hidden, msftdata
3 969GB 1000GB 31.1GB linux-swap(v1)

Model: Kingston DT 101 II (scsi)
Disk /dev/sdb: 4031MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 32.8kB 2167MB 2167MB primary boot
2 2167MB 2171MB 4194kB primary esp

Model: Unknown (unknown)
Disk /dev/nvme0n1: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags

Model: Unknown (unknown)
Disk /dev/nvme1n1: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 274MB 273MB fat32 EFI system partition boot, esp
2 274MB 290MB 16.8MB Microsoft reserved partition msftres
3 290MB 255GB 255GB ntfs Basic data partition msftdata
4 255GB 256GB 1028MB ntfs Basic data partition hidden, diag

Your manjaro can only be here.
See the problem now?
You just cannot have a uefi OS in an msdos partitioned disk.
and where is your root partition? Missing?

1 Like

Well, This volume is the live-USB made with rufus.

And where are you going to install Manjaro.
Not just booting up livecd. Or is that all you want to do?

I want to have a dual boot, with both operating systems installed in different hard drives.

I want to install Manjaro in:

Model: Unknown (unknown)
Disk /dev/nvme0n1: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags

Okay. That link that was referred to you was for an installed OS that couldn't boot.
Not for booting a livecd.

The method you oulined later on... configfile......etc. won't work. There is no grub.cfg to boot into.

As to the problem specifically not booting into a livecd..Others will have to help out.
(I don't use usb livecd to boot and install most of my OS's)

Sorry that the link (and I here) have wasted you time.
But if I can think of anything else, I'll be back.
ps: it's late here and I need to sleep.

So good luck, hope others here can help you on it.
Others.......please help out. Thanks (to others).

Oh... check if your HP is tied in with microsoft and won't boot non-microsoft keys.
@AgentS ? (thanks) good night. glad the fire didn't get to you.


Possible. If your HP model is not tied in with microsoft.
Make partitions ready before installation.
Create and format to ext4.
When installed, install some packages to it like efibootmgr, mtools, dosfstools and grub-efi (or something like that, search for it) and grub-install using target.
make fstab entry for $esp
then mount $esp as /boot/efi
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --boot-directory=/boot --recheck --debug

You can try. ...

ps: I did not read topic earlier as it was about live-usb.
Until I was notified when my link was referred to.

-I will first check if my HP is not tied with microsoft. It should be an option in BIOS right?

-then I will try to boot live-USB a last time in UEFI, if it works.. well I will continue the installation. If it doesn' t I will boot live-USB in Legacy and install Manjaro installing the packages to transform the installation to UEFI.

PS. I thank you very much for the help. I will be asking questions in the future if needed.

Not really, this is just assumed after several conflicts are observed.

Not a real option AFAIK. You can't transform as you suspect.

You have to boot your USB ISO in UEFI mode to install in UEFI mode. Thus you have to look for this option, or a way to make this happen in your UEFI/BIOS. You may check for a BIOS update, if there is one.
IIRC BIOS has two boot entries for each extUSB drive, Legacy/DOS and UEFI.
Another workaround possible (may worth trying) is to physically disconnect other drives, leaving only the one supposed to get Manjaro.

Bad news indeed.

Ok, back to square 1..
I manage to load the live-usb grub... and then, when trying to boot manjaro: black frozen screen.

I will try this as a last resort. It is not that easy to take those SSDs out.. :slight_smile:

Forum kindly sponsored by