Unable to maximize windows with multiple screens

I have Manjaro XFCE but I have a problem.
Here is my display configuration:

My problem is that, when I try to maximize a window on my primary display, it does not work.
Windows will only maximize if they are on the top left display (the one at the origin 0,0).
Thanks for reading!

  • Is this a fresh installation?
  • Have you rebooted after install/updates?
  • Was it ever working?
  • What happens if you move/change monitors order/layout?
  • What Window manager do you use?

Please post info:

inxi -SMGrxxxz
mhwd -li --pci

Use proper formatting, please

Read for better support
How to provide information about your issues

thanks for your answer.

  • Yep, it's a fresh install.
  • Of course I rebooted after updates
  • Yes, it worked when my primary screen was on the left and that every displays were side by side
  • It depends, sometimes it works, sometimes it doesn't. Most of the time, when a display is set to be above another one, it doesn't work.
  • The default xfce one, xfwm.

Here is the terminal output:

[sceekr@SKR ~]$ inxi -SMGrxxxz
  Host: SKR Kernel: 4.19.13-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
  Desktop: Xfce 4.13.2git-UNKNOWN tk: Gtk 3.24.2 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.28.0 Distro: Manjaro Linux 
  Type: Desktop System: Gigabyte product: Z97-D3H v: N/A serial: <filter> 
  Chassis: type: 3 serial: <filter> 
  Mobo: Gigabyte model: Z97-D3H-CF v: x.x serial: <filter> 
  UEFI: American Megatrends v: F4 date: 04/25/2014 
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
  vendor: Gigabyte driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0412 
  Device-2: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ZOTAC driver: nvidia 
  v: 415.25 bus ID: 01:00.0 chip ID: 10de:1c03 
  Display: x11 server: X.Org 1.20.3 driver: nvidia 
  resolution: 1920x1080~60Hz, 1920x1080~60Hz, 1680x1050~60Hz 
  OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 415.25 
  direct render: Yes 
  Active pacman repo servers in: /etc/pacman.d/mirrorlist 
  1: http://manjaro.melbourneitmirror.net/stable/$repo/$arch
  2: http://mirror.datacenter.by/pub/mirrors/manjaro/stable/$repo/$arch
  3: http://ftp.free.org/mirrors/repo.manjaro.org/repos/stable/$repo/$arch
  4: https://mirror.philpot.de/manjaro/stable/$repo/$arch
  5: http://kibo.remi.lu/stable/$repo/$arch
  6: http://mirror.ufam.edu.br/manjaro/stable/$repo/$arch
  7: https://mirror.cedia.org.ec/manjaro/stable/$repo/$arch
  8: http://mirror.upb.edu.co/manjarostable/$repo/$arch
  9: https://mirror.clarkson.edu/manjaro/stable/$repo/$arch
  10: https://mirror.math.princeton.edu/pub/manjaro/stable/$repo/$arch
  11: http://mirror.chmuri.net/manjaro/stable/$repo/$arch
  12: http://mirror.inode.at/manjaro/stable/$repo/$arch
  13: http://manjaro.dcc.uchile.cl/stable/$repo/$arch
  14: https://mirrors.sjtug.sjtu.edu.cn/manjarostable/$repo/$arch
  15: http://ftp.riken.jp/Linux/manjaro/stable/$repo/$arch
  16: http://ftp.caliu.cat/manjaro/stable/$repo/$arch
  17: https://ftp.nluug.nl/pub/os/Linux/distr/manjaro/stable/$repo/$arch
  18: https://download.nus.edu.sg/mirror/manjaro/stable/$repo/$arch
  19: http://ftp.belnet.be/mirrors/manjaro/stable/$repo/$arch
  20: http://manjaro.mirrors.uk2.net/stable/$repo/$arch
  21: https://mirror.tuchola-dc.pl/manjaro/stable/$repo/$arch
  22: http://mirror.infotronik.hu/mirrors/pub/manjaro/stable/$repo/$arch
  23: https://ftp.cc.uoc.gr/mirrors/linux/manjaro/stable/$repo/$arch
  24: http://ftp.rz.tu-bs.de/pub/mirror/manjaro.org/repos/stable/$repo/$arch
  25: https://manjaro.moson.eu/stable/$repo/$arch
  26: https://www.uex.dk/public/manjaro/stable/$repo/$arch
  27: https://osmirror.org/manjaro/stable/$repo/$arch
  28: http://ftp.cuhk.edu.hk/pub/Linux/manjaro/stable/$repo/$arch
  29: http://ftp.snt.utwente.nl/pub/linux/manjaro/stable/$repo/$arch
  30: http://mirrors.serverhost.ro/manjaro/packages/stable/$repo/$arch
  31: http://free.nchc.org.tw/manjaro/stable/$repo/$arch
  32: http://ftp.tsukuba.wide.ad.jp/Linux/manjaro/stable/$repo/$arch
  33: http://mirror.rise.ph/manjaro/stable/$repo/$arch
  34: http://repo.manjaro.org.uk/stable/$repo/$arch
  35: https://www.mirrorservice.org/sites/repo.manjaro.org/repos/stable/$repo/$arch
  36: http://mirror.ragenetwork.de/manjaro/stable/$repo/$arch
  37: https://ct.mirror.garr.it/mirrors/manjaro/stable/$repo/$arch
  38: https://manjaro.c3sl.ufpr.br/stable/$repo/$arch
  39: http://mirror.xeonbd.com/manjaro/stable/$repo/$arch
  40: http://kambing.ui.ac.id/manjaro/stable/$repo/$arch
  41: https://mirror.netzspielplatz.de/manjaro/packages/stable/$repo/$arch
  42: https://ftp.lysator.liu.se/pub/manjaro/stable/$repo/$arch
  43: https://mirrors.netix.net/manjaro/stable/$repo/$arch
  44: https://mirrors.ocf.berkeley.edu/manjaro/stable/$repo/$arch
  45: http://mirror.is.co.za/mirrors/manjaro.org/stable/$repo/$arch
  46: https://mirrors.dotsrc.org/manjaro/stable/$repo/$arch
  47: https://repo.sadjad.ac.ir/manjaro/stable/$repo/$arch
  48: https://mirror.zetup.net/manjaro/stable/$repo/$arch
  49: http://manjaro.telecoms.bg/stable/$repo/$arch
  50: http://mirrors.tuna.tsinghua.edu.cn/manjaro/stable/$repo/$arch
  51: http://mirror.catn.com/pub/manjaro/stable/$repo/$arch
  52: https://manjaro.mirror.garr.it/mirrors/manjaro/stable/$repo/$arch
  53: https://manjaro.cu.be/stable/$repo/$arch
  54: https://mirrors.ucr.ac.cr/manjaro/stable/$repo/$arch
  55: http://ftp.linux.org.tr/manjaro/stable/$repo/$arch
  56: https://mirror.espoch.edu.ec/manjaro/stable/$repo/$arch
  57: http://kartolo.sby.datautama.net.id/manjaro/stable/$repo/$arch
  58: http://linorg.usp.br/manjaro/stable/$repo/$arch
  59: https://mirrors.zju.edu.cn/manjaro/stable/$repo/$arch
  60: https://mirrors.shu.edu.cn/manjaro/stable/$repo/$arch
  61: http://mirror.ventraip.net.au/Manjaro/stable/$repo/$arch
  62: http://ftp.tu-chemnitz.de/pub/linux/manjaro/stable/$repo/$arch
  63: https://mirror.yandex.ru/mirrors/manjaro/stable/$repo/$arch
  64: https://mirrors.shuosc.org/manjaro/stable/$repo/$arch
  65: http://distro.ibiblio.org/manjaro/stable/$repo/$arch
  66: https://mirror.netcologne.de/manjaro/stable/$repo/$arch
  67: http://manjaro.barata.pt/stable/$repo/$arch
  68: https://mirror.koddos.net/manjaro/stable/$repo/$arch
  69: http://pet.inf.ufsc.br/mirrors/manjarolinux/stable/$repo/$arch
  70: https://ftp.halifax.rwth-aachen.de/manjaro/stable/$repo/$arch
  71: https://ba.mirror.garr.it/mirrors/manjaro/stable/$repo/$arch
  72: http://mirror.truenetwork.ru/manjaro/stable/$repo/$arch
  73: https://repo.rhindon.net/manjaro/stable/$repo/$arch
  74: https://mirror.dkm.cz/manjaro/stable/$repo/$arch
  75: http://manjaro.mirror.ac.za/stable/$repo/$arch
  76: https://manjaro.ipacct.com/manjaro/stable/$repo/$arch
  77: https://mirrors.ustc.edu.cn/manjaro/stable/$repo/$arch
  78: http://mirror.dacentec.com/manjaro/stable/$repo/$arch
[sceekr@SKR ~]$ mhwd -li --pci
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

[sceekr@SKR ~]$ xrandr
Screen 0: minimum 8 x 8, current 3840 x 2130, maximum 32767 x 32767
DVI-D-0 connected primary 1920x1080+1920+1050 (normal left inverted right x axis y axis) 521mm x 293mm
   1920x1080     60.00*+
   1680x1050     59.95  
   1440x900      74.98    59.89  
   1440x576      50.00  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1280x720      60.00    50.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.94  
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1920x1080+0+1050 (normal left inverted right x axis y axis) 509mm x 286mm
   1920x1080     60.00*+  59.94    50.00  
   1680x1050     59.95  
   1440x900      59.89  
   1280x1024     60.02  
   1280x720      60.00    59.94    50.00  
   1024x768      60.00  
   800x600       60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       59.94    59.93  
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 disconnected (normal left inverted right x axis y axis)
DP-5 connected 1680x1050+240+0 (normal left inverted right x axis y axis) 494mm x 320mm
   1680x1050     59.88*+  59.95  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   640x480       75.00    72.81    59.94  

Thanks again!

This shows that even if you only have mhwd config for the free drivers, you have non-free nvidia drivers active (and successful!!). It doesn't make sense.. Can you explain this franken-video case?
Which ISO have you used?
Did you change video drivers and how?

Oh sorry I forgot that, originally I used the xfce ISO and installed Manjaro with free drivers.
Then, the only thing I changed is the video drivers because Nouveau was not working properly (black screens, xfce freeze after login...).
So then I installed the Nvidia non-free drivers, blacklisted Nouveau, rebuilt the initramfs and then I rebooted and everything was working fine except this window maximizing problem. It was doing the same thing under Nouveau.

I am really happy for you! You used the Arch way I assume. On Manjaro we use mhwd utility (Manjaro Settings Manager-Hardware) for video drivers (de)install/setup.
This is weird (for me and some others used to mhwd) to troubleshoot, but let's give it a try.
We will need more info to come inline

pacman -Qs nvidia
cat /etc/X11/xorg.conf.d/*.conf 
cat /etc/modules-load.d/*.conf 
cat /etc/modprobe.d/*.conf 
journalctl -b -p3
cat /var/log/Xorg.?.log

I hope I can help, while @bogdancovaciu @dglt and others need to jump in

Edit: First notice is that xrandr output layout seems different from your posted image (Monitor settings), unless I need more coffee..

1 Like

Oh well, I didn't know about mhwd...
The xrandr output is a little bit different because I move the top left monitor a bit to the right but that's all.
The terminal output was too long for a post... Sorry, it's quite long haha.
Here is a pastebin link: terminal output.

So, is a desktop. Do you use the integrated GPU? If not, disable it from BIOS.
If you want to use it, it might need an updated BIOS as right now is outdated

Also, because is

you have to be careful what bios you update. Make sure you get the correct version number.

I don't use the integrated GPU no, but what would be the point/link with my problem of disabling it?
As for the BIOS update, I might do it soonly.

ive never ran into an optimus (inegrated/dedicated gpu) desktop before so i dont know how/if they are different than a laptop setup. what instructions did you follow to set it up? prime?

updating bios may be all you need to do, maybe not but it cant hurt to update to the latest firmware.

im curious what drivers are currently installed in mhwd and what shows as available options.
please post
mhwd ; mhwd -li

also, since this is a desktop i assume your using the hdmi or display ports directly on your nvidia gpu? are any of the monitors connected to the hdmi/dp output thats on the motherboard? if you have different monitors set up on both integrated/dedicated gpu this is likely an issue. if you dont need the intel integrated gpu, disable it in bios like @AgentS said and you will avoid any of the conflicts that are caused by optimus

I think you are right. As I reviewed the Xorg logs, only nvidia is active, being Primary GPU from boot. I suppose you have all monitors physically connected to the nvidia card.

This issue tends to be an XFCE issue after all.. :frowning_face:

In the past (when I used xfce) there was a difficulty/bug about the Primary monitor in xfce.
To workaround this, until it is finally fixed upstream, you can use a layout where your Primary monitor is "always" at top left.
I don't know if this trick suits your preference, but at least you can try it and tell us if it really works. Then it may be your decision.. or we 'll see..:wink:

1 Like

Didn't set up anything, I didn't disable the integrated GPU but I'm not using it.

I don't think the BIOS has something to do with such a small software-related problem.

Here is the output:

[sceekr@SKR ~]$ mhwd ; mhwd -li
> 0000:01:00.0 (0300:10de:1c03) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-bumblebee            2018.08.09               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2018.08.09               false            PCI
          video-nvidia            2018.08.09               false            PCI
    video-nvidia-390xx            2018.08.09               false            PCI
           video-linux            2018.05.04                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:00:02.0 (0300:8086:0412) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-bumblebee            2018.08.09               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2018.08.09               false            PCI
           video-linux            2018.05.04                true            PCI
            video-vesa            2017.03.12                true            PCI

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

Everything is plugged on the Nvdia card:

  1. iiyama screen on the DVI port
  2. HP screen on the HDMI port
  3. Samsung screen on the DisplayPort port

Will do that. I'll tell you if it changed anything.

Yep, I think it is but I wanted to know is there is a way to fix it.

Yes, that way it works, but then to switch from one monitor to another with my mouse I have to do extremely unnatural and weird moves (like to go down to go the the screen on my left...).

So I just update my BIOS and disabled the integrated GPU.
The problem persists and nothing changed.

Even if is irrelevant to disable it, is equally irrelevant to your system if you are not using it :wink:
More than that, now you have all this drivers installed:

You only need the video-nvidia and the configurations it provides. The you will be able to make use of Nvidia Server X Settings ...

Because you still have the other drivers/configs ... Keep only the video-nvidia

@Sceekr didnt use mhwd to install the nvidia drivers, right now all mhwd lists as installed is video-linux (i think i unnecessarily complicated the mhwd and mhwd -li by putting into one command)

@Sceekr mhwd sets up needed configs when you install drivers, your best/easiest option IMO would be to disable the intel card as its not used and can only cause risk of problems that could be easily avoided by disabling it. then:
sudo mhwd -r pci video-linux
sudo mhwd -a pci nonfree 0300

also: remove/backup any custom video configs before installing with mhwd to avoid any conflicts.

1 Like

Oh, that was special :slight_smile:

So why not only mhwd -li ?
Anyway, this topic looks on the solved track ...

1 Like

i never troubleshooted an optimus desktop and i was wondering what drivers mhwd would recommend to install

It does the same as on a laptop, in some cases works, but in other instance will not work. Some sort of confusion ... that is why i prefer to disable the intel GPU on Desktops, then when you install with nonfree option is installing the correct driver, with no hiccups.
So, because i'm use to go directly to mhwd -li i misread the OP post :slight_smile:
Anyway, i think all is going to work after all !

1 Like

That's great! Now try to set Your physical top-left monitor as Primary, either at Nvidia Settings utility, or Xfce settings, preferably the former.
I assume your monitors layout follows their physical placement, is it?

Sorry, couldn't reply before...

@bogdancovaciu @dglt Did everything you told me to do but I still have the same problem :disappointed_relieved:

New mhwd -li output:

[sceekr@SKR ~]$ mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2018.08.09               false            PCI

Warning: No installed USB configs!

Exactly, here is my screen layout:

I don't really know what to do anymore...

Forum kindly sponsored by