Unable to restore system after an interrupted kernel update.

I ran mhwd-kernel - li, it displayed only one installed kernel - linux54. What will happen if I remove Linux54 and install Linux57? Will I lose my data?

If you remove kernel version 5.4 and install then kernel 5.7, then you won´t loose your data.
But kernel 5.7 is at rc4 at www.kernel.org.
I recommend using kernel 5.6.

1 Like

Unfortunately, I can't reinstall kernel. After running mhwd-kernel -i linux56I got the following error:
Error: You can't reinstall your current kernel. Please use 'pacman -Syu' instead to update

Guys do you have any ideas how to solve it?

Then you should use the Manjaro USB stick.
Chroot into the system and complete the update.

1 Like

I have already tried chroot, it didn't help me :sob:

Try to boot from the Manjaro USB stick.
Then use the command "manjaro-chroot -a" to chroot into the system.
After that you should try to complete the system update.

1 Like

Your are in chroot now, right?
Try installing Manjaro Kernel 4.19:

sudo  pacman -S linux419 linux419-headers
sudo update-grub

then reboot and see if you can boot into your Manjaro again and finish the update with
sudo pacman -Syyuu

Post if there are any errors. We're willing and happy to help. :slight_smile:

As a tipp: always have at least two kernels installed. I usually install the current LTS kernel (linux54) and the current linux kernel (as of writing: linxu56)
On my main production machine I have the current and the previous LTS-kernel (linux 54 and linux 419)

1 Like

@seantum, thank you for your reply! I did it as you said, but it didn't help me, I still have the same problem.
I screened all my steps:

  1. 1
  2. Screenshot from 2020-05-06 17-30-10
  3. Screenshot from 2020-05-06 17-31-38

What I did wrong?

Please don't post screenshots of terminal output, use copy+paste and properly format via </> button.

Take a look at this fine tutorial to restore broken bootloader:


moved to #newbies as this is no kernel issue

1 Like

Thanks for the link. I tried to obtain Kernel Boot Method from the post.
Here's a result (sorry for a screenshot again):
photo_2020-05-06_18-33-03
When I tried to run boot command I have the following error:
photo_2020-05-06_18-43-24

I also tried to perform the same actions for vmlinuz-5.4-x86_64, but I still have the same error.

Did you try the fallback initramfs?
Your earlier screenshot shows an error while running the autodetect hook for the normal one..

1 Like

You mean, did I run mkinitcpio -P?
Yes, I did, loot at the main post on this topic.
I ran:

pacman -Syu
mkinitcpio -P
update-grub

No, according to screenshots you selected the normal initramfs (which had problems while generating) when specifying initrd /boot/initramfs-....img.
You must have noticed the error -13 when generating?
At this step - did you try the initramfs-...fallback.img?

1 Like

Oh, I get it. I will try it, thank you!

I noticed that I forgot to specify parameters root=UUID=$abc rw.
I performed the following combinations of commands:

grub> linux /boot/vmlinuz-5.4-x86_64 root=UUID=$abc
grub> initrd /boot/initramfs-5.4-x86_64.img
grub> linux /boot/vmlinuz-5.4-x86_64 root=UUID=$abc
grub> initrd /boot/initramfs-5.4-x86_64-fallback.img
grub> linux /boot/vmlinuz-4.19-x86_64 root=UUID=$abc
grub> initrd /boot/initramfs-4.19-x86_64.img
grub> linux /boot/vmlinuz-4.19-x86_64 root=UUID=$abc
grub> initrd /boot/initramfs-4.19-x86_64-fallback.img

And it didn't help. I don't see any errors -13.

photo_2020-05-07_08-11-46

After boot invoking:
photo_2020-05-07_08-35-23

At this juncture, you might want to consider re-installing your system after having backed up your personal data plus config files/folders in your home directory.

2 Likes

If you don't find this reply helpful, just ignore it, but here is what I'd do in your shoes.

You've been at this for at least 19 hours now. During that time, you could have:

  1. backed up your /home directory (including all dotfiles and settings, assuming you don't already have a backup),
  2. saved a list of all installed packages using
    pacman -Qqe > pgklist.txt,
  3. reinstalled Manjaro,
  4. reinstalled all your packages,
  5. restored backup, and...
  6. still have some 18 or so hours of free time.

Also, this situation could have been prevented by using timeshift, I wholeheartedly recommend looking into it and learning how to use it, as updates may break your system and being able to restore a snapshot is extremely convenient.

3 Likes

Oh, that's bad news :frowning_face:
Anyway, thank you so much guys for your help.

This topic was automatically closed after 180 days. New replies are no longer allowed.

Forum kindly sponsored by