Unable to see the bootloader on Windows 10 - Where did I go wrong?

I recently installed Manjaro on my Windows 10 Laptop (Dell | Intel Core i3-4010U Processor 4 GB DDR3 500 GB 5400 rpm Hard Drive).

I was just trying out different distros to see which one is right for me. So, please be gentle the moment a thought crosses your mind, "Why the hell was was he doing that?"

  1. I first installed Ubuntu. After playing it for a couple of days, removed Ubuntu and installed Elementary OS.
  2. During both these cases, the moment I switched on my laptop, I used to see an option to select the OS I want to boot in to (Windows / Elementary or Ubuntu).
  3. A couple of days back, I reset my PC.
  4. I then installed the latest Manjaro Deepin 17.1.11.
  5. After installing it, I was no longer seeing the bootloader to choose the OS when I switch on my machine.
  6. So, I tried the instructions here and it didn't help, Dual-boot problem: System goes directly into Windows 10 and skips Manjaro (manjaro-kde-17.1.5-stable-x86_64)


sudo parted -l

Model: ATA WDC WD5000LPVX-7 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  525MB   524MB   fat32           EFI system partition          boot, esp
 2      525MB   567MB   41.9MB  fat32           Basic data partition          hidden
 3      567MB   701MB   134MB                   Microsoft reserved partition  msftres
 4      701MB   1488MB  786MB   ntfs            Basic data partition          hidden, diag
 5      1488MB  125GB   124GB   ntfs            Basic data partition          msftdata
 6      125GB   126GB   975MB   ntfs                                          hidden, diag
10      126GB   242GB   115GB   ext4
11      242GB   248GB   6127MB  linux-swap(v1)
 7      248GB   248GB   472MB   ntfs                                          hidden, diag
 8      248GB   491GB   243GB   ntfs            Basic data partition          msftdata
 9      491GB   500GB   8939MB  ntfs            Microsoft recovery partition  hidden, diag

Model: JetFlash Transcend 8GB (scsi)
Disk /dev/sdb: 8032MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      32.8kB  2300MB  2300MB  primary               boot
 2      2300MB  2304MB  4194kB  primary               esp

sudo blkid

/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"
/dev/sda1: LABEL="ESP" UUID="FC45-C469" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="573c3a47-cacd-4a31-99d6-abbd593e40ee"
/dev/sda2: LABEL="DIAGS" UUID="C8EE-4E98" TYPE="vfat" PARTLABEL="Basic data partition" PARTUUID="c4c56113-2567-4ac1-9bd7-c8298cfb1fe8"
/dev/sda4: LABEL="WINRETOOLS" UUID="02FEEFFAFEEFE3BF" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="b10be14c-9d20-45ba-aa9f-44f9e523e3f9"
/dev/sda5: LABEL="OS" UUID="84B6FB01B6FAF312" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="518c8069-10f2-4d5e-8828-62a24551fbd5"
/dev/sda6: UUID="16C872FEC872DB85" TYPE="ntfs" PARTUUID="fe365e62-f411-4a64-8006-50786f8ddaf5"
/dev/sda7: UUID="CA12BE9312BE844B" TYPE="ntfs" PARTUUID="cd910537-9113-456e-860f-d4414471acaf"
/dev/sda8: LABEL="Local Win Disk" UUID="EAA8E0C3A8E08F7F" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="c6ebf240-b054-405b-8990-eca82432e778"
/dev/sda9: LABEL="PBR Image" UUID="3208824808820B55" TYPE="ntfs" PARTLABEL="Microsoft recovery partition" PARTUUID="37f56d82-990e-4752-8332-284d0b841a3f"
/dev/sda10: UUID="7ef673a7-2bea-43ba-bee1-3343dc7506f6" TYPE="ext4" PARTUUID="f44b5fa1-df6d-492a-89af-7a4defe515e7"
/dev/sda11: UUID="3f4a6fbc-1cd1-430b-a624-efa65bd53061" TYPE="swap" PARTUUID="960a7232-08f4-4268-a6d7-0c90e87e72de"
/dev/sdb1: UUID="2018-07-03-16-53-42-00" LABEL="MJRO1711" TYPE="iso9660" PARTUUID="e24c0a5e-01"
/dev/sdb2: SEC_TYPE="msdos" LABEL="MISO_EFI" UUID="F626-64DE" TYPE="vfat" PARTUUID="e24c0a5e-02"
/dev/sda3: PARTLABEL="Microsoft reserved partition" PARTUUID="9d424599-5d88-4dea-bb18-087b75ad59d8"

findmnt -s

/      /dev/mapper/root-image auto   defaults

efibootmgr -v

BootCurrent: 0005
Timeout: 0 seconds
BootOrder: 0003,0000,2003,0004,2001,2002
Boot0000* ubuntu	HD(1,GPT,573c3a47-cacd-4a31-99d6-abbd593e40ee,0x800,0xfa000)/File(\EFI\ubuntu\shimx64.efi)
Boot0001* UEFI Onboard LAN IPv4	PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)/MAC(ecf4bb9b3f85,0)/IPv4(,0,0)RC
Boot0002* UEFI Onboard LAN IPv6	PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)/MAC(ecf4bb9b3f85,0)/IPv6([::]:<->[::]:,0,0)RC
Boot0003* Windows Boot Manager	HD(1,GPT,573c3a47-cacd-4a31-99d6-abbd593e40ee,0x800,0xfa000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...R................
Boot0004* Ubuntu	HD(1,GPT,573c3a47-cacd-4a31-99d6-abbd593e40ee,0x800,0xfa000)/File(\EFI\ubuntu\grubx64.efi)RC
Boot0005* EFI USB1 PATH1 (JetFlashTranscend 8GB)	PciRoot(0x0)/Pci(0x1d,0x0)/USB(0,0)/USB(0,0)/HD(2,MBR,0xe24c0a5e,0x448c90,0x2000)RC
Boot2001* EFI USB Device	RC
Boot2003* EFI Network	RC

Also, do let me know if I need to remove any of my partitions. Happy to do that. I just want to keep the Windows OS one, OEM recovery one, and Manjaro root and swap one.

Check this out.
Read completely.

1 Like

I read it. Am I supposed to follow the "Step 4 variations" part? I mean does my machine have a separate boot partition?

Also, if it's not too much to ask for, can you help me with where did I go wrong?

Looking at your parted -l, no, it does not have a separate boot partition.
Just proceed. (To boot into Manjaro) - Step 4
provide data as required (not previously provided) like finsmnt -s, finsmnt /boot/efi, etc...
Don't worry too much.
If you can boot into manjaro, that's a good sign.
See if you can.

[EDIT] - Did you disable secureboot when installing Manjaro?
If you did not, please do so.

1 Like

Many thanks. It worked :slight_smile:

Also, I think secure boot is off. Must have switched it off when I installed Ubuntu the first time.IMG_20180712_231551-compressor%20(1)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by