Unable to uninstall noveau

System:    Kernel: 5.4.6-2-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 root=UUID=11946327-7561-4e0c-b1b6-d43661ce6b47 rw quiet apparmor=1 
           security=apparmor udev.log_priority=3 
           Desktop: KDE Plasma 5.17.4 tk: Qt 5.14.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx serial: <filter> UEFI: American Megatrends 
           v: 2901 date: 10/16/2019 
CPU:       Topology: 6-Core model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 8 stepping: 2 
           microcode: 800820D L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86256 
           Speed: 2401 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 2401 2: 1714 3: 2118 4: 2195 5: 1775 
           6: 1985 7: 1884 8: 2199 9: 2991 10: 1839 11: 1846 12: 2177 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: eVga.com. driver: nouveau v: kernel bus ID: 09:00.0 
           chip ID: 10de:1c82 
           Display: x11 server: X.Org 1.20.6 driver: nouveau unloaded: modesetting alternate: fbdev,nv,vesa 
           compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: NV137 v: 4.3 Mesa 19.3.1 direct render: Yes 
Audio:     Device-1: NVIDIA GP107GL High Definition Audio vendor: eVga.com. driver: snd_hda_intel v: kernel bus ID: 09:00.1 
           chip ID: 10de:0fb9 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 0b:00.3 chip ID: 1022:1457 
           Device-3: Kingston HyperX Virtual Surround Sound type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-5:4 
           chip ID: 0951:16a4 serial: <filter> 
           Device-4: Texas Instruments PCM2902 Audio Codec type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-6:5 
           chip ID: 08bb:2902 
           Sound Server: ALSA v: k5.4.6-2-MANJARO 
Network:   Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: 5.6.0-k port: e000 bus ID: 04:00.0 
           chip ID: 8086:1539 
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 2.05 TiB used: 8.25 GiB (0.4%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 250GB size: 232.89 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 1B2QEXE7 scheme: GPT 
           ID-2: /dev/sda vendor: Seagate model: ST1000DM003-1SB102 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC43 scheme: MBR 
           ID-3: /dev/sdb type: USB vendor: Seagate model: Expansion size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B serial: <filter> rev: 0708 scheme: MBR 
Partition: ID-1: / raw size: 26.29 GiB size: 25.75 GiB (97.95%) used: 8.22 GiB (31.9%) fs: ext4 dev: /dev/nvme0n1p5 
Sensors:   System Temperatures: cpu: 42.2 C mobo: N/A gpu: nouveau temp: 31 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 300 Uptime: 1m Memory: 15.63 GiB used: 1.64 GiB (10.5%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           Shell: bash v: 5.0.11 running in: konsole inxi: 3.0.37

I recently got Manjaro KDE for experimenting and dualbooted it with my Windows 10.
there has been a problem though: when i try to install nvidia drivers and uninstall linux drivers i get stuck at TCP SYSTEM STARTUP/SHUTDOWN every time i boot, it fixes itself, when i uninstall nvidia Drivers and reinstall video-linux with mhwd. I looked online but couldn't find a solution how to remove noveau and not get a error .

Start by reading this so you know how to give us the relevant information in order to help you out:

:grin:What is the question exactly, you have solved your own problem by reinstalling video-linux which is the intel video for your device and now everything is working. So good for you :+1:
If you are having problems with the Nvidia driver itself, which sounds like what is happening then start to trouble shoot from there.
Learn what nvidia device you have, check the web for linux compatibility, see what errors your are getting with journalctl and perhaps you can solve it.

Hey whoops, turns out video-linux could also be noveau. My bad, anyway check out what you have exactly I guess.

The problem is, that i can't run non-free Nvidia drivers without getting an Error at boot

also please post the contents from this command

cat /etc/modprobe.d/mhwd-gpu.conf


cat /etc/modules-load.d/mhwd-gpu.conf

cat /etc/modprobe.d/mhwd-gpu.conf 

## Generated by mhwd - Manjaro Hardware Detection
cat /etc/modules-load.d/mhwd-gpu.conf
## Generated by mhwd - Manjaro Hardware Detection

that's what i got,tried sudo too

Sheez I am having real problems with copy/paste and mouse control in my VM, you have just confirmed that I am out of my depth at the moment.

In the past these files controlled some nvidia graphics driver things but it looks like things have changed since yours are empty.

Please have a look at some of the FAQ specifically for the TCP Nvidia Booting keywords. I think @jonathon had written up something at one point.

So it is a desktop PC with GeForce GTX 1050 Ti GPU

Are you sure is TCP and not TLP ? My guess is that you had a typo, and is about tlp
You can safely remove tlp package, install video-nvidia trough MHWD, or by:
sudo mhwd -i pci video-nvidia-440xx
then reboot.

Thanks for the info, but how do I remove tlp ? I only found commands for ubuntu

As any other package.
From Add/Remove Software, reboot after that, or from terminal:
sudo pacman -R tlp

Thanks for the help but now i have another problem: it booted into the wrong resolution (native is 1920x1080 for both my monitors) but in xrandr i got this:

Screen 0: minimum 8 x 8, current 3840 x 1080, maximum 32767 x 32767
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 1600mm x 900mm
   1920x1080     60.00*+  59.94    50.00    23.98    60.05    60.00    50.04  
   1280x1024     60.02  
   1280x720      60.00    59.94    50.00  
   1024x768      60.00  
   800x600       60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       59.94    59.93  
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 597mm x 336mm
   1920x1080    144.00 + 120.40*   99.93    60.00    59.94    50.00    29.97    25.00    60.00    50.04  
   1680x1050     59.95  
   1600x1200     60.00  
   1440x900      59.89  
   1400x1050     59.98  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1280x720      60.00    59.94    50.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.94    59.93

The general resolution is set to 3840x1080 and i didn't find a fix for it and when i try to save it to xconf in the xserver settings the only message i get i that there is no file

I don't think i follow. What issue you have? The xrandr looks fine to me.

What is to fix about it?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by