Unable to update AUR packages: nothing to do (pamac and yay)

I have some AUR packages which are out of dates, but pamac and also yay, when I check for updates, tell me "nothing to do" about the AUR packages. Mirrors are synchronized.
I am aware of this: https://gitlab.manjaro.org/applications/pamac/-/issues/627 (eg the suggestion to delete /var/lib/pacman/db.lck)
But AUR updates has always worked for me, is a problem that started to occurrs some system update ago.
I miss something? I though that YAY would be able to deal with AUR packages, at least (yay --aur -Syu), but I still get "nothing to do".

What makes you think they need updates?

If you are getting a message in yay that states they are marked out of date that means the AUR package is out of date and the maintainer needs to update it.

example: I have solaar-git at 1.0.2.rc1 and here https://aur.archlinux.org/packages/solaar-git is at 1.0.2.rc2; in facts, if I manually build it, the new release is proposed. I simply have no alerts of updates for this and other AUR packages.

That may be a development package.

Call yay with --devel or enable checking of development updates in the pamac settings.

Still "there is nothing to do".

What is that actual yay command line you are using?

The first one, as indicated in my post: yay --aur -Syu
then yay --aur --devel -Syyu

For the little I have used yay it has never worked with VCS packages (-git,-svn,-hg,..) like yaourt did; speaking of --devel option.

About pamac don't know if the feature is done yet since I don't use it (I use pamac-classic)

About yay --devel

$ yay --aur --devel -Syyu
:: Searching AUR for updates...
:: Checking development packages...
-> phoronix-test-suite-milestone: local (9.8.0m1-1) is newer than AUR (9.6.0m1-1)
-> Missing AUR Packages: eos-easy-installer-git nemo-debug-git
there is nothing to do

While I have plenty of them instead

devel git

I use yay --devel and it has always worked.

I have never used it with --aur.

Does yay -Syu --devel --combinedupgrade show you any aur packages that need updating?

$ yay -Syu --devel --combinedupgrade
[sudo] password di fabio:
:: Sincronizzazione dei database in corso...
core è aggiornato
extra 2,0 MiB 261 KiB/s 00:08 [####################################################] 100%
community è aggiornato
multilib è aggiornato
Lolix_repo_cauldron 1170,0 B 0,00 B/s 00:00 [####################################################] 100%
Lolix_repo_clean 44,0 KiB 0,00 B/s 00:00 [####################################################] 100%
Lolix_repo_dirty 5,1 KiB 1706 KiB/s 00:00 [####################################################] 100%
Lolix_repo_test 13,4 KiB 0,00 B/s 00:00 [####################################################] 100%
cingg è aggiornato
privacyshark è aggiornato
:: Searching databases for updates...
:: Searching AUR for updates...
-> delft-icon-theme: local (1.13-1) is newer than Lolix_repo_clean (1.12-1)
-> gmusicbrowser-git: local (1.1.15.r62.g547b631-1) is newer than Lolix_repo_clean (1.1.15.r54.g4538a5a-1)
-> guayadeque-git: local (0.4.6.r26.ga0666894-1) is newer than Lolix_repo_clean (0.4.6.r23.gdffe91c8-1)
-> guitar: local (1.2.0-1) is newer than Lolix_repo_clean (1.1.1-2)
-> handbrake-full: local (1.3.3-1) is newer than Lolix_repo_clean (1.3.1-1)
-> inxi: local (3.1.04-1) is newer than community (3.0.37-1)
-> libnpupnp: local (4.0.7-1) is newer than Lolix_repo_clean (4.0.3-1)
-> libupnpp: local (0.19.2-1) is newer than Lolix_repo_clean (0.19.1-1)
-> spacefm-git: local (1.0.6.r80.ge257d15-3) is newer than Lolix_repo_clean (1.0.6.r80.ge257d15-1)
:: Checking development packages...
-> phoronix-test-suite-milestone: local (9.8.0m1-1) is newer than AUR (9.6.0m1-1)
-> Missing AUR Packages: eos-easy-installer-git nemo-debug-git
:: Aggiornamento del sistema in corso...
attenzione: delft-icon-theme: la versione installata (1.13-1) è più recente di quella presente in Lolix_repo_clean (1.12-1)
attenzione: gmusicbrowser-git: la versione installata (1.1.15.r62.g547b631-1) è più recente di quella presente in Lolix_repo_clean (1.1.15.r54.g4538a5a-1)
attenzione: guayadeque-git: la versione installata (0.4.6.r26.ga0666894-1) è più recente di quella presente in Lolix_repo_clean (0.4.6.r23.gdffe91c8-1)
attenzione: guitar: la versione installata (1.2.0-1) è più recente di quella presente in Lolix_repo_clean (1.1.1-2)
attenzione: handbrake-full: la versione installata (1.3.3-1) è più recente di quella presente in Lolix_repo_clean (1.3.1-1)
attenzione: inxi: la versione installata (3.1.04-1) è più recente di quella presente in community (3.0.37-1)
attenzione: libnpupnp: la versione installata (4.0.7-1) è più recente di quella presente in Lolix_repo_clean (4.0.3-1)
attenzione: libupnpp: la versione installata (0.19.2-1) è più recente di quella presente in Lolix_repo_clean (0.19.1-1)
attenzione: spacefm-git: la versione installata (1.0.6.r80.ge257d15-3) è più recente di quella presente in Lolix_repo_clean (1.0.6.r80.ge257d15-1)
non ci sono aggiornamenti disponibili

There is a lot of stuff because of the things I have half done, but still don't update -git packages

And they all have new commits that need updates?

It is not even checked or taken in consideration by yay.

yaourt output for comparison:

$ yaourt -Sua --devel
Altri pacchetti: / 21 / 21
==> aggiornamento di un pacchetto SVN/CVS/HG/GIT

Oggetti (20): cmake-modules-elementary-git conky-git eos-easy-installer-git filebrowser-git gmusicbrowser-git guayadeque-git imageburner-git 
              inxi-perl-git libdri2-git linuxstopmotion-git madrigal-git mdpreview-git mediainfo-gui-hv-git nemo-debug-git pcsxr-pgxp-git 
              play-emu-git python-javascriptcore4-git python-markdown-checklist-git spacefm-git upplay-git 

==> Procedere con l'aggiornamento?  [S/n]
==> -------------------------------------
==>

yay checks development packages silently during this phase:

:: Checking development packages...

Have a stab with 'topgrade' and see if it gives more information :wink:
yay topgrade
topgrade
Sorted :wink:

1 Like

Don't forget to mark this as solved :innocent:

I installed and executed topgrade, but unfortunately it didn't update AUR packages (to be more precise it didn't update anything, anyway because despite some AUR packages, the system is all up-to-date - I am on the stable branch) Thank you anyway for your suggestion.

Unfortunately the topic is not solved...

Hi, I really don't know what happened, but after the [Stable Update] 2020-07-19 I am again able to receive updates from AUR.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by