Unable to update or install packages, cannot retrieve keys. (KDE edition)


see end of post for method

Hi, please help!! :cry: I've tried what I can I believe.

The problem I have is that when updating I'm suddenly confronted with:

error: GPGME error: General error
error: failed to update DEB_Arch_Extra (invalid or corrupted database (PGP signature))
error: database 'DEB_Arch_Extra' is not valid (invalid or corrupted database (PGP signature))

as such the update won't complete and I cannot install new packages.

The rest of the update seems fine, I get:

core is up to date
extra is up to date
community is up to date
multilib is up to date
archlinuxfr is up to date

and DEB_Arch_Extra and DEB_Arch_Extra.sig download but do not resolve.

I have followed the steps outlined at the Issues with “signature is marginal trust” or “invalid or corrupted package” page including the 'nuclear option'.

I have updated my package mirrors, which seem fine, however when I update my signing keys I get lots of 'missing key' errors.

I've also tried to download keys from:

sudo pacman-key --refresh-keys --keyserver pgp.mit.edu

but the terminal just hangs and does nothing.

I've searched for GPGME error: General error with ddg but have had no matches, similarly with the error: database 'DEB_Arch_Extra, although there are similar errors I do not understand them enough to know whether they are cross-compatible.

Why have my keys suddenly gone missing and why can I not retrieve new ones?

Many thanks for any help.

This was solved by first identifying the culprit for the error, with help from the forum, as the repository for Megasync.

I then tried to reinstall Megasync by downloading the source package. However I was still unable to install it and received an error: failed to prepare transaction (invalid or corrupted database)

I then opened /etc/pacman.conf and commented out the entry for DEB_Arch_Extra.

I was then able to complete a full update with sudo pacman -Syyu

Once this was complete I was able to reinstall Mega sync from downloaded package which added the repo and the correct key.

That is the repository of Megasync right? search for their key

This is a third-party repo. Please ask whoever maintains it for help.

(moved from #technical-issues-and-assistance:updating to #technical-issues-and-assistance:third-party-applications as this is an issue with a third-party package repo)

Aha, yes! that makes perfect sense. Thank you :smiley:

Thanks, was just told that it is Megasync, which hopefully should solve it once I get the key.

1 Like

Thanks that was exactly it!

Hi I have managed to solve it with the help from the forum.

I have marked my post as solved and added the method used.

Is this the correct protocol?

Yes. :wink:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by