Uninstalled pulseaudio and took kde along with it

I am 99% certain this is related to the fact I upgraded to 4.20 Kernel as I didn’t do anything else noteworthy on my pc, except for the fact I was trying to set up JACK.

After restarting, kernel updated and it now asks me to log into my pc although I never had to do that before. It also has a layout that is unfamiliar to me, I don’t know if it’s kernel related. Initially I thought ok, I’ll just login normally but that’s not the case. It asks me to select my user and to enter password. I select my user and I enter my password but other than that nothing happens. I press enter but no message appears to at least inform me what I’m doing wrong. There’s also no button for me to press. Keyboard works just fine.

I can still access the terminal through ctrl+alt+F2 and I can log into my user just fine to run sudo commands. How do I gain access to my PC again?

Here’s a photo of what it looks like on login screen: http://i63.tinypic.com/2j27twh.jpg

you can try reinstalling kauth, and then re-run the update.
sudo pacman -S kauth
sudo pacman -Syyu

if you still think its kernel related, then from grub menu select advanced options and choose the 4.19 kernel

Tried both and neither worked so perhaps it's not kernel related. I really don't want to reinstall manjaro. Can I somehow log into my DE using terminal?

Can I somehow log into my DE using terminal?
if you can login through tty, you can try startx .

if kauth is not the cause then you can also try disabling sddm and reinstalling it.
from tty:
sudo systemctl stop sddm
sudo systemctl disable sddm
sudo pacman -S sddm
sudo systemctl enable sddm --now
is sddm (default kde desktop manager) working? able to login?

Reinstalling sddm didn't help. I'm still getting that login screen as in the photo, still unable to hit enter after typing my password.
Startx command only returns some errors and warnings and nothing else.

Someone really needs to help me out here because I'm practically locked out of my computer and I don't want to reinstall manjaro until I make a few more attempts at least.

and those warning are???

may want to rephrase that.

ok, you can boot to tty only. no desktop manager will be started.

at grub, on the manjaro selection, instead of hitting enter, hit E and then find the word "quiet" and replace it with the number 3. (be sure to leave a single space before and after 3)
when you get to a TTY, login and then startx . this should bring you to your desktop and avoid sddm ever starting. report back here with results. then provide more information for others to work with.

and also provide output of
systemctl status sddm

Sorry, I didn't imply that you're not helping me, I was merely expressing my frustration about the situation :smile:

Typing forum posts on a smartphone is a bit clunky so sorry if I'm not providing enough information.

I think I followed your steps correctly. Here's what happens when I type startx: http://i65.tinypic.com/ohsdxw.jpg

And here's the output of your last command: http://i65.tinypic.com/2j0nhqh.jpg

"could not exec startkde : no such file or directory."

you mentioned previously about messing with JACK. did you happen to try an uninstall pulseaudio maybe? i ask because it looks like SDDM is in fact installed but where is KDE? i dont suppose you have a backup like timeshift?

you can try avoiding a full re-install by installing kde itself? im not sure of the exact package or packages but im guessing if you try to install some of the core apps it will pull in whats needed.

sudo pacman -S plasma-desktop plasma-workspace kdeplasma-addons 

if that does not work, i think you should re-install. do you have a combined partition for both home and root? or separate?
if you want to backup the home directory, just put it on a separate partition for now and you can restore it later.
if you have a separate home partition, just dont delete it. or resize it small enough and out of the way of the new install. good luck, let me know how it goes.

once its working, timeshift is your friend.


I indeed tried to uninstall pulseaudio at some point but I thought I reinstalled it. In any case, reinstalling KDE packages worked! If pulseaudio was really the problem, was it that serious that I couldn't log into KDE? I'd expect to not have sound at the most. Thanks a lot though!


i have made the mistake of trying to uninstall pulseaudio in the past. it takes alot more than itself along with it. gllad you got it working, now look into timeshift :+1:

Had no idea about it, I just set it up. Thanks for the tip!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by