[Unstable Update] 2018-05-18 - Kernels, Mesa, Xorg-server, Video drivers, Libinput, Gstreamer

I have a problem with the kernel-4.17-rc on Xfce4-gtk3 in VirtualBox . After I login, with any program that I load it could not be moved, resized. Others kernels works

Bottom line is 304.xx and 340.xx nvidia proprietary drivers don't support xorg 1.20, and all indications are new libglvnd support will not be backported to these.

One option is to roll forward with xorg 1.20 and either force these nvidia users to nouveau / prime nouveau, which as you point out will most likely end in severe anguish for the less technically inclined.

This transition is not straight forward and will require manual intervention and some knowledge to setup / troubleshoot.

Another possible option is to package an xorg 1.19 compat package group to allow the 304.xx and 3.40.xx drivers to continue to operate. Keep this xorg 1.19 compat package group around for six months or so and announce the phasing out of 304.xx / 340.xx drivers, giving users time to plan and test their transition to xorg 1.20 compatible video drivers.

All this is predicated on nvidia not backporting these legacy drivers to xorg 1.20 compliance.

Personally I am moving my primary laptop back to testing as even the 396.xx driver does not work with bumblebee and xorg 1.20. My other optimus laptop I'll keep on unstable to test.


Xorg 1.20 is in Arch Stable, what are legacy nvidia Arch users doing?

writing bugreports: https://bugs.archlinux.org/task/58660?project=1&string=nvidia-340xx
and let me guess what will happen... these drivers will go to !aur



Without xorg 1.20+ compatibility they are useless, whether in official repos or AUR.

Without nvidia backporting only way to use these drivers is with xorg <= 1.19.

Just another :fu: from nvidia.

1 Like

And another :woman_facepalming: :man_facepalming: for the community. Because it isnt surprising that Nvidia would do this, but it's just surprising that nobody where prepared for it...

I mean we're moving on with all these stuff in webdad, gnome, firefox, KDE-Stuff and whatever BUT cant¹ get² our³ base⁴ system⁵ right⁶? For me it's so frustrating to see this.

1 Like

I am in the testing and today I have a vlc-nightly update and when doing this update I have this message:

attention: linux-firmware: local (20180518.86d39f8-1) is newer then core (20180518.2a9b2cf-1)

should I downgrade?

Normally, you can just ignore these messages if your system is working without problems.

1 Like

20180518.2a9b2cf-1 is newer than 20180518.86d39f8-1

downgrade to upgrade ...

xorg 1.20 with GLVND, I hope this will help optimus users.

Current differences from testing

:: Different overlay package(s) in repository community x86_64

                             PACKAGE              testing             unstable
                           bumblebee             3.2.1-18             3.2.1-19
                        sddm-classic             0.15.0-2             0.15.0-3
                   skippy-xd 2015.12.21.r0.gd0a11f4-1 2016.10.20.r0.g72d1ddf-1
                          wallpaperd            0.2.1-0.1                    -
                      xf86-video-qxl              0.1.5-5                    -
                              xlogin      0.r11.a578cf2-1      0.r14.6e566b5-1

:: Different sync package(s) in repository community x86_64

                             PACKAGE              testing             unstable
                      xf86-video-qxl                    -              0.1.5-6

:: Different overlay package(s) in repository extra x86_64

                             PACKAGE              testing             unstable
                   libva-mesa-driver             18.0.4-0             18.1.0-0
                                mesa             18.0.4-0             18.1.0-0
                          mesa-vdpau             18.0.4-0             18.1.0-0
                         opencl-mesa             18.0.4-0             18.1.0-0
                        vulkan-intel             18.0.4-0             18.1.0-0
                       vulkan-radeon             18.0.4-0             18.1.0-0
                   xf86-video-amdgpu             18.0.1-1                    -
                      xf86-video-ati            1_7.9.0-1                    -
                    xf86-video-dummy              0.3.8-2                    -
                    xf86-video-fbdev  0.4.4+12+ge0bce0d-1                    -
                    xf86-video-intel 1_2.99.917+829+gd7dfab62-1              -
                  xf86-video-nouveau             1.0.15-2                    -
               xf86-video-openchrome              0.6.0-2                    -
                   xf86-video-sisusb              0.9.7-1                    -
                     xf86-video-vesa              2.4.0-1                    -
                   xf86-video-vmware             13.2.1-3                    -
                   xf86-video-voodoo              1.2.5-9                    -
                         xorg-server 1.19.6+24+g56547b196-1                  -
                  xorg-server-common 1.19.6+24+g56547b196-1                  -
                   xorg-server-devel 1.19.6+24+g56547b196-1                  -
                    xorg-server-xdmx 1.19.6+24+g56547b196-1                  -
                  xorg-server-xephyr 1.19.6+24+g56547b196-1                  -
                   xorg-server-xnest 1.19.6+24+g56547b196-1                  -
                    xorg-server-xvfb 1.19.6+24+g56547b196-1                  -
                xorg-server-xwayland 1.19.6+24+g56547b196-1                  -
                                 gdm                    -           3.28.1-1.1
                              libgdm                    -           3.28.1-1.1

:: Different sync package(s) in repository extra x86_64

                             PACKAGE              testing             unstable
                         egl-wayland                    -               0+23-1
                 eglexternalplatform                    -                0+3-1
                   xf86-video-amdgpu                    -             18.0.1-2
                      xf86-video-ati                    -           1:18.0.1-2
                    xf86-video-dummy                    -              0.3.8-3
                    xf86-video-fbdev                    -  0.4.4+13+g9af7f81-1
                    xf86-video-intel              - 1:2.99.917+831+ge7bfc906-1
                  xf86-video-nouveau                    -             1.0.15-3
               xf86-video-openchrome                    -              0.6.0-3
                   xf86-video-sisusb                    -              0.9.7-2
                     xf86-video-vesa                    -              2.4.0-2
                   xf86-video-vmware                    -             13.3.0-1
                   xf86-video-voodoo                    -             1.2.5-10
                         xorg-server                    -             1.20.0-2
                  xorg-server-common                    -             1.20.0-2
                   xorg-server-devel                    -             1.20.0-2
                    xorg-server-xdmx                    -             1.20.0-2
                  xorg-server-xephyr                    -             1.20.0-2
                   xorg-server-xnest                    -             1.20.0-2
                    xorg-server-xvfb                    -             1.20.0-2
                xorg-server-xwayland                    -             1.20.0-2

:: Different overlay package(s) in repository multilib x86_64

                             PACKAGE              testing             unstable
             lib32-libva-mesa-driver             18.0.4-0             18.1.0-0
                          lib32-mesa           18.0.4-0.1           18.1.0-0.1
                    lib32-mesa-vdpau             18.0.4-0             18.1.0-0
                  lib32-vulkan-intel             18.0.4-0             18.1.0-0
                 lib32-vulkan-radeon             18.0.4-0             18.1.0-0
1 Like

lib32-wayland required deleting

  • /usr/lib32/libwayland-egl.so , libwayland-egl.so.1 , libwayland-egl.so.1.0.0

  • /usr/lib32/pkgconfig/wayland-egl.pc

ansible 2.5.3-2 solved my problem :wink:

1 Like

You mean after Xorg 1.20 broke our nvidia 304 and 340 series?

We downgraded Xorg 1.20 to the previous one.

Certainly not solved for us and not likely to be from the devtalk thread.

I suppose 1.20 will be breaking my Manjaro install shortly,

You may switch to testing. Only in unstable we have xorg-server 1.20 series for now, which is currently tagged as blocker package.

I'm using stable. I just posted in this thread because of the trauma of a non booting Arch yesterday and then discovering that nvidia will not do anything for legacy users.

Thanks anyway,


Update: There were a few very minor hiccups, but I made the transition to Nouveau from the proprietary 304xx, and have been using several days. I've been pleasantly surprised.

To get kwin usable, I had to switch compositor rendering backend to XRender from the default OpenGL 2.0. I had to tweak a few files, but it was less difficult, and more successful than any previous attempt to run Nouveau.

So far so good


Would you be so kind as to explain the steps you took?

PM if you don't want to post in this thread but it would be useful.
Maybe you could start another thread somewhere.
I think there are going to be more people in our situation.

thanks in advance


If you have issues with bumblebee, you may remove xf86-input-mouse package and see if that helps you out.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by