[Unstable Update] 2019-02-28 - Kernels, Plasma5, Systemd, Mesa, Xorg-Server, Deepin

I am fine :slight_smile:, @ JpegXguy not :wink:

Yes, it was released around the same time as latest 418, but that one was updated

Is anyone else experiencing the same problem with gnome control center after the latest round of updates 2019-03-13?

gnome-control-center -v                                                  
zsh: segmentation fault (core dumped)  gnome-control-center -v

Update: I restored the backup from yesterday with the same result.

Backup of 2019-03-11 has the latest working version of gnome-control-center.
So with the introduction of 18.0.4 it has been broken.

here is the full package list pending to update now, i will try to investigate it further.

Packages to update
Pakete (85) attica-5.56.0-1  colord-1.4.4-1  colord-sane-1.4.4-1
            double-conversion-3.1.4-1  e2fsprogs-1.45.0-1  glib2-2.60.0-1
            gtk-update-icon-cache-3.24.7-1  gtk3-3.24.7-1  gvfs-1.38.2-1
            gvfs-afc-1.38.2-1  gvfs-goa-1.38.2-1  gvfs-google-1.38.2-1
            gvfs-mtp-1.38.2-1  gvfs-smb-1.38.2-1  iana-etc-20190228-1
            imagemagick-7.0.8.33-1  kactivities-5.56.0-1  karchive-5.56.0-1
            kauth-5.56.0-1  kbookmarks-5.56.0-1  kcodecs-5.56.0-1
            kcompletion-5.56.0-1  kconfig-5.56.0-1  kconfigwidgets-5.56.0-1
            kcoreaddons-5.56.0-1  kcrash-5.56.0-1  kdbusaddons-5.56.0-1
            kglobalaccel-5.56.0-1  kguiaddons-5.56.0-1  ki18n-5.56.0-1
            kiconthemes-5.56.0-1  kio-5.56.0-1  kitemmodels-5.56.0-1
            kitemviews-5.56.0-1  kjobwidgets-5.56.0-1  knewstuff-5.56.0-1
            knotifications-5.56.0-1  kparts-5.56.0-1  kservice-5.56.0-1
            ktexteditor-5.56.0-1  ktextwidgets-5.56.0-1  kwallet-5.56.0-1
            kwidgetsaddons-5.56.0-1  kwindowsystem-5.56.0-1  kxmlgui-5.56.0-1
            ldb-1:1.4.6-1  lib32-cairo-1.16.0-2  lib32-colord-1.4.4-1
            lib32-glib2-2.60.0-1  lib32-libvdpau-1.2-1  lib32-pcre-8.43-1
            lib32-systemd-241.607-1  libmagick-7.0.8.33-1  libosinfo-1.4.0-1
            libphonenumber-8.10.6-1  libva-vdpau-driver-0.7.4-4  libvdpau-1.2-1
            libwbclient-4.9.5-1  libxcomposite-0.4.5-1  libxcursor-1.2.0-1
            libxdamage-1.1.5-1  libxmlb-0.1.7-1  lollypop-0.9.925-1
            lua52-lpeg-1.0.2-1  manjaro-release-18.0.4-1  protobuf-3.7.0-1
            qt5-base-5.12.1-3.1  rtkit-0.12-1  samba-4.9.5-1  smbclient-4.9.5-1
            solid-5.56.0-1  sonnet-5.56.0-1  srt-1.3.2-1
            syntax-highlighting-5.56.0-1  systemd-241.607-1
            systemd-libs-241.607-1  systemd-sysvcompat-241.607-1
            talloc-2.1.16-1  tdb-1.3.18-1  terminus-font-4.47-2
            tevent-1:0.9.39-1  threadweaver-5.56.0-1  vlc-3.0.6-9
            winetricks-20190310-1  xorg-xprop-1.2.4-1

The last set of updates was on 03/13 on the satble branch and on 3/11 on the testing branch. Are you sure your running on the unstable branch?

cat /etc/pacman-mirrors.conf                                             
##
## /etc/pacman-mirrors.conf
##

## Branch Pacman should use (stable, testing, unstable)
Branch = unstable

## Generation method
## 1) rank   - rank mirrors depending on their access time
## 2) random - randomly generate the output mirrorlist
# Method = rank

## Define protocols and priority
##   separated by comma 'https,http' or 'http,https'
## ATM available protocols are: http, https, ftp
## Not specifying a protocol will ban the protocol from being used
## If a mirror has more than one protocol defined only the first is written to the mirrorlist
## Empty means all in reversed alphabetic order
# Protocols =

## When set to False - all certificates are accepted.
## Use only if you fully trust all ssl-enabled mirrors.
# SSLVerify = True

yes :wink:

1 Like

The GNOME control center is known to crash with this version of glib2, both on Manjaro and on Arch Linux. Most likely the reason why glib2 has been downgraded to 2.58.3 in Testing notably.

There is not much you can do on your side as far as I know of, outside of temporarily downgrading glib2 and/or wait for updates.

1 Like

Thanks, that is the cause, downgrading to glib2 2.58.3-1 solves it.

Apparently had the same issue that @karserasl talked about - Black screen after boot, but terminal was responding. Trying to manually start an X session resulted in an error. I updated from the terminal and after reboot it worked again.

FYI. With todays update gnome-control-center works with glib2 2.60.0-1

1 Like

@philm, @oberon or someone else could please synchronize the unstable repo with arch?
Gnome 3.32 is already for two days now in arch stable.

1 Like

I've updated my distro, but it seems that version 3.30.2 is still in manjaro unstable repo. I see it in gnome-conrol-center and also in /usr/share/gnome/gnome-version.xml

Yes I know, because unstable repo still is not synchronized with arch.
Someone should do it. :slight_smile:

synced now. Have fun! :sunglasses:

4 Likes

@oberon many, many thanks! :smiley:

Well, we might have some issues with Gnome as it will break a lot of environments. So have fun with it :stuck_out_tongue:

It does -- GNOME is Great!

The Manjaro Linux Update Indicator is taking the color of the theme making it invisible....but it's THERE!!!

After one day of testing 3.32 there is nothing to report, everything works as expected.

Some 3rd party extensions are not working right now, but well... just give the devs some time to catch up.

Overall if you don't heavily rely on extensions, you're good to go with 3.32

One minor thing I noticed was that the terminal fonts were changed after the update to 3.32, so maybe the dconf settings were changed on update or I clicked something wrong :wink:

Update: one minor bug does exist, window focusing of gtk apps does not work if the app is started from the gnome overview. If started from a terminal it does get focus.

1 Like

Does it work with at least the extensions that are enabled by default on Manjaro Gnome?

My installs are M-A so I had to look up which extensions are used by Manjaro Gnome.

Not sure if other extensions are enabled by default, maybe @Ste74 can give more info here, what should be tested.

Forum kindly sponsored by