[Unstable Update] 2019-04-23 Kernels, Qt5, Deepin, KDE

Hi community,

After some little hickups with syncing from upstream we are now all set again for a fresh unstable update :partying_face:
Meanwhile I have updated pushed all updated

  • kernels and a
  • patched version of virtualbox fixing the issues booting Win7
    also we have
  • KDE apps 19.4
  • once more updated Deepin packages and
  • and an update for qt5

Detailed list of updated packages can be found here


  • Some additional updates were added 2019-04-24. See post below.
  • Also, just pushed a new point release of manjaro-settings-manager. Some small bugs were fixed and adjustments made. Thanks for your contributions included in this, @Frog (I think your the same frog, aren't you? :wink: ) and vfjpl - who's forum username I'm afraid I don't know and cannot guss ... :wink:

I have also just added some new patches to systemd and packaged a new point release 242.16. This should hopefully fix some remaining issues.
Thank you for testing and feeding back your discoveries as always :wink:
Also, still some more updates for Deepin have arrived.

Current supported Kernels

  • linux316 3.16.65
  • linux318 3.18.138 [EOL]
  • linux44 4.4.178 - ! see here !
  • linux49 4.9.170
  • linux414 4.14.113
  • linux419 4.19.36
  • linux420 4.20.17
  • linux50 5.0.9
  • linux51rc 5.1rc1.d0317.g9e98c67 (experimental. no extramodules, yet)
  • linux419-rt 4.19.31_rt18
  • linux50-rt 5.0.5_rt3
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


qt5-base needs to be updated, it breaks QT based DE's and apps.

It has already mentioned here and already fixed by @oberon :slight_smile:

1 Like

Well, it isn't on my mirror yet, so.....

[New Packages]

Cool job! Whoever is quick on going with the update, make sure you sync the mirrors then update. The problem with the qt5-base is solved.

Yep, hot it now. :slight_smile:

1 Like

Same problem, booted to black screen with mouse cursor, eventually qt5-base arrived. Was extracting a list to start downgrading........

All fine here.

A note for others like me - make sure to check up on your custom mirror lists from time to time. I left mine extremely trimmed but slightly out of date, so I was not getting the synced mirror that was available for my region. Once handled, I got access to all the fresh qt stuff, not just half of the update that was previously available.

I also tried, and just boot to a black screen with the mouse

If not all the packages were shown in the update, then it means you jumped the gun and/or your mirror wasnt fully synced yet.
You can downgrade some packages to get back to desktop, or wait/change mirrors, and run the full update.

[hint - you might need to use nmcli to get internet working]

I update my mirrors before every run, qt5-base was late :smiley:

Press ctrl-alt-f2 log in.

sudo pacman-mirrors -f5
sudo pacman -Syyu

@somebody1121 - this is for you.

1 Like

Mine were 'updated' and 'fast tracked' ... but my custom list was omitting some mirrors - none in my list were fully synced, but pacman-mirrors fell back on 1 of the available ones, despite it only being half-synced. Once I cleaned that up - fasttrack correctly returned the only functional mirror from my region, which was initially missing from my list.

Thanks, i just go to testing to revert

You guys are just too fast!
I sync the repo and see that qt5-base is included. By the time I have built our qt5 overlay and manjaro-settings-manager I already see 5 complaints about incompatible libraries ... :roll_eyes::stuck_out_tongue_winking_eye:
's all good man!


This is probably my mostest favouritest bestest Unstable Update for quite a while. Dunno if it's due to the latest kernel 5.0.9-2, or latest VirtualBox 6.0.6-2, or simply benevolent Mutant-Space-Goats, but today's update is the first time my Unstable KDE+GNOME VM's Shared Folders have worked with any 5.0.x kernel version.

My usual timezone gap protected me from the fun & games that apparently entertained the northern hemisphere early updaters re KDE, as it was all solved whilst i slept... hence my updated Plasma continues to run just fine. Furthermore when i logged the VM out of KDE & into GNOME, it is also a happy camper.

Much magnificence to the meticulous munificent Manjaroo Marvels responsible.


More updates added this morning. Notably:

  • chromium
  • vte3 - hopefully fixing some glitches with xfce4-terminal
  • qt5-base with an additional patch addressing an issue with disappearing systray icons
  • ruby 2.6.3 and
  • networkmanager 1.18

no problems with this set

I tried this now, now i don't have issues.

Forum kindly sponsored by