[Unstable Update] 2019-05-03 - Kernels, Backintime, Palemoon

Hi unstable community! :wink:

I have added some more packages, including more point releases for our kernels and latest versions of backintime and palemoon. The update for systemd is merely of cosmetic nature :wink:

My impression is that the set of packages can very soon move on to testing... let me know your concerns otherwise.
The current state of updated packages can be found here

Current supported Kernels

  • linux316 3.16.65
  • linux318 3.18.139 [EOL]
  • linux44 4.4.179 - ! see here !
  • linux49 4.9.172
  • linux414 4.14.115
  • linux419 4.19.38
  • linux420 4.20.17
  • linux50 5.0.11
  • linux51rc 5.1rc1.d0317.g9e98c67 (experimental. no extramodules, yet)
  • linux419-rt 4.19.37_rt19
  • linux50-rt 5.0.5_rt3
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Cool! I am waiting for stable next week or so

RIP qt4

                             qt4                    -             4.8.7-28
1 Like

@oberon @philm Here's all packages in current Testing that require or optionally require qt4 package.

[awesome@i56400 ~]$ sudo pacman -Syu
[sudo] password for awesome: 
Sorry, try again.
[sudo] password for awesome: 
:: Synchronizing package databases...
 core is up to date         0.0   B  0.00B/s 00:00 [----------------------]   0%
 extra is up to date        0.0   B  0.00B/s 00:00 [----------------------]   0%
 community is up to date    0.0   B  0.00B/s 00:00 [----------------------]   0%
 multilib is up to date     0.0   B  0.00B/s 00:00 [----------------------]   0%
 DEB_Arch_Extra             4.2 KiB  0.00B/s 00:00 [######################] 100%
 DEB_Arch_Extra.sig       280.0   B  0.00B/s 00:00 [######################] 100%
:: Starting full system upgrade...
 there is nothing to do
[awesome@i56400 ~]$ sudo pacman -Sii qt4
Repository      : extra
Name            : qt4
Version         : 4.8.7-28
Description     : A cross-platform application and UI framework
Architecture    : x86_64
URL             : https://www.qt.io
Licenses        : GPL3  LGPL  FDL  custom
Groups          : None
Provides        : None
Depends On      : sqlite  ca-certificates  fontconfig  libgl  libxrandr  libxv
                  libxi  alsa-lib  xdg-utils  hicolor-icon-theme
                  desktop-file-utils  libmng  dbus
Optional Deps   : postgresql-libs: PostgreSQL driver
                  mariadb-libs: MariaDB driver
                  unixodbc: ODBC driver
                  libfbclient: Firebird/iBase driver
                  libxinerama: Xinerama support
                  libxcursor: Xcursor support
                  libxfixes: Xfixes support
                  icu: Unicode support
                  sni-qt: StatusNotifierItem (AppIndicators) support
Required By     : fbreader  fcitx-qt4  freemat  gambas3-gb-qt4  gebabbel
                  hydrogen  ibus-qt  keepassx  keepassx2  launchy  lib32-qt4
                  libdbusmenu-qt4  liblightdm-qt4  openssh-askpass  qjson
                  qmpdclient  qt-at-spi  qtcurve-qt4  qwt5  qwtplot3d  tipp10
                  tuxcards  v4l2ucp
Optional For    : avahi  catalyst-utils  dssi  gcin  graphviz  i7z  scim
                  thrift  uim  wt  yate
Conflicts With  : qt
Replaces        : qt<=4.8.4
Download Size   : 21.04 MiB
Installed Size  : 85.14 MiB
Packager        : Evangelos Foutras <evangelos@foutrelis.com>
Build Date      : Sat 06 Apr 2019 08:57:11 AM EDT
MD5 Sum         : 2abc246ebd29a414a6206b09db2c0198
SHA-256 Sum     : 35ab0214944a726c73103ff5200309d123c6b0e30dd1545a04ad1e7a8b615a7a
Signatures      : 51E8B148A9999C34

[awesome@i56400 ~]$ 

Notably, it means that AMD Catalyst Control Centre (provided in catalyst-utils) won't work anymore because qt4 won't be available anymore.

It is the only package built by Manjaro Team that needs (optionally) qt4 as far as I know.

Considering the legacy status of Catalyst, we can say good bye to the Control Centre.

In my case:

$ sudo pacman -Rsn sni-qt
checking dependencies...

Packages (3) libdbusmenu-qt4-0.9.3+16.04.20160218-2  qt4-4.8.7-28  sni-qt-0.2.6-5

Looks as if it has been removed from Arch also:

Hi! Something's wrong with nvidia and 5.0.12:

$ optirun glxgears
[   39.631695] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[   39.631743] [ERROR]Aborting because fallback start is disabled.

4.19 and 5.1 are not affected. I haven't tried to rebuild 5.0 but I believe it might help.

I'm back to break things. nvidia driver I forgot to recompile. Should be fixed now. Now checking grub, which seems to be broken ...


Yep, sort of. But actually grub worked for me: before reboot I noticed that update-grub executable is missing, so I had to do grub-mkconfig -o /boot/grub/grub.cfg after I merged grub.pacnew with my grub conf file (wouldn't it be a good idea to add some kind of support for /etc/default/grub.d/custom.cfg to our grub in order to keep user-defined modifications intact?). Also I have a plethora of other loaders like refind, systemd-boot and vmlinuz itself so I'm on a safe side anyways.

Regarding above-mentioned /etc/default/grub.d/custom.cfg thingie: I mean it could be a good place for user to set his grub theme, background, kernel options like cryptdevice,etc. KDE Neon, for instance, uses similar file for setting its Breeze grub theme whereas their grub is actually a basic Ubuntu one (as far as I can tell).

I just updated this morning and upon rebooting when it goes to grub all I get is a command line with this: grub>

Not sure what to do from here.

You simply have no grub.cfg file. This was an issue due to packaging. You may chroot into your system and generate a new config file.

I gotta create a bootable USB. The old disk I have is too outdated and will not let me install mhwd-Chroot. What happened to cause this?

You can do it also oldschool:

mount -t proc proc /mnt/proc
mount -t sysfs sys /mnt/sys
mount -o bind /dev /mnt/dev
mount -t devpts pts /mnt/dev/pts/
chroot /mnt
1 Like

Where do I need to be in the terminal to do this?

Before this

do this:
mount /dev/sdXY /mnt
mount /dev/sdXZ /mnt/boot
mount /dev/sdXC /mnt/boot/efi
where sdXY is where the root of your system is located, and sdXZ - where /boot used to be (if it is located on a separate partition), and sdXC is your efi partition, if any.
Everything can be done within Manjaro live environment.

I am on my bootable usb and have mdwd-chroot installed. When I try the grub-mkconfig command I get this:

swapon UUID=d1b2c96b-59c0-49f2-91a9-d77ad04c5ba1
[root@manjaro /]# grub-mkconfig -o /boot/grub/grub/cfg
/usr/bin/grub-mkconfig: line 248: /boot/grub/grub/cfg.new: No such file or directory
[root@manjaro /]#

grub-mkconfig -o /boot/grub/grub.cfg
It's grub.cfg not grub/cfg

Well, darn, it worked that time. Let me reboot and give it a try.

I am back up and running. Thanks guys. Wonder what caused this?

If you want to know. I missed some files during the PKGBUILD redesign ...


Linux 5.0.12. I again encountered an issue similar to this. The only difference is it was related to /home partition, not root one. It just appears as corrupted upon reboot. Partition details: ext4, lvm, luks2 (the other lvm volume is root, esp is on unencrypted nvme0n1p1).

Forum kindly sponsored by