[Unstable Update] 2020-05-15 - Kernels, Cinnamon 4.6, Toolchain, PHP, AMDVLK, Pamac, Browsers

If I recompile qt5-styleplugins pamac uninstall manjaro-xfce-settings.

I haven't had any problems with recent updates...but I did notice this got promoted to the community repo several days ago. I was going to remove it but I just waited instead.

1 Like

Since update of 2020-06-03 login with Plasma-wayland [KWinFT / Wrapland] didn't work anymore for me.
Classic plasma no problem.

I backup to 2020-06-02

Upgraded again but not the packages related to qt5

I think is solved,

Jun 05 11:46:20  kernel: vboxdrv: loading out-of-tree module taints kernel.
Jun 05 11:46:20  kernel: VBoxNetAdp: Successfully started.
Jun 05 11:46:20  kernel: VBoxNetFlt: Successfully started.
Jun 05 11:46:20  kernel: nvidia: module license 'NVIDIA' taints kernel.
Jun 05 11:46:20  kernel: Disabling lock debugging due to kernel taint
Jun 05 11:46:20  kernel: NVRM: loading NVIDIA UNIX x86_64 Kernel Module  440.82  Wed Apr  1 20:04:33 UTC 2020

After the latest update, I'm getting a small hang on boot and a long one if I attempt a restart through tty2.

I'm back to qt5ct and used this on /etc/environment in my Xfce with some KDE apps, and is working:
QT_QPA_PLATFORMTHEME=qt5ct
QT_AUTO_SCREEN_SCALE_FACTOR=0
QT_STYLE_OVERRIDE=Breeze

With 5th of june update still no login with plasma Wayland [KWinFT / Wrapland].
Classic plasma works.

QT_SCREEN_SCALE_FACTORS=1.00
instead of
QT_AUTO_SCREEN_SCALE_FACTOR=0
better for fractional scaling?
Please comment:

plasma 5.19 does not boot to a GUI but to a black screen.

installing "plasma-workspace", "plasma-desktop", "kscreen", and "kscreenlocker" 5.18.5 makes the GUI reappear.
there seems something wrong with it.

i am using kwinFT.

same for me: plasma clasic does not boot to a GUI but to a black screen.
plasma Wayland [KWinFT / Wrapland] still short black screen, then login again
So in the moment nothing works....

i have now updated to 5.19 and it works fine.

but i needed to uninstall kwinFT (which is still as version 5.18.1 in the unstable repos) and install kwin.
the outdated version of kwinFT seems to be the cause of the problem.

i recommend to only move plasma 5.19 to the testing/stable branch when kwinFT 5.19 is available, too.

I am having this messages when update using pamac:

ldconfig: /usr/lib/libkdeinit5_kcminit.so não é um link simbólico

ldconfig: /usr/lib/libkdeinit5_klipper.so não é um link simbólico

ldconfig: /usr/lib/libkdeinit5_kcminit_startup.so não é um link simbólico

After update both (Plasma X and KWinFT) works again !

I removed the *.old libraries. Solved!

KDE Frameworks 5.71 landed for me this morning on Unstable. My VM did not re-start cleanly, but after I forced it down, it seemed to start normally with no immediate breakage.

I can confirm the above.
..
I can confirm the below as well.

Real hardware: smooth reboot, no issues with that.

I noticed a wide variety of font changes with the newest version of fontconfig (2:2.13.91+48+gfcb0420-1) -- I'd recommend soliciting extensive feedback before deploying to stable.

Forum kindly sponsored by