[Unstable Update] 2020-05-15 - Kernels, Cinnamon 4.6, Toolchain, PHP, AMDVLK, Pamac, Browsers

Do you have some examples? See also here: https://bugs.archlinux.org/task/67043?project=1&string=fontconfig

1 Like

Fonts did look a little off all over the place on first glance: sizes and spacing was different than before.
Screenshots are from mediathekview 13.5.1-3, the german umlauts aren't readable at all:

fontconfig 2.13.91+24+g75eadca-2
Screenshot_fontconfig_2.13.91+24+g75eadca-2

fontconfig 2.13.91+48+gfcb0420-1
Screenshot_fontconfig_2.13.91+48+gfcb0420-1
Simply downgrading the package fixed it, didn't investigate any further due to time constraints.

maybe we should do a git-bisect to find the issue. These are the commits so far. Wilde guess would be this:

What happens if you clear your cache?

Clearing the cache didn't improve the situation.
I tried bisecting: the last commit Drop Bitstream Vera fonts from 60-latin.conf (fcb042028126d79ea5a5fa015b2b034b98656e73) introduces the breakage for me.


edit: Although my "test case" is/was mediathekview there are visible changes introduced on sddm login screen with this commit as well.

I was just about to post that as well. It appears that favoring Nimbus font loading doesn't exactly jibe well here.

Please read this and check which fonts are installed on your system.

Seems Debian and Ubuntu added some patches which might be missing on Arch.

Seems they added it after all

https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/ttf-dejavu&id=72e33b26ad0e64c57b6422194f690a60243d93b2

Try to uninstall ttf-bitstream-vera which is broken anyway.

2 Likes
[Testing Update] 2020-06-23 - Kernel, KDE-git, Cinnamon, Firefox, Pamac, Plasma, Deepin
[Testing Update] 2020-06-26 - Kernels, Mesa 20.1.2, Haskell
[Testing Update] 2020-07-04 - Firefox, Jade, Deepin, LibreOffice, Curl
[Testing Update] 2020-07-08 - Kernel, Deepin, Gnome, Gambas, Plasma 5.19.3
[Stable Update] 2020-07-19 - Kernels, KDE, LibreOffice, Mesa, Cinnamon, Deepin, Pamac, Browsers
[Testing Update] 2020-07-11 - KDE-git, Firefox-beta, AMDVLK 2020.Q3-1, Fixes to Plasma 5.19.3
[Testing Update] 2020-08-07 - Kernels, KDE-git, Browser, AMDVLK, Mesa, Haskell, Python
[Testing Update] 2020-08-08 - Browsers, Systemd, Firmware, Pamac
[Testing Update] 2020-07-14 - KDE Frameworks 5.72, Linux57 with FSync, Firefox, Python, Haskell
[Testing Update] 2020-07-15 - Palemoon, Linux57 with Fsync/Futex, Vulkan-ICD, Deepin
[Testing Update] 2020-07-17 - Kernels, Firmware
[Testing Update] 2020-07-10 - Kernels, Deepin, KDE Apps 20.04.3, Firefox 78.0.2
[Testing Update] 2020-07-01 - Kernel, Fonts, Deepin, Browser, Thunderbird, Nvidia, AMDVLK
[Stable Staging Update] 2020-07-17 - Kernels, KDE, LibreOffice, Mesa, Cinnamon, Deepin, Pamac, Browsers
KDE fonts settings got ignored by GTK programs
[Stable Update] 2020-07-19 - Kernels, KDE, LibreOffice, Mesa, Cinnamon, Deepin, Pamac, Browsers
[Testing Update] 2020-07-22 - Kernels, VirtualBox, NextCloud, Deepin, OpenJDK
[Testing Update] 2020-07-25 - Kernels, Deepin, Mesa, AMDVLK, Python
[Testing Update] 2020-06-25 - Kernel, Plasma 5.19.2, Perl, Calamares, AMDVLK, Cinnamon, Deepin
[Testing Update] 2020-07-31 - Kernels, Plasma 5.19.4, Firefox 79, Deepin, UKUI, Systemd, Python

Thanks, I hadn't dabbled much with fonts before but the links you provided helped and explained the situation:

  • ttf-bitstream-vera was explicitly installed on my KDE system since it was set up
$ fc-match Sans
Vera.ttf: "Bitstream Vera Sans" "Roman"
$ fc-match Serif
VeraSe.ttf: "Bitstream Vera Serif" "Roman"
$ fc-match Mono
VeraMono.ttf: "Bitstream Vera Sans Mono" "Roman"

  • fontconfig changes to remove BitStream Vera from the font order made my system fallback to different fonts:
$ fc-match Sans
NimbusSans-Regular.otf: "Nimbus Sans" "Regular"
$ fc-match Serif
NimbusRoman-Regular.otf: "Nimbus Roman" "Regular"
$ fc-match Mono
Inconsolata-Regular.ttf: "Inconsolata" "Regular"
  • removal of ttf-bitstream-vera changed nothing
  • installation of ttf-dejavu restored readability
$ fc-match Sans
DejaVuSans.ttf: "DejaVu Sans" "Book"
$ fc-match Serif
DejaVuSerif.ttf: "DejaVu Serif" "Book"
$ fc-match Mono
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"

So the missing ttf-dejavu made the fontconfig change "look bad" in my case.

3 Likes

So it has just hit MJ's Unstable too. 96 updates on my side, what a number.

Along with Plasma there are updated Perl packages. I've got this warning:

(5/7) Warn about old perl modules
WARNING: '/usr/lib/perl5/5.30' contains data from at least 1 packages which will NOT be used by the installed perl interpreter.
 -> Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/5.30'

So I did:

$ pacman -Qqo '/usr/lib/perl5/5.30'

And I got:

apparmor

Apparently something is going to be borked after reboot?

1 Like

Reinstalling apparmor should fix it.

Off topic reply but the links to KDE-dev, and XFCE, KDE, Gnome flavors too, are dead, maybe better link directly to https://osdn.net/projects/manjaro-community/storage/kde-dev/ or other main pages for the specific flavors of Manjaro, instead of subversion that may disappear in the future (this way no breakage by copy/pasting the thread in the future).

Also really nitpicking but I think the #staysave has a typo :stuck_out_tongue: and probably should be #staysafe or maybe this is kind of a joke regarding backups (saves) and I didn't get it :smiley:

In the german publication "linuxuser spezial" (02/2020) I read about
INFORMANT. (AUR)
Well, that is not the STASI - but would this really be helpful before crashing an installation?!
(update will onlybe made AFTER reading notice regarding the update; looking into Forum
is not obsolete indeed, maybe less complaining :innocent:

DETAILS:

https://github.com/bradford-smith94/informant

New orphans?

$ pacman -Qdt
xorg-font-utils 7.6-6
xorg-fonts-alias 1.0.3-3

Stellarium 0.20.2 is now available and working.
There is still no distance information for objects, that never cross the horizon.
How to travel without this information (mainly: how much petrol / food do I need to fill up)?
(Wer ist der Mensch mit Werkvertrag bei Stellarium?)
(Who is the person with a "contract for work and labour" at Stellarium?)
how to reach--> arojas@archlinux.org

Yep. See Todo List: removal of "xorg-font-utils" transitional package

1 Like

Thank you. I did my usual
$ sudo pacman -Rsn $(pacman -Qqdt)
and have no immediate issues.

Kernel 5.7.8-1 breaks systemd.automount.

I only see these ...

SMB3: Honor persistent/resilient handle flags for multiuser mounts
SMB3: Honor 'seal' flag for multiuser mounts
SMB3: Honor 'posix' flag for multiuser mounts

See the full changelog. Or do you mean this: https://github.com/systemd/systemd/issues/16291

It's a NFS share, I will check out this evening what's going on.

No issues with 5.7.8-5.
I suspect it was a timing issue trying to mount the device too early.

Confirmed working here as well. I had additional tmpfs and firejail issues that have since resolved themselves.

Forum kindly sponsored by