[Unstable Update] 2020-05-15 - Kernels, Cinnamon 4.6, Toolchain, PHP, AMDVLK, Pamac, Browsers

plasma 5.19 does not boot to a GUI but to a black screen.

installing "plasma-workspace", "plasma-desktop", "kscreen", and "kscreenlocker" 5.18.5 makes the GUI reappear.
there seems something wrong with it.

i am using kwinFT.

same for me: plasma clasic does not boot to a GUI but to a black screen.
plasma Wayland [KWinFT / Wrapland] still short black screen, then login again
So in the moment nothing works....

i have now updated to 5.19 and it works fine.

but i needed to uninstall kwinFT (which is still as version 5.18.1 in the unstable repos) and install kwin.
the outdated version of kwinFT seems to be the cause of the problem.

i recommend to only move plasma 5.19 to the testing/stable branch when kwinFT 5.19 is available, too.

I am having this messages when update using pamac:

ldconfig: /usr/lib/libkdeinit5_kcminit.so não é um link simbólico

ldconfig: /usr/lib/libkdeinit5_klipper.so não é um link simbólico

ldconfig: /usr/lib/libkdeinit5_kcminit_startup.so não é um link simbólico

After update both (Plasma X and KWinFT) works again !

I removed the *.old libraries. Solved!

KDE Frameworks 5.71 landed for me this morning on Unstable. My VM did not re-start cleanly, but after I forced it down, it seemed to start normally with no immediate breakage.

I can confirm the above.
..
I can confirm the below as well.

Real hardware: smooth reboot, no issues with that.

I noticed a wide variety of font changes with the newest version of fontconfig (2:2.13.91+48+gfcb0420-1) -- I'd recommend soliciting extensive feedback before deploying to stable.

I downgraded to 2:2.13.91+24+g75eadca-2 because I had unreadable characters in some applications.

Noticed this too on XFCE

Do you have some examples? See also here: https://bugs.archlinux.org/task/67043?project=1&string=fontconfig

1 Like

Fonts did look a little off all over the place on first glance: sizes and spacing was different than before.
Screenshots are from mediathekview 13.5.1-3, the german umlauts aren't readable at all:

fontconfig 2.13.91+24+g75eadca-2
Screenshot_fontconfig_2.13.91+24+g75eadca-2

fontconfig 2.13.91+48+gfcb0420-1
Screenshot_fontconfig_2.13.91+48+gfcb0420-1
Simply downgrading the package fixed it, didn't investigate any further due to time constraints.

maybe we should do a git-bisect to find the issue. These are the commits so far. Wilde guess would be this:

What happens if you clear your cache?

Clearing the cache didn't improve the situation.
I tried bisecting: the last commit Drop Bitstream Vera fonts from 60-latin.conf (fcb042028126d79ea5a5fa015b2b034b98656e73) introduces the breakage for me.


edit: Although my "test case" is/was mediathekview there are visible changes introduced on sddm login screen with this commit as well.

I was just about to post that as well. It appears that favoring Nimbus font loading doesn't exactly jibe well here.

Please read this and check which fonts are installed on your system.

Seems Debian and Ubuntu added some patches which might be missing on Arch.

Seems they added it after all

https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/ttf-dejavu&id=72e33b26ad0e64c57b6422194f690a60243d93b2

Try to uninstall ttf-bitstream-vera which is broken anyway.

2 Likes
[Testing Update] 2020-06-23 - Kernel, KDE-git, Cinnamon, Firefox, Pamac, Plasma, Deepin
[Testing Update] 2020-06-26 - Kernels, Mesa 20.1.2, Haskell
KDE fonts settings got ignored by GTK programs
[Stable Update] 2020-07-19 - Kernels, KDE, LibreOffice, Mesa, Cinnamon, Deepin, Pamac, Browsers
[Testing Update] 2020-07-22 - Kernels, VirtualBox, NextCloud, Deepin, OpenJDK
[Testing Update] 2020-07-25 - Kernels, Deepin, Mesa, AMDVLK, Python
[Testing Update] 2020-06-25 - Kernel, Plasma 5.19.2, Perl, Calamares, AMDVLK, Cinnamon, Deepin
[Testing Update] 2020-07-31 - Kernels, Plasma 5.19.4, Firefox 79, Deepin, UKUI, Systemd, Python
[Testing Update] 2020-07-04 - Firefox, Jade, Deepin, LibreOffice, Curl
[Testing Update] 2020-07-08 - Kernel, Deepin, Gnome, Gambas, Plasma 5.19.3
[Testing Update] 2020-07-10 - Kernels, Deepin, KDE Apps 20.04.3, Firefox 78.0.2
[Testing Update] 2020-07-11 - KDE-git, Firefox-beta, AMDVLK 2020.Q3-1, Fixes to Plasma 5.19.3
[Testing Update] 2020-08-07 - Kernels, KDE-git, Browser, AMDVLK, Mesa, Haskell, Python
[Testing Update] 2020-08-08 - Browsers, Systemd, Firmware, Pamac
[Testing Update] 2020-07-14 - KDE Frameworks 5.72, Linux57 with FSync, Firefox, Python, Haskell
[Testing Update] 2020-07-15 - Palemoon, Linux57 with Fsync/Futex, Vulkan-ICD, Deepin
[Testing Update] 2020-07-17 - Kernels, Firmware
[Testing Update] 2020-07-01 - Kernel, Fonts, Deepin, Browser, Thunderbird, Nvidia, AMDVLK
[Stable Update] 2020-07-19 - Kernels, KDE, LibreOffice, Mesa, Cinnamon, Deepin, Pamac, Browsers
[Stable Staging Update] 2020-07-17 - Kernels, KDE, LibreOffice, Mesa, Cinnamon, Deepin, Pamac, Browsers

Thanks, I hadn't dabbled much with fonts before but the links you provided helped and explained the situation:

  • ttf-bitstream-vera was explicitly installed on my KDE system since it was set up
$ fc-match Sans
Vera.ttf: "Bitstream Vera Sans" "Roman"
$ fc-match Serif
VeraSe.ttf: "Bitstream Vera Serif" "Roman"
$ fc-match Mono
VeraMono.ttf: "Bitstream Vera Sans Mono" "Roman"

  • fontconfig changes to remove BitStream Vera from the font order made my system fallback to different fonts:
$ fc-match Sans
NimbusSans-Regular.otf: "Nimbus Sans" "Regular"
$ fc-match Serif
NimbusRoman-Regular.otf: "Nimbus Roman" "Regular"
$ fc-match Mono
Inconsolata-Regular.ttf: "Inconsolata" "Regular"
  • removal of ttf-bitstream-vera changed nothing
  • installation of ttf-dejavu restored readability
$ fc-match Sans
DejaVuSans.ttf: "DejaVu Sans" "Book"
$ fc-match Serif
DejaVuSerif.ttf: "DejaVu Serif" "Book"
$ fc-match Mono
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"

So the missing ttf-dejavu made the fontconfig change "look bad" in my case.

3 Likes

So it has just hit MJ's Unstable too. 96 updates on my side, what a number.

Along with Plasma there are updated Perl packages. I've got this warning:

(5/7) Warn about old perl modules
WARNING: '/usr/lib/perl5/5.30' contains data from at least 1 packages which will NOT be used by the installed perl interpreter.
 -> Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/5.30'

So I did:

$ pacman -Qqo '/usr/lib/perl5/5.30'

And I got:

apparmor

Apparently something is going to be borked after reboot?

1 Like

Forum kindly sponsored by