Unstable update: Hanging at dbus on reboot

The updates were:

───────┬──────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
       │ File: updates2019-06-26T23:41:50
───────┼──────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
   1   │ dbus 1.12.16-1 -> 1.12.16-1.1
   2   │ oh-my-zsh-git 5182.c105c04b6-1 -> 5183.5f743e1a8-1
   3   │ systemd 242.29-3 -> 242.29-4
   4   │ systemd-libs 242.29-3 -> 242.29-4
   5   │ systemd-sysvcompat 242.29-3 -> 242.29-4
───────┴──────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
10:29:00 ➜ ~/.updates ➜

I assume dbus is the problem, will update selectively and report back. This will be a slow process as I have got a lot on this morning :smiley:

maybe both dbus and systemd are problems.

Testing systemd now, but I accidently ran a pre-update timeshift, so it will be a while before I can reboot time for :coffee: and a cigarette :wink:

Well, systemd is not to blame. I can't see anything in journalctl.

Got to go, I am going to stick dbus in ignorepkg temporarily.

We removed the depends of apparmor in dbus. Might push a new version soon to see if that helps. Was dbus or dbus-x11 used?

Normal dbus, apparmor was removed when the new dbus was installed, but then machine would not boot.

Please test if dbus 1.12.16-1.2 fixes the dependency issue with apparmor. Please also test dbus-x11.

2 Likes

Yup, that fixed it.

dbus-x11 1.12.16-3...no problems.

Great, so we can mark this as solved. Current dbus removed the hard dependency of apparmor.

1 Like

My Unstable VM update tonight, & its reboot + login, went fine.

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by