Update stopped at grubsection, cant restart pamac. Can i Reboot?

2 weak old system hangs on update in what looks like the Grub section.
Have been reading about others having trouble booting after update so I have not tried a reboot.
I guess its easier to fix or check the system when its running then it would be after a possible no boot scenario.
I'm very thankful for help and will provide further logs if asked.

[2019-02-10 20:49] [ALPM-SCRIPTLET] Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img
[2019-02-10 20:49] [ALPM-SCRIPTLET] Fant initrd-bilde: /boot/intel-ucode.img /boot/initramfs-4.19-x86_64.img
[2019-02-10 20:49] [ALPM-SCRIPTLET] Fant linux-bilde: /boot/vmlinuz-4.19-x86_64
[2019-02-10 20:49] [ALPM-SCRIPTLET] Fant tema: /usr/share/grub/themes/manjaro/theme.txt
[2019-02-10 20:48] [ALPM-SCRIPTLET] Lager grub-oppsettsfil …
[2019-02-10 20:48] [ALPM] running '99-grub.hook'...
 some part deleted
[2019-02-10 20:48] [ALPM-SCRIPTLET] ==> Starting build: 4.19.20-1-MANJARO

Some Norwegian in the logs
Fant = Found

Things I have tried.
Start another instance of pamac, but not allowed cause another instance is waiting.
killall pamac
start new instance of pamac but is not allowed to do anything cause it is waiting

Start parted and gparted to take note of the disk setup in case there will be a no boot scenario.
But i doesn't start so tries to kill the processes with kill -9/or kill -15 but no luck.

Restarted x server with Ctrl+Alt +Backspace
I should have known better, of course problem it didn't help.

Things I have done earlier to the system.

  • First installed Cinnamon edition but later followed a guide to change to Deepin desktop environment.

  • I have activated AUR repository. I think i activated the options for "searching Aur for updates"
    It sounded like a good thing so I did that without really knowing why.

  • Maybe changed app handling system to pamac instead of Pacman. Dont know here, there is so many new words.

1 Like

you are one of the rare ones that actually reads, and knows not to reboot on a failed update of grub. :+1: (not sarcasm).

is the first update still running in the background?
close any package managers, then
check in terminal with top and make note of any pamac or pacman PID's.
from another terminal window you can
kill 1234 (replace 1234 with PID's from top, if any. you may need sudo)

re-run the update and post any errors, better yet. install wgetpaste first so you can post logs from each of the commands in full.
sudo pacman -S wgetpaste
sudo pacman -Syyu | wgetpaste (this will provide a link at the end, post it here)


At this point I'd also recommend falling back to pacman as it should work no matter what.

Combinations of pacman -Syu and update-grub will probably get things moving again.

1 Like

Thx for response =)

In a bit of a hurry, but i did find and killed 2 instances of pamac.
Killed them.
copied and then removed file /var/lib/pacman/db.lck

And the link is here.

Output for pacman -Syu is here
I save you a click =)

Some norweigian there but in the end it say "everything is done"

sudo pacman -Syyu
[sudo] passord for höjdhopparen: 
:: Synkroniserer pakkedatabaser...
 core                     148,5 KiB  1597K/s 00:00 [####################] 100%
 extra                   1863,4 KiB  1498K/s 00:01 [####################] 100%
 community                  5,2 MiB  1497K/s 00:04 [####################] 100%
 multilib                 186,7 KiB  1556K/s 00:00 [####################] 100%
:: Starter full systemoppgradering...
Alt er utført.

I tried to reinstall Grub and received some strange output.
Looks like my problem could be a software called flexnet installed in the startsector.

[höjdhopparen@nannanananina ~]$ sudo grub-install /dev/sda
Installing for i386-pc platform.
grub-install: warning: Sector 32 is already in use by the program `FlexNet'; avoiding it.  This software may cause boot or other problems in future.  Please ask its authors not to store data in the boot track.
Installation finished. No error reported.
[höjdhopparen@nannanananina ~]$ 

Edit , Flexnet issue is solved.
Disk had done job for Windows earlier and had Autocad installed.
Flexnet is some kind of licensing f%#¤% rootkit that also installs in the mbr.
Removed with instructions from https://lonewolfonline.net/uninstall-flexnet-software-updates-manager/
For future reference copy, erase first 62sectors of mbr with commands.

sudo dd if=/dev/sda of=/tmp/mbr.img bs=512 count=63
dd if=/dev/zero of=/dev/sda bs=512 count=62 seek=1

Reinstall grub

sudo grub-install /dev/sda

But it fails in the end when updating Grub so no reboot tonight either.

[höjdhopparen@nannanananina ~]$ sudo update-grub
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-4.19-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.19-x86_64.img
Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img
[höjdhopparen@nannanananina ~]$
1 Like

How long are you leaving it to do the update-grub?

It might also be worth reinstalling grub and the linux419 in case there's some corrupted or missing file.

You may leave it without an updated config, since the grub installation was successful.
When you (re)boot, use the "More Complicated Setups" method of the following tutorial, so you can boot and try again.
Later on, until you find a proper solution to have an auto-created grub.cfg, you may create a custom.cfg file or manually created grub.cfg with only one menu entry (for your installation) at


Instructions on this can be found with a forum search, or ask for assistance, when you decide.

It might be helpful if you post

sudo parted -l
sudo fdisk -l

I tried now, waited 10 minutes.

I didnt get any output from Parted , There are 5 parted processes I cant figure out how to kill.

sudo ps -A | grep parted
19101 ?        00:00:00 parted
19165 ?        00:00:00 parted
20109 ?        00:00:04 gpartedbin <defunct>
20177 ?        00:00:00 parted
20201 ?        00:00:00 parted
29117 pts/5    00:00:00 parted

But fdisk -l gives this

i ssd for system
and 2 disks that i havent touched in linux yet. (they was mirrored in windows)

Disk /dev/sda: 111.8 GiB, 120034123776 bytes, 234441648 sectors
Disk model: Corsair Force GT
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x41f207ec

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1       217026560 234436544  17409985   8.3G 82 Linux swap / Solaris
/dev/sda2            2048 217026559 217024512 103.5G 83 Linux

Partition table entries are not in disk order.

Disk /dev/sdb: 298.1 GiB, 320071851520 bytes, 625140335 sectors
Disk model: ST3320620AS     
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xc2fb8eac

Device     Boot Start       End   Sectors   Size Id Type
/dev/sdb1          63 625138286 625138224 298.1G 42 SFS

You will need to check with Flexnet on how to go about booting in Linux.

From flexnet wikipedia

Issues with bootloaders

Due to the way the digital rights management (DRM) works in FlexNet Publisher, FlexNet affects bootloaders; this makes FlexNet Publisher incompatible with drives encrypted with TrueCrypt[6][7] and renders Linux-based systems unable to boot.[8][9] The TrueCrypt developers also state that "the issue is caused by inappropriate design of the third-party activation software."[10]

And another thing - Your swap is in the first partition of the msdos disk.
Do not put that in the first partition. swap partition does not have a first sector. mbr is the first sector of the disk. If you do not want to have extra partitions (to waste disk space), just create a very small first partition of about 1 MB (any format - fat will do) in the first partition.

Good luck.

May I ask if you are sarcastic? I dont think they will respond.

Yes you are correct, I created swap first but forgot to look for options to put it at the end.
I will remove swap partition and go for a swap file later.
But could that be the cause of parted is not possible to quit and grub not updating?

You may ask. I am not being sarcastic. Their website says the package can be used for linux.
So go ask. Unless they are illegal (contravene non open source regulations).

I don't know on the parted part. It may be.
Some claim it was working (swap in first partition) for some time. But could be due to system not using swap before it becomes not working when swap was finally used.
grub part may be due to the flexnet thingy.

Swap partition is not on the beginning of drive.

Yes, it may not be but just maybe.
"not in disk order" though yes, OP has only 2 partitions makes that likely.
But the issue is not due to swap, but his flexnet putting a rootkit in the mbr.

And you've told him to try the ... er.. {what do you call it?} use the livecd menu way [more complicated setup]? I think it will work as it won't use his corrupted mbr and boots directly the kernels. But he hasn't responded on this. I personally don't mind others circumventing DRM and rent-seeking proprietary systems. We all just download 'free' music? Anyway ... the music industry had given up suing dancing babies long ago. We all have different lines to draw from babies to Autocads. And if big corporations through lobbying the Mafia extend their drm illegally ....why would/should the small guys pay.... Anyway... cheers.

1 Like

For future reference.

I did reboot and i t started, everything was ok.
Thx all =)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by