updating to kernel 5.1.1-2

I downloaded and installed 5.1.1-2 in KDE & Deepin editions, both systems are fully updated. When I am at the GRUB screen and go to advanced options, there is no option for the 5.1 version kernel. Both systems are working fine on the previous kernel but I am wondering what could be causing this? I also have GNOME edition and I do have the option for the 5.1 kernel.

Thanks for any suggestions!

You can install kernels through Manjaro Settings Manager.

Correct, I do have them installed. I just don't get the option to load the kernel on the boot menu.

try running sudo update-grub in a terminal session and post the output so we can see what is or is not happening.

[jlap4@jlap4MJkdeP ~]$ sudo update-grub
[sudo] password for jlap4: 
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.1-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.1-x86_64.img
Found initrd fallback image: /boot/initramfs-5.1-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.0-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.0-x86_64.img
Found initrd fallback image: /boot/initramfs-5.0-x86_64-fallback.img
Found linux image: /boot/vmlinuz-4.19-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.19-x86_64.img
Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img
Found Manjaro Linux (18.0.4) on /dev/nvme0n1p3
Found Manjaro Linux (18.0.4) on /dev/nvme0n1p4
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

that may be the stumbling block

Please do this:

and also sudo fdisk -l

Thank you! I will run those and post shortly. I agree that warning may be the problem. I have multi - booted several distros on a single machine before without this problem.

jlap4@jlap4MJkdeP ~]$ inxi -Fxzc0 
System:    Host: jlap4MJkdeP Kernel: 5.0.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: KDE Plasma 5.15.5 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 20KGS4JU00 v: ThinkPad X1 Carbon 6th serial: <filter> 
           Mobo: LENOVO model: 20KGS4JU00 v: SDK0J40697 WIN serial: <filter> UEFI: LENOVO v: N23ET55W (1.30 ) date: 08/31/2018 
Battery:   ID-1: BAT0 charge: 54.2 Wh condition: 55.5/57.0 Wh (97%) model: SMP 01AV430 status: Unknown 
CPU:       Topology: Quad Core model: Intel Core i5-8350U bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 30344 
           Speed: 752 MHz min/max: 400/3600 MHz Core speeds (MHz): 1: 700 2: 700 3: 700 4: 765 5: 700 6: 792 7: 700 8: 700 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.4 driver: intel unloaded: modesetting resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 19.0.4 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.0.15-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: 3.2.6-k port: efa0 bus ID: 00:1f.6 
           IF: enp0s31f6 state: down mac: <filter> 
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: efa0 bus ID: 02:00.0 
           IF: wlp2s0 state: up mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 52.74 GiB (5.7%) 
           ID-1: /dev/nvme0n1 vendor: Crucial model: CT1000P1SSD8 size: 931.51 GiB 
Partition: ID-1: / size: 245.07 GiB used: 20.44 GiB (8.3%) fs: ext4 dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 51.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 238 Uptime: 2m Memory: 15.42 GiB used: 1.45 GiB (9.4%) Init: systemd Compilers: gcc: 8.3.0 Shell: bash 
           v: 5.0.7 inxi: 3.0.34 

[jlap4@jlap4MJkdeP ~]$ sudo fdisk -l
[sudo] password for jlap4: 
Disk /dev/nvme0n1: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: CT1000P1SSD8                            
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 76C7100A-1EFF-46DD-A13C-C94C178684C8

Device              Start        End   Sectors  Size Type
/dev/nvme0n1p1       2048     821247    819200  400M EFI System
/dev/nvme0n1p2     821248  525105151 524283904  250G Linux filesystem
/dev/nvme0n1p3  525105152 1049389055 524283904  250G Linux filesystem
/dev/nvme0n1p4 1049389056 1573672959 524283904  250G Linux filesystem

My apologies is this isn't in the format you suggested.

looks like it's caused by memtest, it throws an error but doesnt inhibit function.

also, update-grub output shows 5.1 being detected. maybe look again. if it's not there, have you by any chance been using grub-customizer?

1 Like

I also have Manjaro w/ GNOME on this computer, that has 5.1 and I can use it. It's only the KDE & Deepin DEs that aren't giving me the option for 5.1
I'll look in the Deepin partition, I have tried the GRUB customizer before but I do not recall if I tried it with this install.

grub customizer causes alot of issues that end up breaking normal grub function, for example

  • update grub finishes, yet nothing is updated , no changes made
  • update-grub taking forever and a day to finish.

in other words, use at your own peril.

1 Like

This topic was automatically closed after 180 days. New replies are no longer allowed.

Forum kindly sponsored by