Upgrading M. 2 SSD Lenovo X1 carbon Gen 3

I googled as much information I thought I needed on my Lenovo X1 carbon 3rd generation. The normal places that give suggestions on upgrading hardware all said that I needed a PCIe NMVe SDD. So I picked up a Sabrent Rocket 1TB off of Amazon. I replaced it this morning. Loaded up Manjaro i3. Successful install. Reboot to 2103 SSD error.

So I tried KDE. Again successful install. And failure in the reboot.

I plugged my old HD back in and everything works perfect as it did before, so it's not my computer.

Crucial upgrade says I have the correct upgrade SSD, as does Tom's hardware. So, I thought, no worries, nice easy swap. I noticed that my old SSD actually says it's a PCIe ACHI and not PCIe NVMe as I was suggested to upgrade to. I cannot seem to find any to purchase do I still think I got the correct SSD.

After googling, I'm not the only person with the issue. Most seem unsuccessful in their attempts but a few said they got them working by updating their firmware and setting the but parameters to both (legacy and UEFI).

I have tried all the combinations suggested to no luck reinstalling Manjaro successfully each time.

My firmware is 100% up to date as of a few weeks ago. Anyone else out there successfully swapped a HD in their X1 carbon?

@Days we were talking about this in chat. @eugen-b if there's anything else you'd like to move here is cool too.

Search came up with very little success here and beyond. This was the only one on here.

1 Like

Check the usual Manjaro suspects:

  • Fast-Boot: Off
  • Secure Boot: Off

Is the drive partitioned via GPT?

I can't give an exact reference, but I've seen somewhere that some NVMe will not boot, and that the only workaround was to put the /boot partition on another (non-NVMe) drive.

Something else to try:

Boot from live cd. Chroot to the NVMe install. Do:

pacman -Syu nvme-cli

Then run:

sudo nvme list

1 Like

Fast boot isn't an option. Secure boot is disabled. Drive was partitioned with Manjaro automatic partitioning. I tried w/swap, w/swap and hibernate, and w/o anything. If I remove the new HD, and put my old one back in, Manjaro works fine still. So, I'm assuming firmware is correct, and it has to do with the SSD.

I had also read that in some of the googling. Some people said they fixed it, others had not managed to get it working. The people that said they got it working messed with firmware. I duplicated their layout exactly, and I did not have such luck. But, it seems like this may be true.

I will give the chroot stuff you suggested to see if it works. But, I'm pretty close to just giving up, and hoping they will allow me to return the SSD.

I can tell you that my M.2 SSD connected with an adapter to PCIe cannot be booted by the MB. It isn't shown in the boot device list of the MB. So I simply use another disk as boot device.

1 Like

I don't have room for another device inside my laptop, and I'd rather not boot to USB 100% of the time. That's pretty disheartening. The more I read, it seems my best option is to return this, or I guess get an external case for now until I buy another computer that might use this someday. :frowning:

You had 2 successful installs and in each, an unsuccessful reboot.

One question, before this replacement with Sabrent Rocket 1TB new disk , had you successfully installed Manjaro in the old disk? And if you had, was it in uefi or in bios-legacy? (2 questions ? :wink:)

Check if you can reboot using this topic and see if this topic applies.

And finally, it may be a firmware issue as eugen-b indicated and as the link you provided suggest.

It currently has an Arch install on it, and I'm even typing this from this very computer. I did have Manjaro on it before this Arch install. I'm actually just about to load the USB with Manjaro right now to put on the old HD again to double check it still works.

It was in UEFI. (I also tried Both this morning, which also didn't work. It is now currently in UEFI again and running Arch w/o issue)

Alright. Good. You should be able to boot up Manjaro per....

When booted, do 'grub-install' and the 2 [Additional UEFI commands] .
Oh, important. after you boot and before doing the commands, provide output of

efibootmgr -v

And again after completing the commands, (output of 'efibootmgr -v').

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by