USB Device Detection

Hi everyone.

Whilst I have been using Linux and Manjaro for a couple of years now, I am by no means a 'power user', hence the reason I'm posting in the 'newbie corner'.

I recently started using a new laptop (ASUS F555YI-XO049T) to replace my old ThinkPad. I have Manjaro working almost perfectly aside from issues detecting USB devices.

I have an external USB HDD which I have only had working on one occasion via the laptops USB 2.0 port. Currently it will not mount on any USB port, though it does spin up and the LED indicator lights up. It is not detected with lsusb. I same goes for a USB flash drive. This has worked on one of the USB 3.0 ports on one occasion, currently not working. I also just used my printer to print one page, which worked. I turned off the printer, and upon turning it back on, the system will not find it.

Output of lsusb with a printer, a flash drive and a USB HDD plugged in:

Bus 002 Device 002: ID 0438:7900 Advanced Micro Devices, Inc. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0bda:57b5 Realtek Semiconductor Corp. 
Bus 001 Device 002: ID 0438:7900 Advanced Micro Devices, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

This was never an issue on the ThinkPad, therefore I am wondering if this is a issue with my new machine, or a bug/configuration issue.

Any advice would be much appreciated.

Thank you.

so, it can find the usb interfaces ...
open a terminal and type: sudo journalctl -f
connect a usb device
is something happening in the log ?

btw: try a kernel update to kernel 4.5.4,
I did see something simular with the 4.4.10 kernel
reboot the machine, and try again

Hi @jsvsouth
Reboot.
Plug in USB HDD device.
Launch

sudo dmesg > dmesg.log

Paste dmesg.log file to pastebin.com site.

In general it's a better idea in this case to use journalctl (-f to follow) then dmesg.
with dmesg, it's possible that you don't see output of udev actions, that can be important here.

btw as an alternative for dmesg, you can use journalctl -k

Upon reboot and plugging in USB HDD to USB 3.0 port:

[jeremy@jeremy-asus ~]$ sudo journalctl -f
[sudo] password for jeremy:
-- Logs begin at Sun 2016-05-08 21:09:02 AEST. --
May 17 22:58:23 jeremy-asus gcr-prompter[1238]: 10 second inactivity timeout, quitting
May 17 22:58:23 jeremy-asus gcr-prompter[1238]: Gcr: unregistering prompter
May 17 22:58:23 jeremy-asus gcr-prompter[1238]: Gcr: disposing prompter
May 17 22:58:23 jeremy-asus gcr-prompter[1238]: Gcr: finalizing prompter
May 17 22:58:27 jeremy-asus gnome-keyring-daemon[735]: asked to register item /org/freedesktop/secrets/collection/Default_5fkeyring/2, but it's already registered
May 17 22:58:36 jeremy-asus manjaro-settings-manager-daemon[910]: error: failed to determine if system is up-to-date (pacman)!
May 17 22:58:36 jeremy-asus manjaro-settings-manager-daemon[910]: QProcess: Destroyed while process ("pacman") is still running.
May 17 22:58:40 jeremy-asus dbus[503]: [system] Failed to activate service 'org.bluez': timed out
May 17 22:59:57 jeremy-asus sudo[1543]: jeremy : TTY=pts/0 ; PWD=/home/jeremy ; USER=root ; COMMAND=/usr/bin/journalctl -f
May 17 22:59:57 jeremy-asus sudo[1543]: pam_unix(sudo:session): session opened for user root by (uid=0)

and dmesg.log available here: http://pastebin.com/gEvVYA1j

So the kernel is not seeing anything,
I suggest to update the kernel to the latest stable (not LTS) kernel,
You can use the manjaro-settings-manager to do this

1 Like

You have a core dump and major ACPI Errors due DSDT table:

[    6.511285] ACPI Error: [^^^PB2_.VGA_.AFN7] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[    6.511295] ACPI Error: Method parse/execution failed [\_SB.PCI0.VGA.LCDD._BCM] (Node ffff88022709bc58), AE_NOT_FOUND (20150930/psparse-542)
[    6.511306] ACPI Error: Evaluating _BCM failed (20150930/video-367)
[    6.511429] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:01/input/input10
[    6.549623] resource sanity check: requesting [mem 0x8d20c000-0x8d20ffff], which spans more than MSFT0101:00 [mem 0x8d20c000-0x8d20cfff]
[    6.549629] ------------[ cut here ]------------
[    6.549637] WARNING: CPU: 2 PID: 216 at arch/x86/mm/ioremap.c:198 __ioremap_caller+0x234/0x390()
[    6.549640] Info: mapping multiple BARs. Your kernel is fine.
[    6.549642] Modules linked in:
[    6.549644]  tpm_crb(+) video battery button acpi_cpufreq tpm_tis tpm processor sch_fq_codel nfs lockd grace sunrpc fscache ip_tables x_tables ext4 crc16 mbcache jbd2 sr_mod cdrom sd_mod atkbd libps2 ahci libahci libata xhci_pci ehci_pci xhci_hcd ehci_hcd scsi_mod usbcore usb_common i8042 serio
[    6.549673] CPU: 2 PID: 216 Comm: systemd-udevd Not tainted 4.4.8-1-MANJARO #1
[    6.549676] Hardware name: ASUSTeK COMPUTER INC. X555YI/X555YI, BIOS X555YI.508 09/02/2015
[    6.549678]  0000000000000286 00000000ce3e3cd8 ffff8802249379a0 ffffffff812d4d01
[    6.549683]  ffff8802249379e8 ffffffff817177b5 ffff8802249379d8 ffffffff81077772
[    6.549686]  000000008d20c000 ffffc90000cb0000 0000000000004000 0000000000000000
[    6.549690] Call Trace:
[    6.549699]  [<ffffffff812d4d01>] dump_stack+0x63/0x82
[    6.549705]  [<ffffffff81077772>] warn_slowpath_common+0x82/0xc0
[    6.549709]  [<ffffffff8107780c>] warn_slowpath_fmt+0x5c/0x80
[    6.549713]  [<ffffffff8107df17>] ? iomem_map_sanity_check+0x97/0xd0
[    6.549717]  [<ffffffff81065ae4>] __ioremap_caller+0x234/0x390
[    6.549721]  [<ffffffff81065c57>] ioremap_nocache+0x17/0x20
[    6.549726]  [<ffffffff812ed8c2>] devm_ioremap_nocache+0x42/0x80
[    6.549731]  [<ffffffffa02db284>] crb_acpi_add+0x154/0x2d0 [tpm_crb]
[    6.549736]  [<ffffffff813586d1>] acpi_device_probe+0x4f/0xf5
[    6.549741]  [<ffffffff813f8b42>] driver_probe_device+0x222/0x4a0
[    6.549745]  [<ffffffff813f8e44>] __driver_attach+0x84/0x90
[    6.549749]  [<ffffffff813f8dc0>] ? driver_probe_device+0x4a0/0x4a0
[    6.549753]  [<ffffffff813f677c>] bus_for_each_dev+0x6c/0xc0
[    6.549757]  [<ffffffff813f82fe>] driver_attach+0x1e/0x20
[    6.549760]  [<ffffffff813f7e4b>] bus_add_driver+0x1eb/0x280
[    6.549764]  [<ffffffffa0006000>] ? 0xffffffffa0006000
[    6.549767]  [<ffffffff813f97d0>] driver_register+0x60/0xe0
[    6.549771]  [<ffffffff813585a0>] acpi_bus_register_driver+0x3b/0x43
[    6.549775]  [<ffffffffa0006010>] crb_acpi_driver_init+0x10/0x1000 [tpm_crb]
[    6.549779]  [<ffffffff81002123>] do_one_initcall+0xb3/0x200
[    6.549785]  [<ffffffff811639c7>] do_init_module+0x5f/0x1d8
[    6.549790]  [<ffffffff810fdd2a>] load_module+0x21aa/0x2820
[    6.549793]  [<ffffffff810fabf0>] ? symbol_put_addr+0x50/0x50
[    6.549798]  [<ffffffff810fe4ee>] SyS_init_module+0x14e/0x190
[    6.549804]  [<ffffffff815a0eee>] entry_SYSCALL_64_fastpath+0x12/0x6d
[    6.549807] ---[ end trace 2fb249bbcd1a130c ]---
[    6.549815] resource sanity check: requesting [mem 0x8d210000-0x8d213fff], which spans more than MSFT0101:00 [mem 0x8d210000-0x8d210fff]

USB device as HDD is not seen in dmesg too...

I really hope that the kernel update helps .. If ACPI is the problem here (and that is possible):
maybe the parameter acpi=off can help ... because otherwise you have to play with a custom aml file,
and that's pretty advanced stuff ..

Kernel update seems to have fixed the issue. Thank you very much for your help.

Unfortunately the issue has returned. It was working okay immediately after the kernel update, but no more. Is this like to be related to ACPI?

  • HW issue
  • cable issue
  • HDD firmware issue

many posibilities

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by