USB ethernet dongle stopped working

Hi all, on my older Asus N56VZ laptop (running up to date Manjaro with kernel 5.4.18) I'm using an USB 3 hub and GE dongle which has been working great for a couple of years. Yesterday while I was VNC'ing to it the laptop lost power (the power cable had gone loose and the battery holds very little) and it shut itself down. After booting this problem came up.

As soon as the laptop boots the network works, I can load a few websites, then after about 30 seconds the network is lost and NetworkManager hangs, I can't even stop or reload it with systemctl, I have to reboot and even that hangs with 'A stop job is running for Network Manager' and I have to long press the power button.

If I boot with the dongle disconnected everything works including the wifi and the built in GE (which I don't use as it doesn't support WoL). But if I boot with the dongle connected NetworkManager goes awry again. If I connect the dongle after the laptop has already booted all works until I connect the network cable to it.

It doesn't look as a driver (r8152) issue as I've tried booting kernel 4.19.102 and installed 5.5.2 and no change. It would seem more like a NetworkManager problem. The dongle itself is good, it works under Ubuntu on the same machine, also I've tried another USB-GE dongle of another brand but with the same chip and it has the same problem. Any help appreciated.

Here are the logs beginning from when I plug in the dongle after the laptop is booted and the network is connected to the built-in GE enp4s0, I then move the cable to the USB dongle enp0s20u2u4 and it all looks fine until this line appear then the network is lost:

Feb 23 12:14:03 lt kernel: usb 4-2.4: reset SuperSpeed Gen 1 USB device number 3 using xhci_hcd

Is there any chance that you installed updates, but had not rebooted yet when this occurred.

Please post:

inxi -SMa; hwinfo --netcard --bluetooth | grep -Ei "(hotplug|speed|model|status|cmd|file|detected|driver:)" | grep -v "Config S" && echo "System install date $(head -n1 /var/log/pacman.log | cut -d " " -f1 | cut -c 2-11)" 
sudo dmesg  | grep -Ei 'error|fail|firm|regdom|wmi|wl|qos|deauth|denied|broke|crda|80211|enp0|eth0|8152' | grep -viE 'acpi|ras|nvidia'

Hi, thanks for your reply.

Is there any chance that you installed updates, but had not rebooted yet when this occurred.

No, I always reboot after I install important Manjaro stable updates, also I've tried the dongle on my main laptop also running the latest Manjaro stable and it works fine. Something broke with that unfortunate power cut.

Here are the info you requested.

A reboot of your router, switching ports on the router, and replacement of your network cable is standard troubleshooting methodology. I hate mentioning it, because you seem like an experienced user (but it should be done regardless).

You may want to try downgrading network manager. Not a good long term solution, but it may help troubleshoot your issue.

The other option might be to install networkmanager-iwd from the AUR.

Be sure to do a system backup before making changes to your setup.

Don't worry, any idea is welcome as it's easy to overlook things when troubleshooting. I've rebooted my router and the cable and port are good as they work with the built-in GE.

I've been thinking more about it and it points to an USB problem, for some reasons the dongle gets reset and then it stops working, the message below always pops up before the network is lost. The weird thing is it only affects this Realtek chip, other USB 3 devices are working fine.

kernel: usb 4-2.4: reset SuperSpeed Gen 1 USB device number 3 using xhci_hcd
sudo dmesg | grep usb

I simulated your issue and found these steps worked to fix Network Manager connectivity.

After the improper shutdown I had no connectivity.

I found a permissions problem trying to change settings in Network Manager afterwards.

Reset perms on your home directory to your user account:

sudo chown -R $USER: ~/

Reinstall Network Manager from an older cached version in:

/var/cache/pacman/pkg

Use this command to install from your package cache:

sudo pacman -U /var/cache/pacman/pkg/networkmanager-1.22.8-1-x86_64.pkg.tar.zst

You may substitute any older Network Manager version from your package cache in the above command (if you wish).

After restarting my connectivity was restored.

I have no idea if this procedure will work in your case, as I can not predict results on a different system.

2 Likes

Thanks a lot, I'll try that tomorrow, I've been away all day today.

I have similar problem - USB 3.0 hub with Gigabit Ethernet (R8152/3 chipset) and randomly disconnecting or even hanging whole notebook, usually after some idle time.

Trying to switch kernels (5.5, 5.4, 4.19), downgrade NetworkManager ... but nothing helped.

Now I'm testing if problem isn't the firmware - take a look at https://www.spinics.net/lists/netdev/msg628862.html

In my syslog is often error about USB disconnecting followed by firmware error

[ 1298.307691] usb 2-3.2.3: new SuperSpeed Gen 1 USB device number 28 using xhci_hcd
[ 1298.325622] usb 2-3.2.3: New USB device found, idVendor=0bda, idProduct=8153, bcdDevice=30.00
[ 1298.325629] usb 2-3.2.3: New USB device strings: Mfr=1, Product=2, SerialNumber=6
[ 1298.325634] usb 2-3.2.3: Product: USB 10/100/1000 LAN
[ 1298.325637] usb 2-3.2.3: Manufacturer: Realtek
[ 1298.325641] usb 2-3.2.3: SerialNumber: 000001
[ 1298.408315] usb 2-3.2.3: reset SuperSpeed Gen 1 USB device number 28 using xhci_hcd
[ 1298.429147] r8152 2-3.2.3:1.0: unused bp5 is not zero
[ 1298.429155] r8152 2-3.2.3:1.0: check USB firmware failed
[ 1298.429165] r8152 2-3.2.3:1.0: unable to load firmware patch rtl_nic/rtl8153a-4.fw (-14)

After installing current linux-firmware package from unstable (20200224.r1582.efcfa03-1) messages changes to

...
[ 1960.634102] r8152 2-3.2.3:1.0: load rtl8153a-4 v2 02/07/20 successfully
[ 1960.660463] r8152 2-3.2.3:1.0 eth0: v1.11.11
...

and now I'm waiting for next crash.

EDIT: after firmware update network adapter disconnects still but doesn't hang computer
EDIT: after blacklisting adapter in TLP and reboot adapter stay connected whole night

Similar problem here. My laptop starts with working network, it then loses connection couple of minutes after that (I think it happens when it goes idle). On restart it gets stuck on 'A stop job is running for Network Manager'.

By reverting some of the recent package updates I found that the recent tlp-1.3.1-2 update causes the problem for me.

3 Likes

Have something similar here, with DELL Latitute 5500. Not a dongle, but when I am connected LAN I have frequent disconnection/reconnection.... and indeed, twice the desktop freezes (after some idle time) and I had to switch console (Alt-F2, and back Alt-F1) to regain control.
I thought it could be a NetworkManager issue also, so I downgraded but it was worst (since the update to Plasma 18, testing channel). So I have reinstalled the last version of NetworkManager.
Now, after reading the OP I have try to disconnect the LAN cable and to work with Wifi only.... IT WORKS!. No more connection/reconnection since now 10 hours (I had those every 20 minutes or so) and no freeze after coming back from lunch.
I didn't try to downgrade TLP like suggest @DobromirM, nor to blacklist the adapter like did @ivoshm. I may try those tomorrow if I have time. Anyway working wifi is - at least for me - at the moment a working workaround.

Downgrading tlp has fixed it for me too! Thanks a lot. I hadn't even noticed that update, I did it together with Firefox and another couple of minor packages updates so I didn't reboot. That untimely power cut put me on the wrong track but in fact it was the reboot that kicked in the tlp problem...

Thanks everyone for the input, great community!

For the record:
Only TLP downgrading didn't help in my situation ... I have to install newer linux-firmware too (now is available in stable-staging branch so looks like temporary problem with exact hardware).

1 Like

My USB network adapter seems to be disconnecting and reconnecting every so often (RTL8153).

It seems TLP is in charge of autosuspending USB devices. It can configured to blacklist some devices to avoid autosuspend.

To do so you can create a new file in /etc/tpl.d and either disable autosuspend for USB devices (or just blacklist your network adapter):
sudo sc -c "echo 'USB_AUTOSUSPEND=0' >> /etc/tlp.d/10-networkfix.conf"

This seems to have fixed my problem.

Docs:
https://linrunner.de/tlp/settings/usb.html

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by