USB Keyboard reacts slow: kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling

Hi,
on testing, and with the new kernel 5.0.1, i cannot write emails in thunderbird anymore, because the usb keyboard undeterministic reacts to slow. Even writing this post..
e.g if i write: Hello dear friend, only the characters He de fri were written...

edit: hmm sometimes in 4.20.15 this happens too, but not so often???
I am using an ednet usb 2.0 hub, but only for the mouse. The keyboard plugs into the PC.

inxi -Fxzc0
System:
  Host: Kernel: 4.20.15-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Xfce 4.13.3 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: P5WD2-Premium v: Rev 1.xx 
  serial: <filter> BIOS: American Megatrends v: 0422 date: 05/27/2005 
CPU:
  Topology: Single Core model: Intel Pentium 4 bits: 64 type: MT 
  arch: Netburst Smithfield rev: 3 L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 bogomips: 11245 
  Speed: 2810 MHz min/max: N/A Core speeds (MHz): 1: 2810 2: 2810 
Graphics:
  Device-1: NVIDIA GT215 [GeForce GT 240] driver: nvidia v: 340.107 
  bus ID: 08:00.0 
  Display: x11 server: X.Org 1.20.4 driver: nvidia 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GT 240/PCIe/SSE2 v: 3.3.0 NVIDIA 340.107 
  direct render: Yes 
Audio:
  Device-1: Intel NM10/ICH7 Family High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Device-2: NVIDIA High Definition Audio driver: snd_hda_intel v: kernel 
  bus ID: 08:00.1 
  Sound Server: ALSA v: k4.20.15-1-MANJARO 
Network:
  Device-1: Marvell 88E8001 Gigabit Ethernet vendor: ASUSTeK driver: skge 
  v: 1.14 port: 7800 bus ID: 01:05.0 
  IF: enp1s5 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Intel 82573V Gigabit Ethernet vendor: ASUSTeK driver: e1000e 
  v: 3.2.6-k port: 9800 bus ID: 03:00.0 
  IF: enp3s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 447.14 GiB used: 75.57 GiB (16.9%) 
  ID-1: /dev/sda vendor: Seagate model: ST3160023A size: 149.05 GiB 
  ID-2: /dev/sdb vendor: Seagate model: ST3320620NS size: 298.09 GiB 
Partition:
  ID-1: / size: 286.04 GiB used: 75.57 GiB (26.4%) fs: ext4 dev: /dev/sdb1 
  ID-2: swap-1 size: 6.47 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb2 
Sensors:
  Message: No sensors data was found. Is sensors configured? 
Info:
  Processes: 155 Uptime: 15m Memory: 2.93 GiB used: 1.14 GiB (39.0%) 
  Init: systemd Compilers: gcc: 8.2.1 clang: 7.0.1 Shell: bash v: 5.0.0 
  inxi: 3.0.32

wohohooo, at kernel 4.20.15-1-MANJARO #1 SMP PREEMPT Sun Mar 10 08:50:44 UTC 2019 x86_64 GNU/Linux

journalctl -p3 -xb

-- Logs begin at Mon 2017-09-11 22:07:44 CEST, end at Wed 2019-03-13 22:24:20 CET. --
Mär 13 22:03:15 kernel: ACPI Error: Method parse/execution failed _PR.CPU1._PDC, AE_INVALID_TABLE_LENGTH (20181003/psparse-516)
Mär 13 22:03:15 kernel: ACPI Error: Method parse/execution failed _PR.CPU2._PDC, AE_INVALID_TABLE_LENGTH (20181003/psparse-516)
Mär 13 22:03:27 systemd-vconsole-setup[455]: /usr/bin/loadkeys failed with exit status 1.
Mär 13 22:03:27 systemd-vconsole-setup[454]: /usr/bin/loadkeys failed with exit status 1.
Mär 13 22:04:17 systemd-logind[547]: Cannot find the ESP partition mount point.
Mär 13 22:04:52 colord-sane[1025]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Mär 13 22:17:31 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:17:37 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:17:38 colord-sane[1565]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Mär 13 22:17:46 colord-sane[1644]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Mär 13 22:17:54 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:18:01 colord-sane[1690]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Mär 13 22:18:01 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:18:04 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:18:05 kernel: usbhid 5-2:1.1: can't add hid device: -71
Mär 13 22:18:05 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:18:07 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:18:08 colord-sane[1756]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Mär 13 22:18:09 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:18:12 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:18:13 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:18:15 colord-sane[1850]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Mär 13 22:18:17 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:18:22 colord-sane[1974]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Mär 13 22:19:23 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:19:30 colord-sane[2106]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Mär 13 22:21:03 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:21:09 colord-sane[2180]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Mär 13 22:21:52 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:21:59 colord-sane[2294]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Mär 13 22:22:27 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:22:29 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:22:33 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:22:33 colord-sane[2361]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Mär 13 22:22:42 colord-sane[2457]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Mär 13 22:22:43 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:22:50 colord-sane[2502]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Mär 13 22:22:55 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:22:58 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:23:01 colord-sane[2565]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Mär 13 22:24:13 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:24:16 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:24:16 kernel: usb 5-2: can't set config #1, error -71
Mär 13 22:24:17 kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 13 22:24:20 colord-sane[2671]: io/hpmud/pp.c 627: unable to read device-id ret=-1

never had this usb errors before...

lsusb
Bus 005 Device 010: ID 04d9:1503 Holtek Semiconductor, Inc. Keyboard

lsusb -t

/:  Bus 08.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/:  Bus 07.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/:  Bus 06.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/:  Bus 05.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
    |__ Port 2: Dev 9, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
    |__ Port 2: Dev 9, If 1, Class=Human Interface Device, Driver=usbhid, 1.5M
/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/4p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 3: Dev 3, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/8p, 480M

LF

1 Like

at
5.0.1-1-MANJARO #1 SMP PREEMPT Sun Mar 10 10:34:49 UTC 2019 x86_64 GNU/Linux
also the usb mouse freezes randomly.

journalctl -p3 -xb
kernel: ACPI Error: Method parse/execution failed \_PR.CPU1._PDC, AE_INVALID_TABLE_LENGTH (20181213/psparse-531)
Mär 16 14:05:45  kernel: ACPI Error: Method parse/execution failed \_PR.CPU2._PDC, AE_INVALID_TABLE_LENGTH (20181213/psparse-531)
Mär 16 14:06:05  kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 16 14:06:05  kernel: usb 2-1-port3: disabled by hub (EMI?), re-enabling...
Mär 16 14:06:06  kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 16 14:06:06  kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 16 14:05:58  systemd-vconsole-setup[456]: /usr/bin/loadkeys failed with exit status 1.
Mär 16 14:05:58  systemd-vconsole-setup[455]: /usr/bin/loadkeys failed with exit status 1.
Mär 16 14:07:21  systemd-logind[592]: Cannot find the ESP partition mount point.
Mär 16 14:08:24  kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 16 14:08:24  colord-sane[1129]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Mär 16 14:08:32  colord-sane[1210]: io/hpmud/pp.c 627: unable to read device-id ret=-1
a lot of dmesg
[   30.080113] usb usb5-port2: disabled by hub (EMI?), re-enabling...
[   30.088028] usb 5-2: USB disconnect, device number 4
[   30.513381] usb 5-2: new low-speed USB device number 5 using uhci_hcd
[   30.777768] usb 5-2: New USB device found, idVendor=04d9, idProduct=1503, bcdDevice= 3.10
[   30.777774] usb 5-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[   30.777777] usb 5-2: Product: USB Keyboard
[   30.777779] usb 5-2: Manufacturer:  
[   30.829436] input:   USB Keyboard as /devices/pci0000:00/0000:00:1d.2/usb5/5-2/5-2:1.0/0003:04D9:1503.0009/input/input29
[   30.884405] hid-generic 0003:04D9:1503.0009: input,hidraw1: USB HID v1.10 Keyboard [  USB Keyboard] on usb-0000:00:1d.2-2/input0
[   30.953406] input:   USB Keyboard System Control as /devices/pci0000:00/0000:00:1d.2/usb5/5-2/5-2:1.1/0003:04D9:1503.000A/input/input30
[   31.010326] input:   USB Keyboard Consumer Control as /devices/pci0000:00/0000:00:1d.2/usb5/5-2/5-2:1.1/0003:04D9:1503.000A/input/input31
[   31.010543] hid-generic 0003:04D9:1503.000A: input,hidraw2: USB HID v1.10 Device [  USB Keyboard] on usb-0000:00:1d.2-2/input1
[   31.093568] usb usb5-port2: disabled by hub (EMI?), re-enabling...
[   31.101268] usb 5-2: USB disconnect, device number 5
[   31.603395] usb 5-2: new low-speed USB device number 6 using uhci_hcd
[   31.867771] usb 5-2: New USB device found, idVendor=04d9, idProduct=1503, bcdDevice= 3.10
[   31.867777] usb 5-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[   31.867780] usb 5-2: Product: USB Keyboard
[   31.867783] usb 5-2: Manufacturer:  
[   31.918462] input:   USB Keyboard as /devices/pci0000:00/0000:00:1d.2/usb5/5-2/5-2:1.0/0003:04D9:1503.000B/input/input32
[   31.973839] hid-generic 0003:04D9:1503.000B: input,hidraw1: USB HID v1.10 Keyboard [  USB Keyboard] on usb-0000:00:1d.2-2/input0
[   32.043446] input:   USB Keyboard System Control as /devices/pci0000:00/0000:00:1d.2/usb5/5-2/5-2:1.1/0003:04D9:1503.000C/input/input33

at kernel 5.0.2-2-MANJARO #1 SMP PREEMPT Thu Mar 14 07:54:42 UTC 2019 x86_64 GNU/Linux
still
kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling..

journalctl -p3 -xb
-- Logs begin at Mon 2017-09-11 22:07:44 CEST, end at Sat 2019-03-16 14:47:19 CET. --
Mär 16 14:44:47  kernel: ACPI Error: Method parse/execution failed \_PR.CPU1._PDC, AE_INVALID_TABLE_LENGTH (20181213/psparse-531)
Mär 16 14:44:47  kernel: ACPI Error: Method parse/execution failed \_PR.CPU2._PDC, AE_INVALID_TABLE_LENGTH (20181213/psparse-531)
Mär 16 14:45:02  systemd-vconsole-setup[410]: /usr/bin/loadkeys failed with exit status 1.
Mär 16 14:45:02  systemd-vconsole-setup[409]: /usr/bin/loadkeys failed with exit status 1.
Mär 16 14:46:16  systemd-logind[549]: Cannot find the ESP partition mount point.
Mär 16 14:46:25  kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 16 14:46:27  kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 16 14:46:39  kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 16 14:46:57  kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 16 14:46:59  colord-sane[1221]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Mär 16 14:47:03  kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 16 14:47:10  colord-sane[1320]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Mär 16 14:47:12  kernel: usb usb5-port2: disabled by hub (EMI?), re-enabling...
Mär 16 14:47:16  kernel: usb 2-1.3: device descriptor read/64, error -71
Mär 16 14:47:19  colord-sane[1388]: io/hpmud/pp.c 627: unable to read device-id ret=-1

There is something mentioned about EMI in this post
https://bbs.archlinux.org/viewtopic.php?id=222614

  • a source of electrical noise nearby may be upsetting that port.

Why is happening on kernel 5 and 4.20, i have no clue. Did you try other kernel from the LTS family; like 4.19 and/or 4.14 ?

Are those USB3 ports? Did you try switching to other ports and make sure are USB2 ?

Have you looked to update the BIOS, is quite old and apparently there is a beta release in 2010
https://www.asus.com/Motherboards/P5WD2_Premium/HelpDesk_BIOS/

Hi,
the only EM noise is the power supply in the computer (-;
only usb1 + usb2
i'll try older kernels
no promising posts found at google so far...
i know, its an old BIOS.. never did an bios update for a kernel

dmesg --level err

[    0.609932] ACPI Error: Method parse/execution failed \_PR.CPU1._PDC, AE_INVALID_TABLE_LENGTH (20181213/psparse-531)
[    0.610130] ACPI Error: Method parse/execution failed \_PR.CPU2._PDC, AE_INVALID_TABLE_LENGTH (20181213/psparse-531)
[  109.559839] usb usb5-port2: disabled by hub (EMI?), re-enabling...
[  110.813177] usb usb5-port2: disabled by hub (EMI?), re-enabling...
[  122.813114] usb usb5-port2: disabled by hub (EMI?), re-enabling...
[  141.293008] usb usb5-port2: disabled by hub (EMI?), re-enabling...
[  147.292932] usb usb5-port2: disabled by hub (EMI?), re-enabling...
[  156.306229] usb usb5-port2: disabled by hub (EMI?), re-enabling...
[  160.492842] usb 2-1.3: device descriptor read/64, error -71
[ 2767.547145] usb usb5-port2: disabled by hub (EMI?), re-enabling...
[ 2942.533066] usb usb5-port2: disabled by hub (EMI?), re-enabling...
[ 3076.292442] usb usb5-port2: disabled by hub (EMI?), re-enabling...
[ 3108.532365] usb usb5-port2: disabled by hub (EMI?), re-enabling...
[ 3297.544773] usb usb5-port2: disabled by hub (EMI?), re-enabling...

LF

Is not for the kernel but for the machine itself. It will help whatever OS ...

I'll try another usb port fist (-:

hahahaha this was a "wired" one. The cable from my usb keyboard was laying onto my 6-times-power-connector with integrated over-voltage protection and beneath the printer power-supply. This was causing the disturbing EM-field.

Now no more re-enabling errors
dmesg --level err

[    0.609282] ACPI Error: Method parse/execution failed \_PR.CPU1._PDC, AE_INVALID_TABLE_LENGTH (20181213/psparse-531)
[    0.609490] ACPI Error: Method parse/execution failed \_PR.CPU2._PDC, AE_INVALID_TABLE_LENGTH (20181213/psparse-531)

LF

1 Like

Today i got it again, but only once

dmesg --level err
[    8.308426] usb usb5-port2: disabled by hub (EMI?), re-enabling...

the keyboard cable is safe..
i'll watch it.., or i'll give some distance between the 6x-power-connector to the computer

You can also see this if you tether a phone with an unshielded or too-long USB cable and try charging it while using the data connection, especially if you coil the cable.

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by