USB Stuck at Grub/Boot Drive in grub - rescue

I removed my manajaro partion on a Windows 10 dual boot system forgetting grub was installed there. So my boot drive is stuck in grub-rescue. I try to boot a USB3 flash drive with latest Manjaro KDE ISO burned using dd from terminal in gparted. If I boot it as UEFI I get stuck at Grub rescue as well. If I boot it with out UEFI it shows a black screen that says GRUB on it but I can not execute any type of command. How do I fix grub or boot manjaro from the flash drive to reinstall manjaro and grub?


You have to install Manjaro as same mode (UEFI or bios-legacy) as windows.

From where did you get your gparted booted?

If you 'remove' manjaro partition, you really have no choice but to reinstall Manjaro.
If you do not want to install Manjaro and want only windows, you have to reinstall windows boot.

I don't get the menu though. I tried hitting c as soon as I select to boot from usb. Didn't work.

I booted gparted from said flash drive but choose to install gparted to ram. I then deleted Manjaro partion and used dd to wrote iso to flash drive.

I want to dual boot and reinstall manjaro.

Okay. Good luck.
But I think there's something wrong in your making install usb for Manjaro.
I can't help much with it. But if others here can help, that will be good.
Er... I think OP now cannot boot windows and don't have any linux OS; just a gparted flash drive.
Take care, @Xplorer4x4.

ps: But not sure how he replies on this forum. :grin:
maybe from his mobile phone.

Yes using an android phone to respond. :frowning:
The flash drive was no longer being used by gparted so therefore I used dd to copy/burn the iso to the flash drive. The drive now has manjaro on it. When I boot in bios mode it boots to a screen that just says GRUB and a blinking indicator that won't proceess any input. Can I somehow get the flash drive to get past this grub screen?

Are you saying you boot up that gparted flash and use 'dd' command in its terminal to make an install usb to that same usb? Okay....

People, please help out. I don't have liveusb's and I don't boot live usb's.
If I had one, at the grub menu, I'll type 'e' at the install entry and copy down that menuentry and print it out for @Xplorer4x4 here.

Can you guys help him out here? Thanks.
ps: in bios-legacy mode, please note.

Does it matter I do not get a menu when trying to boot Manjaro from usb?

I don't know how to answer this as I do not understand the question.
But try this.....
At that blcak screen with "GRUB" on top, arrow down 2 times.
Then press 'enter'
Wait for at least 20 secs or longer, if over 2 minutes, it doesn't work.

I tested that. It did not work. Thank you for trying to help @gohlip! I'm wondering if said information could be pulled from a git repo of the source code?

I don't know. (I understand this question :grinning: )

I think the best bet is for you to go to another computer with a flash drive and make an install cd there.
Read up how to do that from windows (Rufus, Etcher?) and how as well (may need some thingies like using 'dd' instead of 'iso'...etc).
It is also possible your current flash drive (ex-gparted drive) may be faulty (like not having squashfs files etc..) and the parameters others can provide may not work as well.

Good luck, take care and have fun .

1 Like

As a last resort is there a way to use my phone as a flash drive? I see it is possible with Rufus but that would require a pc..

Don't know and haven't done it.

I agree with last @gohlip advice.
Booting from Android is said to work with an app, but since Android versions vary, as app versions, it's not so easy. I tried many times in the past with poor results.

If you can't create a proper Manjaro usb installer, you may try to boot and use your current.
For help, read that linked tutorial .
When you land on black screen with grub> prompt, use the relevant instructions in the tutorial to find and boot Manjaro grub (USB ISO). If it succeeds you may try several boot parameters concerning your hardware. If it fails, it's a sad result :sob:
Maybe try a non-USB3 port, I have done this on my hardware to get usb boot.

I am not getting a grub prompt though. It just says GRUB and has a flashing indicator and the system is frozen. I have tried usb2 ports as well.

It means, either your ISO is not properly written to the drive, or the USB drive is not capable to boot from the selected port.
Try another port (preferably not USB3), or try another USB drive, or write again the ISO.

The iso was burned to the flash drive in gparted using dd from a terminal so it shouldn't be an issue.

As for ports, as I said, I have tried other ports and it still does not work. I tried USB3 and USB2 ports. No luck.

Further more, I have no os to use to burn the image again or try to edit any boot parameters.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by