Using §-key as a shortcut disables s-key

I have a Swiss keyboard, so the key left of "1" is the paragraph sign (§). I want to use it as shortcut to open the Yakuake drop-down terminal, but when I assign the key, the s-key stops working correctly. It is still registered, as Shift+s still results in a capital s, but nothing happens when it's pressed on its own.
The paragraph sign can also be written by Shift+AltGr+s, maybe that has something to do with the problem. Also, if I set the shortcut to Ctrl/Shift/Alt/Meta+§, the s-key works normally.

Is there a way to fix this?

I just updated to 18.0.3 (KDE), but this was also the case on 18.0.2.

inxi:

System:    Host: [-] Kernel: 4.19.23-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.15.0 
           Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASRock model: Z370 Extreme4 serial: <filter> UEFI: American Megatrends v: P3.20 
           date: 09/12/2018 
CPU:       Topology: 6-Core model: Intel Core i7-8700 bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 12.0 MiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 76632 
           Speed: 800 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
           9: 800 10: 800 11: 800 12: 800 
Graphics:  Device-1: NVIDIA GM204 [GeForce GTX 980] driver: nvidia v: 415.27 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.3 driver: nvidia tty: N/A 
           OpenGL: renderer: GeForce GTX 980/PCIe/SSE2 v: 4.6.0 NVIDIA 415.27 direct render: Yes 
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: ASRock driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Device-2: NVIDIA GM204 High Definition Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Sound Server: ALSA v: k4.19.23-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: 3.2.6-k port: f000 bus ID: 00:1f.6 
           IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 3.07 TiB used: 47.75 GiB (1.5%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 840 PRO Series size: 238.47 GiB 
           ID-2: /dev/sdb vendor: Seagate model: ST3000DM001-9YN166 size: 2.73 TiB 
           ID-3: /dev/sdc vendor: SanDisk model: SD8SBBU120G1122 size: 111.79 GiB 
RAID:      Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 bus ID: 00:17.0 
Partition: ID-1: / size: 92.35 GiB used: 47.75 GiB (51.7%) fs: ext4 dev: /dev/sdc2 
           ID-2: swap-1 size: 17.16 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdc3 
Sensors:   System Temperatures: cpu: 35.0 C mobo: N/A gpu: nvidia temp: 50 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 30% 
Info:      Processes: 264 Uptime: 2h 47m Memory: 15.60 GiB used: 2.62 GiB (16.8%) Init: systemd Compilers: gcc: 8.2.1 
           Shell: bash v: 5.0.0 inxi: 3.0.30 

Without a swiss keyboard, I can't do anything to test (UK here), but perhaps some pointers:

xev -event keyboard

From a terminal, see what the keys are sending.

Pick another key? The menu key is rarely used, it's what I use.

Or take a hint from Monty Python:
https://www.youtube.com/watch?v=to22rRnK7gE

(Sorry couldn't resist)

Well, I'm now using a workaround by changing the key to tilde using xmodmap, and setting tilde as shortcut in the system settings.
Still playing around with the key events (thanks for the suggestion!), but I think this is a bug when using the swiss keyboard layout. Can I report this bug somewhere?

No idea where it should be reported sorry.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by