Using livecd v17.0.1 (and above) as grub to boot OS with broken bootloader

I don't think you can if m-a is a stand-alone iso.
But if you have any other OS in your system using grub2, regardless of distro, you can use their grub menu (press 'c').

1 Like

I have Ubuntu Budgie 18.04 LTS amd64 bootable USB which was created in May 2018 to test run Live boot Ubuntu session.

Will give it a try. Hopefully it wud work.

If you boot up this Ubuntu livecd in uefi, it should give a grub menu.
But if booted in bios-legacy, it would not.
Don't know if you want to boot up in uefi or in bios-legacy, but take note.

ps: Ubuntu said it would use grub for all uefi and bios-legacy, but it hasn't for 18.04.
Manjaro live is all grub, uefi or bios-legacy.

What I said earlier is if you have an existing installed linux OS using grub2 in your system, either uefi or bios-legacy, it would work.

1 Like

Manjaro Architect uses grub2 and it works.

I have legacy bios and it did not work as you said so instead i used Manjaro Architect Live boot iso. on Boot Menu / grub menu pressed 'c' and smooth sailing thereafter. I cud fix grub after booting manjaro as explained in the original post on this thread.

1 Like

You're welcome.

1 Like

Sharing alternative approach to boot OS with broken bootloader.

Note: I have legacy BIOS and steps detailed below works for me. I hope UEFI Bios / GPT setup wud also work provide relevant efi grub was installed and configured correctly.

We can also boot manjaro using Super Grub 2 Disk.


Just 20 mb iso file. write it to a usb drive or add it to multiboot usb.

Boot ur pc with Super Grub 2 Disk bootable USB and select first option to detect OS. Thereafter Manjaro Grub Menu is displayed along with other linux distros if multiple OS exist.

You can also boot desired kernel for desired OS if multiple linux distros with multiple linux kernel installed.

1 Like

Note this is a major update on how to get back our broken Manjaro bootloader since the introduction of fedora-grub. All edited at first post.
Some notes below.

  1. grub version 2.03.2-1 (or later)
  2. There is no need to set or unset menu_auto_hide though that by the stanza's in 01_header and 01_menu_auto_hide will also work.
  3. hidden menu has "Welcome to Grub" removed.
    Some distros, when compiling grub, has that removed as well by removing a couple of lines in stock grub.
  4. 'countdown' in all stock or recompiled grub will show a small countdown timer and will not show "Welcome to Grub"
  5. fedora-grub will, by 00_header and 01_menu_auto_hide and using grubenv, automatically hide menu if Manjaro is the sole OS. Other distro's do that as well in a less convoluted way.
    And users by themselves can manage it manually in much more simpler way without the use of grubenv or changing stanza's in /etc/grub.d
  6. In Fedora and related distros, different grub.cfg are generated for bios-legacy and uefi.
  7. grubenv causes issues for some filesystems like f2fs or btrfs (no sparse file) as well as other complications (like lvm or encryption).
  8. grub, is itself simple, just kernels and the path to it.
    Simpler than refind definitely, as simple as systemd-boot, just much more versatile.
    In taking advantage of its versatility, we created more complications (and more things that can go wrong) than it's worth.

God bless you Sir gohlip! Something foobard my 4.19.16-1 update installation early this week. The first two lines of your Simple First Start got me back to my desktop (many times!) until I could figure out how to restore GruB.

I do have a Samsung 960 NVME drive as legacy bios boot. I was refused nvme0n1p1 ( / ) with the "embedded blacklist" error by grub-install. /dev/nvme0n1 worked :smiley:

Your choice of beverage when we meet

1 Like

What do you mean 4. When booted at part Simple First Start ? Does it mean boot uo to live OS?

I don't see which topic you need help on this.
Your topic is on yakuake session short cuts which I am not familiar with though I use kde.
But to answer you above,

So you do not boot up to livecd OS at all.
At step 4. you would then boot up to the installed OS (in your computer hard drive), not the livecd OS. Hope this is clear.


1 Like

Just saw your reply at Windows 10 - Update 1809 breaking grub that no need chroot to solve that problem. Make above question(reply) to make sure each steps.

This thread is not mine about yakuake shortcut, so my topic here is about broken bootloader.

Sorry to have taken up your time on yakuake shortcut thread and thanks for your reply.

By the way, never heard 保重 at new year before.


1 Like


Chotomate. Thats how its translated in japanese? Thats not correct. See what is the meaning in russian?
Sumimasen, oh. spasbah.

Oh, it's "take care, happy new year". I just tried to translate your original Chinese message. What makes you think that's incorrect? I am pretty sure it is correct (I'm a graduated Japanese interpreter - that was long ago but I still remember some things).
By the way, chottomatte has double "t", ちょっと待って(ください). Small "tsu" doubles the next consonant.

In Russian it's "Береги себя. С новым годом!" (Bereghí sebyá. S nóvym gódom)

谢谢 (btw this word sounds like "sesie" - at least in Google translate - but both hieroglyphs are the same - I mean it looks strange to me. Is it a common thing in Chinese?)

1 Like

Yes, it chinese, but it is old style. Too many strokes. But I'm old enough when the new style was introduced.:smile: I was taught old style in school, introduced new style after I left school.

But always be careful when translating. Translating to English from other languages may mean differently when read by native English speakers, for example, a simple 'you're welcome' is often translated as ''doesn't matter' or 'small thing' from french or italian, 'please' from german, 'don't be polite' from chinese, 'return' from indonesian and do on. And of course there can be major gaffes like trying to say 'ashamed' in indonesian.

And there is this story/joke about Nixon asking Mao how often he has elections. Mao replied, 'every night.' I hear his translator was fired. Okay, bad joke.

[edit] - it is the new style. but when writing, we often use even shorter forms, anyway we seldom write anymore - all typing, so we don't need to know how to write and many young chinese forget how to write.


"findmnt" is a great find :slight_smile:
Thank you gohlip. I enjoy reading your boot comments. Especially 'efi'.
New computer, first time with 'efi' . A challenge.

1 Like

Just here to say my deepest thanks! You saved my -rear end- with your Uefi specific trouble shooting!

Thank you so very much! I was already about to give up as the system on its own would just not boot without the detour over the liveUSB

thanks thanks thanks

1 Like

What if I have two outputs that are the same:

grub> search.file /etc/manjaro-release
hd0,msdos1 hd0,msdos1

I'll type these outputs out later when on my desktop (on my phone now).

More info at error: file `/boot/grub/i386-pc/normal.mod` not found..

Use them both! One at a time.. :laughing:
What else can you do? :man_shrugging:

1 Like

Forum kindly sponsored by