Using nVidia on a ThinkPad T540p

Hi.

I'm new to Arch and as such new to Manjaro.

I have:
ThinkPad T540p, Core i5-4210M, Intel HD 4600 + nVidia GT730M GPU setup.
manjaro-xfce-20.0.3-200606-linux56.iso (downloaded today, date of post).

During installation I chose "non-free" and from what I can tell ended up with bumblebee, which I understand to be less desirable due to performance hits.
I see nothing among the default installed packages that might indicate a control panel of sorts for controlling which GPU is used, and ideally I just want this machine to use nVidia exclusively.

From what I understand, bumblebee should offer some form of automatic GPU offloading mechanism, redirecting loads between Intel and nVidia as appropriate, but during my first exploration on this machine I found that the nVidia control panel is unusable, and I ended up trying a non-bumblebee nVidia-390 driver which resulted in loss of display funtionality.
I then wiped and reinstalled Manjaro, again choosing "non-free".

I have looked around the forum and ended up with FAQ topic " [[HowTo] Set up PRIME (output offload) with NVIDIA proprietary driver]".

I followed this path on first login to a cleanly installed system:

  1. Removed bumblebee through Manjaro Settings Manager
  2. Installed nvidia-390 through Manjaro Settings Manager
  3. Removed /etc/X11/xorg.conf.d/90-mwhd.conf
  4. Created /etc/X11/xorg.conf.d/optimus.conf with the following data
Section "Module"
    Load "modesetting"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1:0:0"
    Option "AllowEmptyInitialConfiguration"
EndSection

I checked lspci | grep -E "VGA|3D" and it returned the following:

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GK208M [GeForce GT 730M] (rev a1)

This leads me to believe the tutorial suggested BusID "PCI:1:0:0" should be correct.

  1. Removed mhwd-* files from /etc/modprobe.d/
  2. Created /etc/modprobe.d/nvidia.conf with the following data
blacklist nouveau
blacklist nvidiafb
blacklist rivafb
  1. Created /etc/modprobe.d/nvidia-drm.conf with the following data
options nvidia-drm modeset=1
  1. Created /usr/local/bin/optimus.sh with the following data
#!/bin/sh

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto
  1. Executed chmod a+rx /usr/local/bin/optimus.sh
  2. Edited /etc/lightdm/lightdm.conf and added the following line to the top of the file, directly under [Seat:*]
display-setup-script=/usr/local/bin/optimus.sh
  1. Rebooted machine.

While booting no text is shown on the display, the backlight flashes once, then the display is turned off entirely rendering the system completely inoperable.
I forced a shutdown using the power button, then rebooted into the Manjaro live environment to verify if I made any typing errors..
At this point I learned that lightdm.conf contains two [Seat:*] sections, so I tried adding the display configuration line to the second section and rebooted again.
This time the backlight flashed twice during boot, and the backlight remained on but the display remains blank.

I tried another time with the display configuration line commented out in the top [Seat:*] section with the same result.
At this point I have no graphical interface available, only text terminals.

I'm.. a bit disappointed, I hoped this would be easier nowadays.
Could someone give me a hint as to what I may have missed?

Hybrid GPU devices are major PITA. Messing manually with drivers is usually ending badly.

Undo the changes and maybe try installing optimus-manager or optimus-switch. There are guides for those on the forum, but today the server is struggling, showing errors so I can't find the link.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by