Using PacUI produces output related to end of life kernels

Using the (excellent) Command line PacUI and after selecting Option 2 (Clean System) the following message was received ...
The following Linux kernels have reached their end-of-live (sic) status.
Do not expect any security or stability fixes for those kernels anymore.
Kernel modules are likely to break. Please remove these Linux kernels:
linux44
linux49
...........
Now a check of the installed kernels in Settings Manager has me a little confused. I see the main kernel listings and the next line under each shows further references to the kernels installed and/or available. For example, I see, Linux4.4.89-1 and on the next line it says linux44. I have that kernel as installed but not running for I am running Linux 4.9.52-1 (its next line says it's linux49). So when it says as above that I should remove linux44 and linux49 should I move off 4.9.52-1 at this point? I note that 4.9.52-1 is LTS and Recommended :roll_eyes:

According to kernel.org those kernels are not EOL.

Not being the current LTS kernel is not the same thing as being EOL.

Both 4.4 and 4.9 are definitely alive and kicking... and will be for another 6 years.

What is the version of pacui did you installed? The latest version of pacui should state Maintain System as option 2

~ >>> expac "Name\t: %n\nVersion\t: %v" pacui                                                                                                                           
Name	: pacui
Version	: 1.7-2

Screenshot_2017-10-08_17-56-24

Yes thefallenrat, I do seem to have the latest version of PacUI because it does indeed say at option 2 "Maintain System" and the "about" shows 0.8.6 as the version. I was referring to a print out I'd obtained here and that mimics the latest menu but not precisely.

sueridgepipe, I rather think there must be some kind of bug in the Maintain System option. Perhaps the person or people (on this forum) who were instrumental in writing PacUI could chime in? It is just that the warning message is off-putting.

And finally, I imagine there are quite a few who use PacUI so perhaps someone else could run it and see if they get the same warning message?

@excalibur1234 is listed as the author so it's worth asking him. :slight_smile:

See also:

This is wrong. There is no about page, and the latest version is 1.7-2 which included this commit that I think supposedly fixed the issue :

When is the last time you updated your system?

1 Like

My mistake, I checked the about page on the terminal! Boy was that a silly mistake for what that yields of course is the XFCE terminal version!.
Yes, Jonathan, I will follow this up with excalibur1234.
Cheers.

i just ran "pacui m" (the Maintain System option in pacui) on my system and neither linux413 nor linux49 was shown to me as EOL.

in order to know, whether a kernel is EOL, the Maintain System option uses the difference between the following 2 commands:

mhwd-kernel -li
mhwd-kernel -l

please run them on your system and give me the output. the first command should list all installed kernels and the second all available kernels.

also you could run a
pacman -Qi pacui
which should return:

..
Version         : 1.7-2
..

The following kernels are installed in your system:

  • linux-rt-lts-manjaro
  • linux44
  • linux49

available kernels:

  • linux316
  • linux318
  • linux41
  • linux412
  • linux413
  • linux414
  • linux44
  • linux49
  • linux-rt-lts-manjaro
  • linux-rt-manjaro

1.7-2 (confirmed).

So excalibur1234, is that message consistent with what is to be expected? ....

The following Linux kernels have reached their end-of-live status.
Do not expect any security or stability fixes for those kernels anymore.
Kernel modules are likely to break. Please remove these Linux kernels:
linux44
linux49

it looks like both command work as expected and there is something wrong in pacui.

please run the following commands (which get used by pacui to display the warning message) and give me the result of the last command:

 rm /tmp/.installed_kernels /tmp/.available_kernels /tmp/.eol_kernels &>/dev/null
 mhwd-kernel -li 2>/dev/null | awk '/ linux/ {print $2}' > /tmp/.installed_kernels
 mhwd-kernel -l 2>/dev/null | awk '/linux/ {print $2}' > /tmp/.available_kernels
 comm -13 /tmp/.available_kernels /tmp/.installed_kernels  > /tmp/.eol_kernels
 cat /tmp/.eol_kernels

alternatively, you can install "pacui-git" from the AUR (which was patched by me yesterday to use these commands) and test, whether the problem persists.

Hello excalibur1234, and thank you for your help with this.
I firstly, followed the individual commands you suggested and the last one cat /tmp ... results in ....
cat /tmp/.eol_kernels
linux44
linux49

I then ran pacui again and option 2 "Maintain System" and got a broken symbolic link to Firefox (although I suspect that was because I had FF open when I rang pacui). More significantly, the warning message persists.
I will now close FF and install pacui-git from the AUR and test if the problem persists.

Installed pacui-git and the problem persists unfortunately. I am quite bemused that I seem to be Robinson Crusoe with this problem. I mean, where is the code that produces that particular warning?

Update-notifier uses similar method to determine eol kernels, and it gives me erraneous warnings every now and then. I'm not sure yet sure why that is.

Interesting Chrysostomus. Well, I've just run the pacui again and I am now (since implementing the command line actions that excalibur1234 suggested) getting the following:

checking installed kernels ...
comm: file 2 is not in sorted order
The following Linux kernels have reached their end-of-live status. 
Do not expect any security or stability fixes for those kernels anymore. 
Kernel modules are likely to break. Please remove these Linux kernels: 
linux44
linux49

PS please forgive the larger type in my replies. The type seems to be the unwanted larger size font whenever I've copied and pasted from the terminal screen so not sure why that happens.

It happens because you separate the terminal output with those lines made of dots. Use code tags instead. Select text and press that button that looks like

   </>

Thank you Chrysostomus.

we can try to eliminate this warning message with the following commands:

 rm /tmp/.installed_kernels /tmp/.available_kernels /tmp/.eol_kernels &>/dev/null
 mhwd-kernel -li 2>/dev/null | awk '/ linux/ {print $2}' | sort > /tmp/.installed_kernels
 mhwd-kernel -l 2>/dev/null | awk '/linux/ {print $2}' | sort > /tmp/.available_kernels
 comm -13 /tmp/.available_kernels /tmp/.installed_kernels  > /tmp/.eol_kernels
 cat /tmp/.eol_kernels

does the problem persist?
if this is the case, i am baffled and do not know why the "comm" command is not working as intended on your system.

Forum kindly sponsored by