V18.0.3 installation media fails with encryption in autopartition mode

Hey there,

as already mentioned in here i will post the steps here.

1)create a virtualbox with efi boot
2)start and insert latest kde iso 18.0.3
3) Installsteps:
01_install 02_install 03_install
4) install and reboot
then grub rescue will show up

I don't use VM but try this.

That is required for "special" OS's, no need for Manjaro install in Virtualbox.


I had the same issues with the newest version of the installer(18.0.3 gnome) and a nvme disk.
Using the previous version(18.0.2) or disabling encryption in the 18.0.3 version both worked for me.

That is true, however Manjaro should also boot up with enabled EFI.
Did this a couple of months ago in my installation testing, but that was with VBox 5.
It's still recommended to use non-EFI though, which IIRC is only really needed with MacOS guests.

So do we have some issue with the latest ISO? We went thru several testing and it worked. Let me try it again on a VM.

Seems this issue also affects this install media. We didn't change the code in CAL. I've to downgrade again to v239 series to fix this and keep testing in later systemd releases until we have a proper working version. Sorry for that. So the systemd-saga seems not to end yet ...

1 Like

The issue seems to be cryptsetup v2.1.0 here. When using v2.0.6 it works also with systemd v241 series ...

@sueridgepipe: can you give it also a whirl on your end?

Downloading it now, rest of the house is streaming so is taking a while.

Bah ... bloody netflix ... this is take ages!

I might have found a solution I'm currently testing. Maybe you can double-check by creating a fresh unstable ISO when all packages are online.

From my testing there was no issue with full system encryption, I'll retest with 18.0.3.

The home encryption crash was caused by a crypttab keyfile reference which didn't actually exist. Remove this reference and no errors.

Cryptsetup 2.1 was not the cause of any errors, systemd was not the cause of errors, Calamares luks config was.

Yes I know. That is why I pushed some fixes to unstable. Will test them later also on my end. With v18.0.3 I managed to get a crash during encryption in CAL. Also I was able to get the same issue as the user to land in grub-rescue mode ...

Please note my earlier [Unstable Update] 2019-02-22 - Systemd, Cryptsetup, Go, Python - might break encrypted systems with luks. Latest KDE ISO Calamares aborts 100% of the time i try to create:


It works fine if i abandon LUKS & make those individual partitions ordinary ext4... but that's NOT what i want.

I think 18.0.3 encrypted install is broken, I could complete my installs but couldn't get any full encrypted systems to boot.

Phil has cut a new 18.0.4 pre2 ISO with fixes, I'm attempting an installation now.

1 Like

I expect identical failure, but atm i am trying the same install on my Lappy... just to eliminate the root cause possibly being my perennial Tower poultrygoose.

UPDATE: Yep, Lappy's Calamares also crashed & closed as it tried to create the LUKS partition. Seems like this ISO is crook.

Any updates? Is there any chance 18.0.4 is ready tonight?

Same issue here

I think it is upstream...SwagArch (not that it is aproppriate here) is tossing some funky data.

1 Like

You realise you're "bumping" only 12 hours after the previous post on a Saturday evening/Sunday morning? Please keep in mind days of the week, time zones, and the fact people have to sleep.

1 Like

Damn lousy human frailty. Come the Revolution...

Forum kindly sponsored by