Various Deepin desktop and kwin related issues (window effects, wallpapers, etc.)

I just updated my dad's PC with Manjaro Deepin. I had this issue with login that was resolved. However, it turned out that the desktop was not clickable due to the incompatibility with the old WM. I installed deepin-kwin, rebooted and I get black screen, still not clickable. I have no idea if kwin is working.

When I tried:

kwin_x11 --replace

the desktop flickered and nothing really changed, aside terminal that spew a bunch of errors:

kwin_x11 --replace
qt.qpa.xcb: QXcbConnection: XCB error: 5 (BadAtom), sequence: 543, resource id: 0, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 5 (BadAtom), sequence: 609, resource id: 0, major code: 20 (GetProperty), minor code: 0
"Build on kwin 5.18.5 version, but run on kwin 5.18.5 version"
QObject::connect: No such signal KWin::Workspace::propertyNotify(long)
KWinUtils: Ignore the 'propertyNotify' signal connect warning
qt.qpa.xcb: QXcbConnection: XCB error: 5 (BadAtom), sequence: 1389, resource id: 0, major code: 20 (GetProperty), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 5 (BadAtom), sequence: 1417, resource id: 0, major code: 20 (GetProperty), minor code: 0
OpenGL vendor string:                   NVIDIA Corporation
OpenGL renderer string:                 GeForce 9800 GT/PCIe/SSE2
OpenGL version string:                  3.3.0 NVIDIA 340.108
OpenGL shading language version string: 3.30 NVIDIA via Cg compiler
Driver:                                 NVIDIA
Driver version:                         340.108
GPU class:                              G80/G90
OpenGL version:                         3.3
GLSL version:                           3.30
X server version:                       1.20.8
Linux kernel version:                   5.7
Requires strict binding:                no
GLSL shaders:                           yes
Texture NPOT support:                   yes
Virtual Machine:                        no
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 1737, resource id: 92274720, major code: 3 (GetWindowAttributes), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 9 (BadDrawable), sequence: 1738, resource id: 92274720, major code: 14 (GetGeometry), minor code: 0
qt.qpa.xcb: QXcbConnection: XCB error: 5 (BadAtom), sequence: 1760, resource id: 0, major code: 20 (GetProperty), minor code: 0
QCoreApplication::postEvent: Unexpected null receiver
qt.qpa.xcb: QXcbConnection: XCB error: 5 (BadAtom), sequence: 2150, resource id: 0, major code: 20 (GetProperty), minor code: 0

How do I set kwin in Deepin then?

EDIT: It looks like kwin is enabled, because I see it in system monitor, but is it really working? I don't see any composition (no transparency or effects). Windows are drawn thou.

I suspect that I lack configs or some necessary packages. In theory, everything should come with kwin-deepin, but maybe dependencies are screwed? @oberon, any idea?

EDIT 2: I noticed that file manager is not starting. I had a version that doesn't need deepin-anything, but the version was higher than overall versions of other deepin files. I guess, that was the difference between stable branch and AUR. So I switched to official deepin-file-manager that added dkm's and deepin-anything, rebooted and the desktop is back. Wallpaper and clicking is working.

So the biggest issue is out of the way. The only remaining thing is: there is no transparency and no effects so I assume the composition is still off from some reason :frowning:.
The beautiful deepin became ugly and primitive after update (a lot of options disappeared in this deepin version, setting menu is poor). Also, I notice some other, less relevant bugs.

When I try to invoke overview I get info that it's not possible without effects, so yeah, composition is off for sure.

Try turning it on in the settings. In under personalization->general

The current version is filled with bugs. It is under actively development and while it is called a beta it seems more like it is still unfinished.

Ah, found it. Unfortunately, the switch doesn't work (as many others). In short, the switch button is not clickable.
My guess is, something is missing: a package or config.

delete 'kwinrc' file in .config - Reboot

2 Likes

Wow, that worked! So simple and it worked, although the old config is... IDENTICAL withe the new one. Go figure.

Fantstic! Deleting kwinrc under ~/.config fixed a window effect issue which cropped up for me a couple of days ago on my Arch Linux install of Deepin. In addition, it solved a number of other minor bugs I started seeing recently including:

  • Wallpaper and Screensaver not working
  • Window title bars and icons not appearing properly
  • Window transparency incorrectly positioned (before I lost it)

My multitasking view doesn't work but I can live without that for now as the quite functional beta continues to roll forward. In fact, I haven't touched GNOME in over a month and I'm very happy about that.

Linking this as a crumb trail for others: Manjaro Deepin window effect not working

And one more note I'd fixed some issues with window transparency in Deepin in the past by deleting ~/.config/deepin but nuking kwinrc is what did the trick this time.

1 Like

Ah bummer old issues don't get linked to new ones when they're closed. That makes these forums much less navigable. @michaldybczak could you update the title to something less technical and with more keywords like the old issue I tried to link to this one? That's the first result I clicked in search engines when I tried to debug this issue.

Your Welcome :wink:

I have been known to, delete the .cache folder and the deepin folder in .config after a major update and if it gets really messy I delete the .config/dconf/user file, that will put all your deepin configs back to default, so use with caution. I only do this on my test machine while in beta, I am not currently using deepin as a daily driver, I just boot it up now and then to inspect its progress.

Still needs quite a bit of work IMHO, also testing under arch :wink:

Don't forget you can report bugs here:

2 Likes

Done :slight_smile:

1 Like

I tried to install deepin on Virtualbox through Manjaro-Architect, everything went fine until first logon, it just shows a black screen.

Deepin seems to be very broken on Manjaro and maybe Arch. Same applies to Pantheon.

It's interesting that DDE uses Debian Stable as base, but changes so much every release, from 15.11 to Deepin 20 beta, the changes were really big.

That could be vbox, under display - try using vboxvga no acceleration.

if you still have a black screen try changing tty doing ctr,alt F2 then back to ctr,alt F1 that would be right ctr,alt for vbox.

Black Screen as no graphical session (no cursor) or a desktop without wallpaper but with cursor, hence black? In the second case, this seems like kwin issue like described in my topic. Did you try deleting configs?

It's possible that the installer or updates are breaking somehow kwin configs, hence all the issues that people have after Deepin switched to kwin.

P.S. After longer examination, I believe that I missed the one difference between default and the existing config. Since I'm not on computer with Deepin, I can't remeber exact name, but it was something about GPL ready and it was marked as false, changing it to true fixes kwin issues. So it may be that the default arch configs have bad defaults.

I tried a lot of methods but none of them worked pretty well, it seemed to be something related to the display manage. So, I changed it and logged in the desktop, but it was very broken and laggy. I've never seen this on any distro, it was like something was missing. Anyway, I gave up and deleted this vm.

Yes, black screen with nothing, but I managed to use the tty to check, even after "fixed" the issue it was not usable at all... Slow as hell, buggy, the panel flashing so much while the mouse was being moved. I thought it was a kernel issue, changed the kernel, too a huge time due to the laggy, but hasn't worked... so, I give up. I just installed to check if it was the old version like 15.11 or the new look with their latest beta, deepin 20.

I don't think that profile is maintained anymore. It may not be possible to install deepin properly via m-a. To be fair, I haven't tried.

If you want deepin, I would do a CLI install and then install the deepin groups.

It is the version 20 "beta". Although, calling it a beta since overly generous since it seems to be under active development and they are still adding features.

Yes, it is. I installed it like 1 week ago and there was a category for deepin in the Manjaro-Architect.
How to do a CLI-only install on Manjaro? Is it through Manjaro-Architect? Manjaro-Architect seems to uses a semi-graphical ncurses UI.

You're right about that, it's on active development, there is one new "menu" being created as well, check it out.

I mean....I am not sure it is possible to get a working install that way.

Yes. It is one of the options.

It kinda worked, hehehe. Something may be broken.

I'll check that later, maybe. Thanks.

It's very possible, that it doesn't work on vm, but works on bare metal. On other hand, my Manjaro Deepin version was installed from old Manjaro Deepin iso, ca. 1 year ago, all that new Deepin came with updates.

My impression is that kwin is very unstable and Deepin was much better with old DM. Kwin seems to work better on Plasma or LXQt.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by