Venus XT [Radeon HD 8870M / R9 M270X/M370X]

Hi, Im willing to have my VGA configured correctly but I'm unable to have it running as it is supposed to.
I've tried by configuring it using amdgpu driver and the radeon driver but in any case I am stuck
Using amdgpu driver I made it work with Vulkan but fps go from 1 to 70 or higher very randomly
On the other hand when configuring it with the radeon driver I am unable to configure Vulkan

If some one could be so kind of giving a hand to this newbie in manjaro would be great!

This is what lshw tells me that I have:

*-pci:0
             description: PCI bridge
             product: Crystal Well PCI Express x16 Controller
             vendor: Intel Corporation
             physical id: 1
             bus info: pci@0000:00:01.0
             version: 08
             width: 32 bits
             clock: 33MHz
             capabilities: pci pm msi pciexpress normal_decode bus_master cap_list
             configuration: driver=pcieport
             resources: irq:26 ioport:3000(size=4096) memory:b0c00000-b0cfffff ioport:80000000(size=268435456)
           *-display
                description: VGA compatible controller
                product: Venus XT [Radeon HD 8870M / R9 M270X/M370X]
                vendor: Advanced Micro Devices, Inc. [AMD/ATI]
                physical id: 0
                bus info: pci@0000:01:00.0
                version: 83
                width: 64 bits
                clock: 33MHz
                capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
                configuration: driver=radeon latency=0
                resources: irq:39 memory:80000000-8fffffff memory:b0c00000-b0c3ffff ioport:3000(size=256) memory:b0c40000-b0c5ffff

and this is what I get when running Lutris System Information

[System]
OS:              Manjaro Linux 20.0.3 Lysia
Arch:            x86_64
Kernel:          5.6.16-1-MANJARO
Desktop:         GNOME
Display Server:  x11

[CPU]
Vendor:          GenuineIntel
Model:           Intel(R) Core(TM) i7-4870HQ CPU @ 2.50GHz
Physical cores:  4
Logical cores:   8

[Memory]
RAM:             15.5 GB
Swap:            8.8 GB

[Graphics]
Vendor:          X.Org
OpenGL Renderer: AMD VERDE (DRM 2.50.0, 5.6.16-1-MANJARO, LLVM 10.0.0)
OpenGL Version:  4.5 (Compatibility Profile) Mesa 20.0.7
OpenGL Core:     4.5 (Core Profile) Mesa 20.0.7
OpenGL ES:       OpenGL ES 3.2 Mesa 20.0.7
Vulkan:          Not Supported

You don't say what is showing this, so it could be perfectly normal that complex games require more power than your GPU can provide.

Alternatively, your GPU could be overheating and throttling.

Could you give me a hint on how I can get the most of it?
I know that it should be able to run it with no problem, it has to be a bad driver installation.

I know this because on Windows it used to run just fine. (but I hate Windows hahah)

Ah, yes: "This is this". (Anyone?)

I suspect you need to go back to the beginning and ask about your actual issue, not the one that you think it might be.

Im generalizing since its happening with every game I want to run. But since you want to know Im running the first Darksiders game. Also happening with Borderlands (again they run fine on Windows using same graphic settings)

If you believe that the problem could come from another thing it would be very helpfull if you could help finding out. Again, I'm new to Manjaro

What's happening, and in what situations?

First of I cant configure Vulkan on the radeon driver (this is totally my lack of knowledge)
If I want to use the amdgpu driver performance seems to be really bad.
Situation, running games Like Borderlands using lowest graphics CSGO again using lowest graphics, darksiders 1 and bastion.
Fortnite not even playable in lowest graphics.

Then why use amdgpu?

I dont know which driver is the best.
Tried to use radeon but cant make Vulkan run

The one which works best on your hardware - which apparently is the radeon driver.

Ok, but with radeon I cant get to work Vulkan which prevents for me to actually check that.

Forum kindly sponsored by