Very Slow WiFi

I'm having problems after migrating to Manjaro. The WiFi is very very slow, near to unusable. I have been trying some posts without any result.

Edit one

I was using Linux Mint and everyting was ok.

Edit two

cat /proc/net/wireless

 antonio@antonio-pc >  cat /proc/net/wireless

Inter-| sta-|   Quality        |   Discarded packets               | Missed | WE
 face | tus | link level noise |  nwid  crypt   frag  retry   misc | beacon | 22
wlp3s0: 0000   42.  -68.  -256        0      0      0      0  92314        0

Edit three

iw dev wlp3s0 link | grep -v "Connected to" | grep -v "SSID" && iw dev wlp3s0 get power_save

antonio@antonio-pc > iw dev wlp3s0 link | grep -v "Connected to" | grep -v "SSID" && iw dev wlp3s0 get power_save
	freq: 5260
	RX: 206971670 bytes (238950 packets)
	TX: 33774859 bytes (129842 packets)
	signal: -67 dBm
	tx bitrate: 433.3 MBit/s VHT-MCS 9 80MHz short GI VHT-NSS 1

	bss flags:	short-preamble short-slot-time
	dtim period:	2
	beacon int:	100
Power save: off

Edit four

inxi -Fxxxz

antonio@antonio-pc > inxi -Fxxxz
System:
  Host: antonio-pc Kernel: 4.19.13-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Xfce 4.12.4 tk: Gtk 2.24.32 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: ASUSTeK product: X550LA v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: X550LA v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: X550LA.509 date: 06/26/2014 
Battery:
  ID-1: BAT0 charge: 12.4 Wh condition: 12.5/38.5 Wh (32%) volts: 14.8/14.8 
  model: ASUSTeK X550A26 type: Li-ion serial: <filter> status: Charging 
  cycles: 627 
CPU:
  Topology: Dual Core model: Intel Core i5-4210U bits: 64 type: MT MCP 
  arch: Haswell rev: 1 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19161 
  Speed: 824 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 866 2: 812 
  3: 813 4: 825 
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: ASUSTeK 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0a16 
  Display: x11 server: X.org 1.20.3 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 18.3.1 
  compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Haswell-ULT HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 00:03.0 chip ID: 8086:0a0c 
  Device-2: Intel 8 Series HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 00:1b.0 chip ID: 8086:9c20 
  Sound Server: ALSA v: k4.19.13-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8168 v: 8.045.08-NAPI port: e000 bus ID: 02:00.1 
  chip ID: 10ec:8168 
  IF: enp2s0f1 state: down mac: <filter> 
  Device-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter 
  vendor: AzureWave driver: rtl8821ae v: kernel port: d000 bus ID: 03:00.0 
  chip ID: 10ec:8821 
  IF: wlp3s0 state: up mac: <filter> 
  IF-ID-1: br-0a6f00db1bbe state: down mac: <filter> 
  IF-ID-2: docker0 state: down mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 87.28 GiB (18.7%) 
  ID-1: /dev/sda vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: SDM1 scheme: GPT 
Partition:
  ID-1: / size: 444.58 GiB used: 87.28 GiB (19.6%) fs: ext4 dev: /dev/sda2 
  ID-2: swap-1 size: 12.78 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 40.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 2000 
Info:
  Processes: 193 Uptime: 30m Memory: 11.61 GiB used: 1.14 GiB (9.8%) 
  Init: systemd v: 239 Compilers: gcc: 8.2.1 Shell: zsh v: 5.6.2 
  running in: xfce4-terminal inxi: 3.0.28 

I hope, someone can help me. Thanks!!!

1 Like

Did you tried with another OS? Ubuntu live for example

Yes, I was using Linux Mint and everything was ok.

Can you send the result of
cat /proc/net/wireless
please?

Sure!

 antonio@antonio-pc > cat /proc/net/wireless

Inter-| sta-|   Quality        |   Discarded packets               | Missed | WE
 face | tus | link level noise |  nwid  crypt   frag  retry   misc | beacon | 22
wlp3s0: 0000   42.  -68.  -256        0      0      0      0  92314        0

And
iw dev wlan0 link | grep -v "Connected to" | grep -v "SSID" && iw dev wlan0 get power_save
?

Of course! I have changed wlan0 by wlp3s0

antonio@antonio-pc > iw dev wlp3s0 link | grep -v "Connected to" | grep -v "SSID" && iw dev wlp3s0 get power_save
	freq: 5260
	RX: 206971670 bytes (238950 packets)
	TX: 33774859 bytes (129842 packets)
	signal: -67 dBm
	tx bitrate: 433.3 MBit/s VHT-MCS 9 80MHz short GI VHT-NSS 1

	bss flags:	short-preamble short-slot-time
	dtim period:	2
	beacon int:	100
Power save: off

I came to this forum to report the same thing. It's been 1 or 2 weeks since it happened.

Could an update have caused this? I've been using manjaro for years with no issues.

You could try this test to see if it improves your wifi's connection.

Unload the adapter module:

sudo modprobe -r rtl8821ae

Reload the adapter module with software encryption enabled & power saving disabled.

sudo modprobe rtl8821ae swenc=1 ips=0

or

sudo modprobe rtl8821ae debug=0 disable_watchdog=N fwlps=N swlps=Y swenc=Y ips=N msi=0

or

sudo modprobe rtl8821ae disable_watchdog=0 swlps=1 swenc=1 ips=0 fwlps=0 msi=1 debug=0 int_clear=0

This will alter the options of your driver temporarily until you reboot.

For a more permanent change to your adapters options you must create a driver configuration file

Create the following Realtek rtlwifi driver configuration file.

/etc/modprobe.d/rtl8821ae.conf

Copy and paste the following into the conf file:

options rtl8821ae swenc=1
options rtl8821ae ips=0
#options rtl8821ae rtw_power_mgnt=0
#options rtl8821ae rtw_enusbss=0
#options rtl8821ae swlps=1
#options rtl8821ae fwlps=0
#options rtl8821ae debug=1
#options rtl8821ae disable_watchdog=1
#options rtl8821ae msi=0
#options int_clear=0

You can test any of the other driver options in /etc/modprobe.d/rtl8821ae.conf by uncommenting the entry.

Simply remove the "#" sign in front of any option to enable that option.

Placing a comment ("#") in front of any option will disable the option change.

You can also try flipping 1 to 0, or, 0 to 1, to reverse enabling/disabling individual option settings.

Reboot after making any changes to the options in the rtl8821ae.conf file.

swenc=1 enables software encryption (prefered)
swenc=0 enables hardware encryption
ips=0 disables all power saving
swlps=1 enables software control of power saving
fwlps=0 disables firmware control of power saving
rtw_power_mgnt=0 disables power saving
rtw_enusbss=0 disables USB autosuspend (only for USB adapters)
disable_watchdog=1 disable watchdog, if receiving watchdog related errors
msi=1 Set to 1 to use MSI interrupts mode (default 1)
debug=1 Set debug level (0-5) (default 0)
int_clear=0 disable interrupt clear before set (default 1)

swenc=1 enables software encryption (prefered)
swenc=0 enables hardware encryption
ips=0 disables all power saving
swlps=1 enables software control of power saving
fwlps=0 disables firmware control of power saving
rtw_power_mgnt=0 disables power saving
rtw_enusbss=0 disables USB autosuspend (only for USB adapters)
disable_watchdog=1 disable watchdog, if receiving watchdog related errors
msi=1 Set to 1 to use MSI interrupts mode (default 1)
debug=1 Set debug level (0-5) (default 0)
ant_sel=2 rtl8723be driver allows the ant_sel parameter (value 1, or 2)

"ips=0" disables all power saving, rendering swlps and fwlp redundent
"swlps=0" is the default
fwlps=1 is default, meaning the FW controls the power saving
"swenc=1" disables the HW encryption
"fwlps", yes. 0/1 maps to N/Y, but you should use the values provided by modinfo (the parameters here are bool, but sometimes they're integer and then the outcome is arbitrary)
If you already tried "ips=0" (confirmed by systool output?) most of this is moot and the only things left are the swenc=0 parameter and downgrading the firmware.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by