Very Weak Wifi Signal on RTL8822be

I'm on a Asus VivoBook S14 430FA.
It has a Realtek 8822be. My connection is 100 mbit/s but my device gets only 12mbits down and 4mbits up. It's getting -81dbi connection strength even though my WiFi route is just 5 meters away.
Tried kernal 4.4.19 and now on 5.1 but still no improvements, on Windows 10 it gets 40-70mbit up/down.
here's pci-e card info .

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8822BE 802.11a/b/g/n/ac WiFi adapter
        DeviceName: WLAN
        Subsystem: AzureWave RTL8822BE 802.11a/b/g/n/ac WiFi adapter
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 130
        Region 0: I/O ports at 3000 [size=256]
        Region 2: Memory at b1100000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: <access denied>
        Kernel driver in use: r8822be
        Kernel modules: r8822be


modinfo r8822be
filename:       /lib/modules/5.1.8-1-MANJARO/kernel/drivers/staging/rtlwifi/r8822be.ko.xz
description:    Realtek 802.11n PCI wireless core
license:        GPL
author:         Larry Finger    <Larry.FInger@lwfinger.net>
author:         Realtek WlanFAE <wlanfae@realtek.com>
author:         lizhaoming      <chaoming_li@realsil.com.cn>
description:    PCI basic driver for rtlwifi
license:        GPL
author:         Larry Finger    <Larry.FInger@lwfinger.net>
author:         Realtek WlanFAE <wlanfae@realtek.com>
author:         lizhaoming      <chaoming_li@realsil.com.cn>
firmware:       rtlwifi/rtl8822befw.bin
description:    Realtek 8822BE 802.11n PCI wireless
license:        GPL
author:         Larry Finger    <Larry.Finger@lwfinger.net>
author:         Realtek WlanFAE <wlanfae@realtek.com>
description:    Realtek 802.11n PCI wireless core
license:        GPL
author:         Larry Finger    <Larry.FInger@lwfinger.net>
author:         Realtek WlanFAE <wlanfae@realtek.com>
description:    Realtek 802.11n PCI wireless core
license:        GPL
author:         Larry Finger    <Larry.FInger@lwfinger.net>
author:         Realtek WlanFAE <wlanfae@realtek.com>
srcversion:     8CC0865964F60B52C7CC062
alias:          pci:v000010ECd0000B822sv*sd*bc*sc*i*
depends:        mac80211,cfg80211
staging:        Y
retpoline:      Y
intree:         Y
name:           r8822be
vermagic:       5.1.8-1-MANJARO SMP preempt mod_unload modversions 
sig_id:         PKCS#7
signer:         Build time autogenerated kernel key
sig_key:        07:AB:01:47:3C:BC:91:4B:1D:6B:C0:6A:02:13:06:B4:3A:E2:B4:AC
sig_hashalgo:   sha512
signature:      66:3E:30:5E:44:DE:70:C3:99:90:D5:1A:A3:A2:F6:A7:82:2D:0F:EC:
                7C:9A:8D:FF:62:6C:06:71:77:FB:56:16:5A:B4:3E:EC:85:8A:F4:AF:
                ED:20:B8:2B:5E:FA:94:65:57:57:16:56:00:93:27:3A:27:12:88:11:
                25:F6:8A:82:E7:3E:4D:C8:C5:19:E2:7C:77:F0:D9:85:98:80:F8:8C:
                D6:C1:F5:CD:8E:76:08:CA:B1:3B:8D:00:CB:81:6B:62:12:46:92:A0:
                8A:5C:1A:AA:B7:FB:49:FF:F3:DB:0B:91:D1:89:A3:7A:0F:60:5D:0C:
                16:86:BF:C9:FD:0E:6D:3C:5F:A0:67:B6:D3:7E:87:55:CA:71:71:AB:
                37:C1:F8:24:C6:E9:85:5E:5F:8B:D2:77:5E:5D:FD:3E:12:89:71:2A:
                9A:0A:4A:1C:92:4B:A4:29:40:06:AE:96:77:12:E3:D0:CD:AB:C0:26:
                DD:15:24:A9:53:20:C6:F3:E9:0D:99:04:7D:0B:9C:13:6D:CC:F1:07:
                63:B1:32:FB:43:C0:A9:EE:0A:37:5B:89:9C:DA:88:67:50:73:23:FD:
                7A:F6:C0:4B:54:32:0E:4A:D4:EB:81:E3:76:11:5A:C2:E4:6A:CE:23:
                2A:07:AC:E4:69:31:4B:25:32:2B:5C:1E:18:68:74:46:20:A3:F7:F4:
                F2:AE:DE:B5:B3:FD:2F:40:AC:8E:74:E7:81:AD:78:F9:AE:FE:FC:9D:
                71:78:24:37:CC:9E:58:89:47:76:25:9E:DD:87:33:16:A6:8E:88:09:
                27:29:71:EE:73:9A:61:AC:F8:04:8D:3F:7A:56:57:79:01:09:02:EB:
                16:B2:AC:0E:65:03:52:22:AB:E6:6B:D9:E3:88:6C:2A:6B:16:CC:DC:
                30:9E:E4:AC:F5:00:16:6C:D8:8D:2F:08:A4:CB:0D:41:2E:A2:E6:A5:
                2F:09:70:99:C8:A4:19:58:2E:53:5B:E4:CE:7E:86:82:B1:24:0F:D7:
                E3:BC:1A:95:96:BD:30:7A:AA:71:AB:01:7D:79:46:F9:D2:B2:69:DE:
                62:A1:96:61:B5:29:59:DA:DF:62:5D:11:AA:24:D5:A6:8E:24:65:79:
                C7:1F:0E:39:1B:76:3A:77:70:3E:20:4C:FF:C9:9A:59:65:E7:BA:03:
                87:25:2B:02:EB:1E:A7:19:28:03:D4:D3:B5:6C:39:18:4C:E7:51:9B:
                93:3C:3F:26:F3:3B:13:63:C5:EC:D0:4A:84:69:89:94:5B:A6:4E:DB:
                C4:E3:0E:3E:94:92:E7:88:3D:14:36:DD:B7:CB:65:D6:E9:8D:70:05:
                BC:34:97:68:90:17:50:8D:BB:F8:35:64
parm:           debug_level:int
parm:           swenc:Set to 1 for software crypto (default 0)
 (bool)
parm:           ips:Set to 0 to not use link power save (default 1)
 (bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm:           msi:Set to 1 to use MSI interrupts mode (default 1)
 (bool)
parm:           dma64:Set to 1 to use DMA 64 (default 0)
 (bool)
parm:           aspm:Set to 1 to enable ASPM (default 1)
 (int)
parm:           debug:Set debug level (0-5) (default 0)
parm:           debug_mask:Set debug mask (default 0) (ullong)
parm:           disable_watchdog:Set to 1 to disable the watchdog (default 0)
 (bool)

See here

Thank you for your quick reply. But as OP in that post mentioned his card wasn't even working. Mine is working but wifi signal is too weak, (like when you first install windows and there's no video driver installed so the display is laggy and low res). Plus in that post it was unclear how he fixed his problem.
I do no have any sort of blacklist file in my /etc/modprobe.d/

I'm aware the issue there was different, but, considering that it got it working and was no report of the wireless signal being low, i take it as being 100% working.
Also, you should consider trying different kernels, the LTS especially, disable the IPV6 for wifi, disable mac randomization ... there are a couple of things that some wifi card models require to properly work under linux.

1 Like

UPDATE: I have tried installing proprietary drivers from https://github.com/lwfinger/rtlwifi_new
with commands > make

sudo make install
sudo modprobe -r rtl8822be (doesn't show any errors)
sudo modprobe -v rtl8822be (gives ``` insmod /lib/modules/4.19.49-1-MANJARO/kernel/drivers/net/wireless/realtek/rtlwifi/phydm/phydm_mod.ko.xz

modprobe: ERROR: could not insert 'rtl8822be': Exec format error ``` )

There is the rtlwifi_new-dkms in AUR. You will need the dkms package and the linux-headers for your running kernel. If is the

as you posted, then you will need linux51-headers and then install the AUR package i mentioned.

1 Like

Currently tried ParrotSec OS 4.6, Ubuntu 16.04 LTS. On Ubuntu I tried every solutions out there :frowning:
My last try would be getting
https://github.com/lwfinger/rtlwifi_new to work. Which is giving me modprobe: ERROR: could not insert 'rtl8822be': Exec format error
I had a notebook with Realtek 8821AE with this same exact issue. Installed driver from https://github.com/lwfinger/rtlwifi_new which then resolved the problem.

1 Like

I have switched to 4.19.49-1-MANJARO.
Can you please tell me how can I install https://aur.archlinux.org/packages/rtlwifi_new-dkms ?
I'm totally new to Manjaro (OR any Arch based Linux)

First you install the linux headers:

sudo pacman -S linux$(uname -r| grep -o -E '[0-9]+' | head -n 2 | sed 'N;s/\n//')-headers

Then
sudo pacman -S dkms
then
pamac build rtlwifi_new-dkms
reboot once is done.
Pay attention to what @tbg will say as he is the most knowledgeable about this stuff :wink:

Addition:
Since you are on KDE Plasma (apparently) you have to install a AUR helper first:
sudo pacman -S trizen base-devel --needed
then instead of pamac command use:
trizen -S rtlwifi_new-dkms

1 Like

Do not install the rtlwifi_new package from the AUR. It has not been updated in quite a long time and does not work properly on Manjaro. If you want to use that driver you need to build it from its source on Github. If you build from source the driver will require rebuilding after every kernel update, so that is not a good solution.

This adapter received kernel support at 4.14 i believe. It should be supported by the kernel. You need to test all the kernels from 4.14 on up to see if you can get it working properly.

The other thing worth testing is to disable IPv6 in your router and in Network manager.

2 Likes

I just started reading your post at the end. I am only now reading the full content of your post. Did you install the linux headers package before attempting to install the rtl_wifi new package from github?

This adapter should not require installing out of kernel drivers which makes me think the problem lies elsewhere. The first thing I would suspect is that you need a BIOS update.

  1. Is your bios up to date?

  2. Also which desktop are you using?

  3. Have you tested or DE's or distros?

  4. Have you rebooted your router?

  5. Have you tested this on other wifi networks?

  6. How was the wifi connection on other Linux DE's or distributions?

If you have not tested other DE's I would highly suggest downloading some live boot images and testing them out, (especially if you are using Deepin).

2 Likes

Guys I have a new problem in my hand. Installed kernal 4.14.x then I reebooted from the gui, then system froze. After 2mins I force rebooted my system with this message.Uploading: IMG_20190705_122800.jpg...
I think I'm gonna have to install manjaro again. Hehe. PSX_20190705_123432

Oh ... same story as here:

Re-installing is actually a very good idea at this point because once you have attempted to install drivers from source it makes it very hard to figure out what the problem is. After you do a fresh install, if would like my assistance please don't start making changes on your own. To be able to troubleshoot effectively I need to know where we are starting from and any changes made to your system.

Please answer the questions on my last post as I will be unable to help you until I have all the information I need to diagnose your issue.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by