Viewing a sticker causes telegram-desktop to crash on manjaro arm

Whenever I open a Telegram chat that contains a sticker, a single loop sequence for the sticker will play, then Telegram will crash.

I'm using Manjaro ARM on a Pinebook Pro. The programme in question is community/telegram-desktop version 1.8.15-4, however, the problem has persisted through several versions of the programme.

If I launch telegram-desktop from the terminal, I can see the following error message when the programme crashes:

[swscaler @ 0xffff544f7d10] No accelerated colorspace conversion found from yuv420p to bgra.
Aborted (core dumped)

For referece, my inxi -Fxz output is:

System:    Host: Scatha Kernel: 5.5.0-0.2-MANJARO-ARM aarch64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.17.5 
           Distro: Manjaro ARM 
Machine:   Type: ARM Device System: Pine64 Pinebook Pro details: N/A serial: <filter> 
Battery:   ID-1: cw2015-battery charge: 97% condition: N/A model: N/A status: Discharging 
CPU:       Topology: 6-Core (2-Die) model: N/A variant-1: cortex-a72 variant-2: cortex-a53 bits: 64 type: MCP MCM arch: ARMv8 
           rev: 4 
           features: Use -f option to see features bogomips: 0 
           Speed: 816 MHz min/max: 408/1416:2000 MHz Core speeds (MHz): 1: 408 2: 408 3: 408 4: 408 5: 816 6: 816 
Graphics:  Device-1: display-subsystem driver: rockchip_drm v: N/A bus ID: N/A 
           Device-2: rk3399-mali driver: panfrost v: kernel bus ID: N/A 
           Display: x11 server: 1.20.6 driver: modesetting resolution: <xdpyinfo missing> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: simple-audio-card driver: asoc_simple_card bus ID: N/A 
           Device-2: simple-audio-card driver: N/A bus ID: N/A 
           Sound Server: ALSA v: k5.5.0-0.2-MANJARO-ARM 
Network:   Device-1: wlan-platdata driver: N/A bus ID: N/A 
           IF-ID-1: wlan0 state: up mac: <filter> 
Drives:    Local Storage: total: 116.48 GiB used: 66.08 GiB (56.7%) 
           ID-1: /dev/mmcblk2 model: DA4128 size: 116.48 GiB 
Partition: ID-1: / size: 114.60 GiB used: 66.08 GiB (57.7%) fs: ext4 dev: /dev/mmcblk2p1 
Sensors:   System Temperatures: cpu: 18.8 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 181 Uptime: 25m Memory: 3.71 GiB used: 1.50 GiB (40.6%) Init: systemd Compilers: gcc: 9.2.0 clang: 9.0.1 
           Shell: bash v: 5.0.11 inxi: 3.0.37 

I'm not sure whether this is the correct forum to report the bug. I ran pacman -Q --info on the package, which shows the packager as:
"Arch Linux ARM Build System <>" ... This package.

I've previously tried reporting the bug here, but my bug report magically disappeared. I've just added another one, and will see if the same thing happens. If this isn't the correct place to report the bug, please could someone point me in the direction of where I need to go.

Edit: Predictably, the bug was closed:

Reason for closing: Not a bug
Additional comments about closing: This is not the Manjaro ARM bugtracker.


Am I going mad? Maybe it's a feature then.

Same issue with me, I'm also using the Pinebook Pro.

I know it's super silly to even ask this at the moment but have you tried to run it through gl4es?

Looks like some Panfrost bug (and there are slew of improvements that should be landing in the next few days on mesa's repo).
Are you using fbturbo? What's your mesa version?

As to why it got closed - you've posted on the Arch Linux bug tracker (not sure if there is a dedicated one for Arch Arm :thinking: ).
Arch has a very hard stance about resolving issues for people reporting them while running different distros ( even if they are closely related as Manjaro, Arco Linux,etc).

I'm not sure what's the preffered solution for reporting bugs on Manjaro ARM to be honest. Posting here was a good bet.

You could also try to reach to the maintainer of the package (usually you can find the maintainer at the top of the PKGBUILD)


I haven't tried using gl4es. I saw the tutorial, but thought I'd wait to see if anything popped up in the Manjaro ARM repos.

I'm using mesa-git in place of mesa. fbturbo is uninstalled. I'm using panfrost. I haven't got my Pinebook Pro to hand at the moment, but it would have been the latest version as of when I made the initial comment in this post.

I'll wait for the next mesa-git update, then try and get hold of the package maintainer if the problem persists.

I have the same setup. Gave gl4es a go but no dice. Still crashes.
I don't have my sd card with fbturbo install atm but will give it a go tonight.

Could be an idea to report the bug to the Panfrost devs as well.

Will gles4 every be packaged my the Manjaroarm team?

I have the same problem. I tried with and without panfrost on the Pinebook Pro so I do not think this is a driver issue. Other OS seem to be affected as well:

I tried to dig a bit more. Looks like the colour space conversion is handled by the Hantro VPU driver that is still work in progress for rk3399.

I could be completely wrong but that's what I managed to find in my follow up searches. Hope we can find more information!

I don't mind building and uploading a gl4es package. But I can't really do any testing with it, so it would be with a disclaimer that we don't know if it's working or will bork your system.

Off-topic: As you've asked about it, Strit has released a gl4es package earlier today. It's not replacing the installed mesa libs so to use it, run the target game/program from terminal with LD_LIBRARY_PATH=/opt/gl4es <program_of_choice> . It won't fix telegram unfortunately.
PS: Will create a separate thread about it in the weekend.

Will check out the new packages soon. Thanks @Strit.

Well, there is no change on telegram-desktop.

In amazing turn of events however... Anbox in it's supremely unstable iteration handles Telegram okey (how Anbox performs under X/ XWayland is another thing altogether).

@Feakster , telegram-desktop version 1.9.9-1 doesn't crash for me.

It's a new one built on 30th of Jan.

Will give it a go in a few days. I need to buy a USB eMMC card reader to undo something I messed up a couple of weeks back. I haven't been able to use my Manjaro ARM installation since then.

Finally updated to the new Qt libs. Telegram-desktop crashes again :expressionless:

Luckily the solution from @Icenowy does work. Here is a package using it:

Just got my Pinebook Pro working again... just in time for the version of Telegram that starts crashing with stickers again.

I will see to update my telegram desktop package (most likely I need to update the patch from Icenowy - I needed to alter it for 1.9.9 as well).

Not sure about afterwards. I will create and post a link to a git repo but I'm not sure what's the best way to proceed from there.

telegram-desktop version 1.9.13 still crashes with stickers. Weirdly, I also got a crash when editing a message containing monospace font, i.e. text wrapped in backticks.


I have the same error/crash as OP on 1.9.13 from the distro package.

Also of note the exact same error and crash is happening with 1.9.14 from the Flatpak Flathub package.

Alright, quick notes with the newer version:

  • Crash with 1.9.13- 1.9.14 happens as soon as sticker is on the screen (my guestimate without debugging is the 1st frame)
  • Icenowy's patch doesn't help here (it's targeting smth else)
  • You can use the older 1.9.9 patched version (will share the PKGBUILD once I get home)

Forum kindly sponsored by