VirtualBox and full screen

Good Evening,

I've had a problem with virtualBox for a long time.
I have a Windows 10 installed for a long time and I don't have any problems. The virtual machine displays well in full screen.

It is only with "Linux" virtual machines that I have a problem. It is impossible for me to display them in full screen. Because of this, I can't even install some of them.
Yet in "Settings", "Extensions", I have "Oracle VM VirtualBox Extension Pack" installed.

If I do "Swap Screen", nothing changes.

Can you help me?

Thank you.

1 Like

Have you installed Guest Additions? Number 7 here...

I'm trying to.

But every time I want to install it, I get this error message:


Could not mount the media/drive '/usr/lib/virtualbox/additions/VBoxGuestAdditions.iso' (VERR_PDM_MEDIA_LOCKED).

Just download the file in your host system. Then put it in a shared folder (host and guest system) and then run it/mount it in your guest system. That is the way I do it. Always get the same error.

Are you starting the Guest with an empty Optical Drive?

No, I've started the Guest with the iso file.

And the solution of rexmalcolm is impossible for me.
I can't do it for each virtual machine I have.

What iso file?
What is the Guest OS you have installed?

I try to install "KDE Neon" with the "neon-testing-20200204-1039.iso" file.

But I've the same problem with each linux machine I try to install.

I've no problem with the virtual Windows.

Install it as best you can using the limited screen ( you might be able to get a better experience using Neon's display settings) and then install Guest Additions on your installed Neon OS.

Are you trying to install the guest additions before actually installing the OS, ie in a live session? If so that's your problem.

Once It's installed you can download them via VirtualBox's settings or grab them yourself from their website.

Neon is Ubuntu based so it'll probably run the install script automatically as soon as you mount the disk.

What do you mean? You have to do it for each virtual machine you have (unless they're already on the iso).

That's it.
I installed the operating system.
And when I do "device", "insert guest check CD image", I always get the same error.

Is there an empty virtual Optical Drive to insert it in?
Is the installation iso still in the virtual Optical Drive?

1 Like

Very often (it depends on the guest os) you can open the guest OS file manager, locate the virtual cd rom with the install media, right-click and choose ''eject''.

Then you go to the virtualbox menu bar (or rightctrl+home), insert the guest additions. Now they are in your virtual cd-rom, and you can proceed from there.

knome

The VBoxGuestAddition.iso to install is in /usr/lib/virtualbox/additions/.

So, I think it's the system who said that the fille is locked.

I do not use KDE neon, but I had that problem before if I used the VMSVGA VideoCard in the configuration of the machine with Arch based Distributions. Normally in modern linux the guest additions are alredy preconfigured in the distributions and if you switch to VBoxVGA, which is the oldest of the available VirtualBox Drivers it will just function out of the box. I think I also read a thread somewhere here, that in Manjaro 19 there will be a fix for this, but I don't know for sure. So perhaps give it a try and change the driver. Manjaro itself has it's own guest-additions package which you can install with pacman I think it is virtualbox-guest-utils, but you will need to have the kernel-modules active for your kernel aswell.
Yours, Peter.

I have a lead.

After installing the virtual machine, I'll shut it down.
Then I eject the installation disk and leave the optical drive empty.
This allows me to mount the virtualbox ISO contained in /usr/lib/virtualbox/additions/.
But, when I mount it, I have script files in the iso.
I tried the linux.run: it doesn't work. It installs something, then asks me to reboot, and nothing happens.
I'll now try with the autorun.sh file...

Édit : and now everything is all right :grin: :+1: :wink:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by