VirtualBox going crazy

I did an arch guest install on my newly installed virtual box but I have noticed very weird behavior and I dont know the root cause of such a behaviour but hear me out,
So installed arch and then after restarting installed the xfce DE but then after shutting down and restarting the VBox it often stucks at the VirtualBox (Bootup screen) for reasons unkown to me. Sometimes it fires up everything just fine on its own and sometimes it just stays there at Bootup screen can anyone tell me whats wrong here. I have used VBox before in Mint 19.3 and never encountered any problems there and I am still a noob trying to get more friendly with the new OS experience.

We can only speculate, as we have no remote omniscience :slight_smile:
Make sure you set the Display of your guest like this:

image

Also make sure your host system is fully updated and rebooted after that.

On your Arch guest install you also need to have the system fully updated and virtualbox-guest-utils package installed.

Did you set the guest as an EFI like this?

image

Try to disable EFI and see if it passes to GRUB menu ...

Those sound more like issues with your Arch install than issues with Virtualbox itself.

By default, Virtualbox 6.x uses emulated vmware video so ensure you have xf86-video-vmware installed.

Other than that, you need to troubleshoot it from within your Arch install.

Just tried disabling the EFI option, the screen flashes

FATAL: No bootable medium found! System halted

Well.....if you did a UEFI install, switching EFI off will break things.

How did you install Arch? Is this an old VM or did you do a clean install?

1 Like

You did a EFI GPT install, so enable EFI back to have it bootable.
On my end it works as i showed in the screenshots, with no issues.

I did an EFI GPT install and this is a fresh install.
Just enabled the EFI option and there it is working like a horse :slightly_smiling_face: :+1: but the problem recurs sometimes. However this is not the case right now and I will keep you all posted if this happens again

THANKS for the VBoxSVGA tip though @bogdancovaciu this was switched to VMSVGA before and maybe that was the reason for the wierd behaviour. Will keep you guys posted

Maybe you are right and its something to do with the display or the drivers, however this popped up as a result,

 error: package 'xf86-video-vmware' was not found

O Sorry, my bad, I was searching for it using the -Qi option :sweat_smile: but found it in the store. Can you plz clarify if it needs to be installed on the guest OS or the host OS

If you switched to VBoxSVGA, xf86-video-vmware isn't needed.

It really should be found on an arch install.

In the guest, but it is no longer needed if you switched to vboxsvga

Yeah that was really very silly of me :stuck_out_tongue_closed_eyes:

And thanks for the tip as well

However now with the virtual machine, whenever, I go and try to insert the Guest Additions CD image, it does not show up in Thunar nor their is a notification of it being inserted in the system.

Is this a dependency issue with Thunar or did I screw up in the install process somewhere?

Guess I just dont know what to install with the base install and the Desktop environment to make it all work smoothly out of the box...

Sorry but the arch bootup problem did not go away
I tried installing the xf86-video-vmware and switching back to VMSVGA but the problem remains either ways

Its more of a hit or miss as the bootup completed 2 of the 5 times I have tried till now

EDIT: I installed the OS on a VHD rather than using VDI maybe thats the issue but this is really messy

Since Arch installs are done by hand and are all unique it is somewhat hard to help you troubleshoot.

What are you seeing in the logs during the failures?

The screen freezes at the VirtualBox logo

Screenshot_20200615_193154

However, you can help me out with the logs as I dont know how to get them

I only installed the base linux linux-firmware sudo nano packages and the xfce4 package(with all the dependencies ofcourse), added a user and then booted into the system

After booting up into the system I installed linux-lts kernel and restarted and removed the previously installed kernel and then installed intel-ucode package and thats it I cant even the get the guest additions image working on the VM

OK so finally I kind of worked out what the problem was and it has nothing to do with the guest system. After randomly trying out every possible switch in the settings and double-checking my arch install I figured out that there is a bug with (or maybe thats how it is supposed to work) with the VirtualBox program. So after tweaking anything OR changing any settings which demands a reboot or shutdown of the guest system you need to start over with the whole program and just restarting the virtual machine wont work. You need to shutdown the guest system and then reopen the VirtualBox application as well in order for the settings to take effect and the guest system to open and work properly.

Maybe there was some issue with the display settings as well as I am using the VBoxSVGA option also installed the xf86-video-vmware package. But really this weird issue needs to be resolved from the VirtualBox team.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by