Virtualbox guest additions on Ubuntu host and Manjaro guest

I ran commands yay -Syy and yay -Su to upgrade everything, then I tried installing virtualbox-guest-utils again, but nothing changed :frowning_face:

As a side note, you should run those as one unit yay -Syyu

Is the service enabled and running?

sudo systemctl enable --now vboxservice.service

It wasn't running (and that gave me some hope that it was the issue). I enabled it and now doing systemctl status vboxservice gives this:


The issue is still there :frowning_face: ...

I'm not sure if seeing code=exited next to vboxguest, vboxvideo, and vboxsf is normal here, but whatever the reason, the result is that I can't get the guest additions to work :frowning_face:

It is loaded and active. Everything looks normal there.

I assume you can't get fullscreen to work in the right resolution?

In your VB settings for your Manjaro virtualbox, select VBoxVGA as displaydriver.
Then, start the virtualbox, switch to fullscreen and set the resolution as desired.
This fixed it for me on everything I install in VB.


edit: you might have to setup a new virtual machine with the correct VBoxVGA setting.

I have recently seen a few questions relating to Manjaro VirtualBox Guests.

Most of these questions was solved by using the Guest Additions ISO and installing from that.

It seems the virtualbox-guest-utils package inherited from Arch no longer has all necessary components for the utilities to work as expected.

Have a look at the VirtualBox HowTo in the #technical-issues-and-assistance:tutorials section

If this is the case we should fix it.

Do we know which components are missing?

I have no idea.

But as lately I have seen more issues where using the Guest Additions ISO solves problems - at least in relation with shared folders.

I don't think there is anything wrong with the Arch guest utils package.

Often this is caused an incorrect / incompatible default virtual display adapter for the VM when the OS is installed.

On a couple of occasions for me it has inadvertantly defaulted to VMSVGA, which has ended up with video-vmware mhwd driver. The video-virtualbox mhwd driver is required for display scaling to work correctly.

VBoxSVGA is the correct adapter to select with VBox 6, VBoxVGA is now considered a legacy virtual adapter included for use with legacy OSes (ie WinXP).

FWIW both VBoxSVGA & VBoxVGA still work though with video-virtualbox.


THIS! see my previous post please.
There is nothing wrong with Arch virtualbox guest utils. It's a VBox issue and you need to pay attention when you setup the virtualbox in order to get the right driver installed.


Actually, on the Manjaro guest I have on Windows 10 (on another computer), the guest adapts its display to window size, and not necessarily only to full screen, but I will try your suggestion of course

Yup , same here . This had me scratching my head for a minute yesterday when I installed Manjaro Vanilla KDE in a VM . Knew it was a graphics issue because of display issues . I had to change video settings in Virtual box and reinstall to get it straightened out .

Actually, I tried that too, but I couldn't make that one work either. What I did:

  • I installed linux51-headers
  • Inserted the ISO and ran

But then, while it's running, without any specific messages, it tells me to check /var/log/vboxadd-setup.log and there I see something like this:

/tmp/vbox.0/r0drv/linux/memobj-r0drv-linux.c: In function ‘rtR0MemObjLinuxDoMmap’:
/tmp/vbox.0/r0drv/linux/memobj-r0drv-linux.c:215:58: error: ‘MAP_SHARED’ undeclared (first use in this function); did you mean ‘VM_SHARED’?
         ulAddr = vm_mmap(NULL, R3PtrFixed, cb, fLnxProt, MAP_SHARED | MAP_ANONYMOUS | MAP_FIXED, 0);
/tmp/vbox.0/r0drv/linux/memobj-r0drv-linux.c:215:58: note: each undeclared identifier is reported only once for each function it appears in

I couldn't make things work with VBoxSVGA (I even tried creating a new machine with that, but it doesn't load up), but VBoxVGA seems to be working fine

Thank you @Teek for your suggestion. Although changing to VBoxVGA for my existing VM didn't work (it was showing a blank screen when starting up), but I created a new VM and changed the display to be VBoxVGA, and it works :slight_smile:

As a side note, can you tell me how you have Virtualbox window in a dark theme? :wink:

Question @dalto, does it make a difference if I do it as one unit or separately? I mean, is it just for convenience that you said to do that or it also changes functionality?

happy it helped :slight_smile:
I forgot to mention you might need to reinstall in a new virtualbox. On some of my installs it was enough to uninstall and reinstall the vb guest editions and reboot the virtual machine, in others it wasn't (baseline Arch refused to pull in the correct VM driver)

that's just my dark theme on my Xfce desktop and I use Kvantum (comes preinstalled with Manjaro Xfce) to apply a matching theme. That's usualy enough (if your gtk theme is up to date) for a consistent look.

Can someone please mark the topic as solved? (post #7 & post #8 solution)

1 Like

If you always do them both one after the other it doesn't matter. Although as you point out, it is more convenient to one command than two.

The problem comes if you do yay -Syy and then install software without first upgrading the system. This can result in a partially upgraded broken system. By getting in the habit of using yay -Syyu you avoid the situation where you have updated the database but not the system.


So mhwd needs updating to support the new VBoxSVGA adapter?

If so, has anyone has submitted an issue on this?

No, both VBoxSVGA and VBoxVGA require video-virtualbox and work with Manjaro guest utils.

VBoxSVGA has superceded VBoxVGA in VBox 6, which is still included for legacy purposes.

Issue is when a system is installed with VMVGA VM display adapter, then mhwd auto installs video-vmware, which display scaling does not work.

1 Like

Forum kindly sponsored by