Virtualbox: insufficient permissions for device.

I have marked my phone on the list of usb-devices below guest window. On the phone I have selected "Transfer files" connection mode (as it should be if you run something from PC). But when I'm trying to run something from a guest to the phone: error: insufficient permissions for device.

May be this is related.
Also shared folder doesn't appear on the guest: I tried to set mount point (not sure if this is obligatory, but tried) to guest's home directory. Guest extensions are installed and the user is in vboxsf group (on the guest).

You don't mention what OS you are using?

  • Host
  • Guest

Did you install the Oracle extensions?

Manjaro everywhere.
I did install the extensions.

Interesting, that Ubuntu guest can do it (both shared folder works and transfering to usb).

So does Manjaro - you just have to set it up.

Another thing - if your host USB is USB2 or USB3 you need to set the settings of the guest accordingly. At least that is my experience.

So does Manjaro - you just have to set it up.

Yeah, that's the thing. With Ubuntu guest I didn't have to.

Another thing - if your host USB is USB2 or USB3 you need to set the settings of the guest accordingly.

Don't know what it should be, but on Ubuntu guest it's USB2 and it works, so I did the same on Manjaro guest.

No big deal though, I'm gonna be fine using Ubuntu as the guest.

There is something going on with VirtualBox and it is not only Manjaro - I have tested Arch too and it is the same - so it is something inherited.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by