Virtualbox isn't showing USB devices

First off, let me say that I tried what was shown in this comment:

and it does not show the file he is referring to in my filesystem.
I also ran the groups command as shown in this comment:

and it did not show me as in the group vboxusers.

Edit: when I run the command sudo gpasswd -a $galacton vboxusers(galacton is my username) it comes up with the response gpasswd: user 'vboxusers' does not exist

  1. $USER is an environment variable
    echo $USER
  1. You do not replace USER with your actual username - that won't work.
  2. The group vboxusers only exist on the host
  3. You need to build and install the package virtualbox-ext-oracle to be able to use USB passthrough

I did not know that, I am newer to using Linux and the BASH terminal

I did that, I originally was going to add to the title that I couldn't get it to install but it did eventually. I'm still especially confused that the file that was quoted here wasn't there.

This mention is not a file but a device.

There is a lot of pitfalls using virtual machines and it is important to understand the difference between a host and the guest.

There is also differences between Windows and Linux hosts and guests.

And Manjaro hosts and guests are not like Ubuntu or Windows.

On the host you install virtualbox and if you want to use USB passthrough you need to build and install the extensions package on the host

When you create a guest on a host - it is usually the best option to configure the guest to use VBoxSVGA graphics.

But the mention topic in #technical-issues-and-assistance:tutorials section covers most of it if not all.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by