VirtualBox - Kernel driver not installed (rc=-1908)

Today, I installed Manjaro 18.1 (Cinnamon), and I love it. For the purposes of work, I need to run Windows 10 on VirtualBox, however. After setting it up and running the install of Windows 10 on VirtualBox, however, I immediately get the following error.

kernel-driver

I'm also getting this error message that I copied:

Failed to open a session for the virtual machine Windows 10.

The virtual machine 'Windows 10' has terminated unexpectedly during startup with exit code 1 (0x1).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: MachineWrap
Interface: IMachine {5047460a-265d-4538-b23e-ddba5fb84976}

Please note that I'm also running VirtualBox Version 6.0.12 r133076 (Qt5.6.1).

The kernel running on Manjaro is "Linux 5.2.11-1" (the kernel that came pre-installed with the Manjaro install.

If I need to drop down to a lower kernel, please advise which one, and how to go about doing it. The last time I tried, it would not start after rebooting it, and I had to do a complete system install all over again.

I did some research and found THIS thread, and implemented their solution, but it's not working for me.

Following their advice, I did the following:

  • linux52-virtualbox-host-modules
  • virtualbox-guest-iso

Again, I can't get past this error. Does anybody have a tried and true solution?

Yep @linux-aarhus wrote a tutorial on the topic

5 Likes

There is also a wiki page dedicated to virtualbox: https://wiki.manjaro.org/index.php?title=Virtualbox

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by